Community discussions

MUM Europe 2020
 
jackkitley
just joined
Topic Author
Posts: 9
Joined: Wed Sep 14, 2016 8:25 am

Canon Wireless printer and CAP

Wed Sep 28, 2016 5:38 pm

Hi All

I have a wireless canon printer that i can connect perfectly when the printer is connected to the CAPsMAN router (MAIN) and my mac is connected to the main router as well.

The problem is that the printer is nearer the AP (CAP) and when my mac is connected to the AP as well as the printer they cant find each other.

Why would this be? is there a block that i look for?


# sep/28/2016 16:34:49 by RouterOS 6.37
# software id = P9CW-JBX7
#
/interface bridge
add name=StudyNet
add admin-mac=E4:8D:8C:4B:A1:E8 auto-mac=no name=bridge-local
/interface ethernet
set [ find default-name=ether2 ] comment="D-Link Router in the study" name="Access Point"
set [ find default-name=ether1 ] comment="Port that connects to Netgear" name=Internet
set [ find default-name=ether4 ] comment="All media content stored here" master-port="Access Point" name=Media-Pc
set [ find default-name=ether3 ] comment="Apple Tv / Viera Tv" master-port="Access Point" name="Tv Area"
set [ find default-name=ether5 ] master-port="Access Point" name=ether5-slave-local
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce disabled=no distance=indoors frequency=auto mode=ap-bridge \
ssid=3_stanley_road wireless-protocol=802.11
/interface pptp-client
add connect-to=162.218.235.112 keepalive-timeout=disabled name="IPXCore VPN" password=user=
/ip neighbor discovery
set "Access Point" comment="D-Link Router in the study"
set Internet comment="Port that connects to Netgear" discover=no
set Media-Pc comment="All media content stored here"
set "Tv Area" comment="Apple Tv / Viera Tv"
/caps-man configuration
add datapath.bridge=StudyNet name=StudyNet security.authentication-types=wpa2-psk security.encryption=aes-ccm \
security.group-encryption=aes-ccm security.passphrase=0824145666 ssid=3_stanley_road_AP
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=0824145666 \
wpa2-pre-shared-key=0824145666
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=aes-128-cbc
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
add name=dhcp_pool1 ranges=10.10.10.2-10.10.10.254
add name=dhcp_pool2 ranges=192.168.89.2-192.168.89.254
/ip dhcp-server
add address-pool=dhcp authoritative=yes disabled=no interface=bridge-local name=default
add address-pool=dhcp_pool2 disabled=no interface=StudyNet name=dhcp1
/system logging action
set 1 disk-file-name=log
/caps-man manager
set enabled=yes
/caps-man provisioning
add action=create-dynamic-enabled master-configuration=StudyNet name-prefix=StudyAP
/interface bridge port
add bridge=bridge-local interface="Access Point"
add bridge=bridge-local interface=wlan1
/ip address
add address=192.168.88.1/24 comment="default configuration" interface="Access Point" network=192.168.88.0
add address=192.168.89.1/24 comment="Study DHCP" interface=StudyNet network=192.168.89.0
/ip arp
add address=192.168.88.250 interface=bridge-local mac-address=80:E6:50:14:F1:F8
/ip cloud
set ddns-enabled=yes
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid disabled=no interface=Internet
/ip dhcp-server network
add address=192.168.88.0/24 comment="Default Pool" gateway=192.168.88.1
add address=192.168.89.0/24 comment="Study Pool" gateway=192.168.89.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router
/ip firewall address-list
add address=8.8.8.4 list=GOOGLE_DNS
add address=8.8.8.8 list=GOOGLE_DNS
add address=108.175.32.0/20 list=GOOGLE_DNS
add address=198.38.96.0/19 list=GOOGLE_DNS
add address=198.45.48.0/20 list=GOOGLE_DNS
add address=185.2.220.0/22 list=GOOGLE_DNS
add address=23.246.0.0/18 list=GOOGLE_DNS
add address=37.77.184.0/21 list=GOOGLE_DNS
add address=45.57.0.0/17 list=GOOGLE_DNS
add address=192.168.88.248 list=NETWORK_DEVICES
add address=192.168.88.249 list=NETWORK_DEVICES
add address=192.168.88.253 list=NETWORK_DEVICES
add address=192.168.88.254 list=NETWORK_DEVICES
add address=192.168.88.51 list=NETWORK_DEVICES
/ip firewall filter
add action=drop chain=forward comment="netflix drop rules" disabled=yes dst-address-list=GOOGLE_DNS
add action=accept chain=input comment="default configuration" protocol=icmp
add action=accept chain=input comment="default configuration" connection-state=established,related
add action=accept chain=input comment=winbox dst-port=8291 protocol=tcp
add action=drop chain=input comment="default configuration --- place rules above here " in-interface=Internet
add action=fasttrack-connection chain=forward comment="default configuration" connection-state=established,related
add action=accept chain=forward comment="default configuration" connection-state=established,related
add action=drop chain=forward comment="default configuration" connection-state=invalid
add action=drop chain=forward comment="default configuration" connection-nat-state=!dstnat connection-state=new in-interface=Internet
/ip firewall mangle
add action=mark-routing chain=prerouting disabled=yes new-routing-mark=IPXCore passthrough=yes src-address-list=NETWORK_DEVICES
/ip firewall nat
add action=dst-nat chain=dstnat comment="netflix dns redirect" disabled=yes dst-address-list=GOOGLE_DNS to-addresses=192.168.88.1
add action=masquerade chain=srcnat comment="default configuration" out-interface=Internet
add action=masquerade chain=srcnat disabled=yes out-interface="IPXCore VPN"
add action=masquerade chain=srcnat src-address=10.10.10.0/24
/ip route
add disabled=yes distance=1 gateway="IPXCore VPN" routing-mark=IPXCore
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www port=4080
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/system clock
set time-zone-name=Africa/Johannesburg
/system identity
set name=Garage
/system leds
set 5 interface=wlan1 leds=""
/system logging
add action=remote topics=dhcp
/system routerboard settings
set cpu-frequency=650MHz protected-routerboot=disabled
/tool mac-server
set [ find default=yes ] disabled=yes
add interface="Access Point"
add interface="Tv Area"
add interface=Media-Pc
add interface=ether5-slave-local
add interface=wlan1
add interface=bridge-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface="Access Point"
add interface="Tv Area"
add interface=Media-Pc
add interface=ether5-slave-local
add interface=wlan1
add interface=bridge-local

Thanks
 
uldis
MikroTik Support
MikroTik Support
Posts: 3428
Joined: Mon May 31, 2004 2:55 pm

Re: Canon Wireless printer and CAP

Wed Sep 28, 2016 6:25 pm

you need to enable client to client forwarding for the CAPsMAN configuration as it is disabled by default.
 
jackkitley
just joined
Topic Author
Posts: 9
Joined: Wed Sep 14, 2016 8:25 am

Re: Canon Wireless printer and CAP

Wed Sep 28, 2016 6:54 pm

Thanks for your reply.

Is this easy to do?
You do not have the required permissions to view the files attached to this post.
 
jackkitley
just joined
Topic Author
Posts: 9
Joined: Wed Sep 14, 2016 8:25 am

Re: Canon Wireless printer and CAP

Wed Sep 28, 2016 7:33 pm

you need to enable client to client forwarding for the CAPsMAN configuration as it is disabled by default.
I got it working thanks. I can now connect my mac to the AP and ptinter to the AP and i am able to use it.

The problem that im having now is that i want the printer to remain on the AP (CAP) but i want to join my MAIN router wifi and be able to communicate with the printer. How am i able to do this as this is not working currently.

Thanks
 
jackkitley
just joined
Topic Author
Posts: 9
Joined: Wed Sep 14, 2016 8:25 am

Re: Canon Wireless printer and CAP

Wed Sep 28, 2016 7:59 pm

Sorted! All works now.
You do not have the required permissions to view the files attached to this post.
 
Lilarcor
newbie
Posts: 28
Joined: Sun Oct 08, 2017 3:16 am

Re: Canon Wireless printer and CAP

Sun Oct 08, 2017 3:23 am

I experienced the same issue. Enabled the client to client forwarding helped for wireless client accessing the wireless printer, but the problem still exists for wired devices accessing the printer unless I enable the local FW as well. Does anyone have a solution ?
 
DaMirotika
just joined
Posts: 1
Joined: Sat Jan 04, 2020 2:00 pm

Re: Canon Wireless printer and CAP

Fri Feb 14, 2020 11:15 am

Hello, i've got the same issue here as well.

My Setup:
1x RB2011UAS > running CAPsMAN
2x RBcAPGi-5acD2nD with enabled WLan Roaming
1x Canon ip7250 connected via Wireless (IEEE 802.11g)

It works but until the Printer get's the Job, it toke 4 Ever (at least 2 min)

does anybody have an idea?

Who is online

Users browsing this forum: Google [Bot], jebz and 79 guests