Community discussions

MikroTik App
 
rohitojha
just joined
Topic Author
Posts: 3
Joined: Mon Mar 21, 2016 3:52 pm

IPv6 Implementation in Dual Stack Environment

Thu Oct 27, 2016 5:37 pm

Dear All,

I am new to the forum , hence pardon me if I am unable to express my self in format expected.

We are currently deploying the IPv6 in our network . The configuration for the same are as follows

[rohitojha@MikroTik] > ipv6 export
# oct/27/2016 19:25:39 by RouterOS 6.37.1
# software id = LT02-N6Y3
#
/ipv6 address
add address=2404:1f00:0:98::10 advertise=no interface=ether8

[rohitojha@MikroTik] > ipv6 route export
# oct/27/2016 19:59:20 by RouterOS 6.37.1
# software id = LT02-N6Y3
#
/ipv6 route
add disabled=yes distance=1 gateway=2404:1f00:0:98::1

[rohitojha@MikroTik] > ip dns print
servers: 2001:4860:4860::8844,2001:4860:4860::8888
dynamic-servers:
allow-remote-requests: no
max-udp-packet-size: 4096
query-server-timeout: 2s
query-total-timeout: 10s
cache-size: 2048KiB
cache-max-ttl: 1w
cache-used: 9KiB
[rohitojha@MikroTik] > system resource print
uptime: 3h28m51s
version: 6.37.1 (stable)
build-time: Sep/30/2016 10:28:41
free-memory: 15.6GiB
total-memory: 15.9GiB
cpu: tilegx
cpu-count: 36
cpu-frequency: 1200MHz
cpu-load: 0%
free-hdd-space: 859.1MiB
total-hdd-space: 1024.0MiB
architecture-name: tile
board-name: CCR1036-8G-2S+
platform: MikroTik

The above mikrotik is connected from the parent Mikrotik , who configuration are as follows
rohitojha@acn-195] > ip dhcp-server print
Flags: X - disabled, I - invalid
# NAME INTERFACE RELAY ADDRESS-POOL LEASE-TIME ADD-ARP
0 ACN-810 810 ACN-810-HotSpot 1d
1 dhcp1 803 ACN-803-HotSpot 1d
2 dhcp6 811 dhcp_pool1 1d

rohitojha@acn-195] > ipv6 pool print
Flags: D - dynamic
# NAME PREFIX PREFIX-LENGTH EXPIRES-AFTER
0 ipv6-pool 2404:1f00:0:98::/64 64

[rohitojha@acn-195] > system resource print
uptime: 5w7h46m37s
version: 6.33.5 (stable)
build-time: Dec/28/2015 09:13:47
free-memory: 1808.3MiB
total-memory: 1893.7MiB
cpu: Intel(R)
cpu-count: 8
cpu-frequency: 2327MHz
cpu-load: 8%
free-hdd-space: 80.4MiB
total-hdd-space: 127.0MiB
write-sect-since-reboot: 11888512
write-sect-total: 11888512
architecture-name: x86
board-name: x86
platform: MikroTik

Now coming to the problem. I am able to get internet when I am assigning the static IP address in the first router . Also during this time if i desiable the IPv4 address in the first router I am not getting connected . I can ping the IPv6 address of the google/ FB website . But not through domain.

Kindly need clarification on the few details
1: How to get the IPv6 address in the DHCP in PPPOE user
2: why am i losing the ping to domain name when I am able to ping ipv6 corresponding website
3: If any one can suggest a complete configuration with me, as I am new to Miktotik.

Please let me know if any additional details are needed.

Regards
Rohitojha
 
rohitojha
just joined
Topic Author
Posts: 3
Joined: Mon Mar 21, 2016 3:52 pm

Re: IPv6 Implementation in Dual Stack Environment

Fri Oct 28, 2016 12:17 pm

Hi,

Any body who can help me in implementing IPv6 for PPPoE users in Dual Stack environment

Thanks in advance
 
mbeauverd
just joined
Posts: 18
Joined: Mon Oct 03, 2016 10:46 am

Re: IPv6 Implementation in Dual Stack Environment

Sat Oct 29, 2016 9:32 am

I am new as well to Mikrotik, but I have a good working system using Dual stack and PPoE, so I share my config with you.
I hope you can find good idea for your setup... 8)
/interface bridge
add disabled=yes name=LO
add name=lan1
add name=lan2
/interface ethernet
set [ find default-name=ether1 ] name=1_Switch_Studio
set [ find default-name=ether2 ] master-port=1_Switch_Studio name=2_VOIP
set [ find default-name=ether3 ] name=3_OLD_Wifi_AP
set [ find default-name=ether4 ] name=4_WAN
set [ find default-name=ether5 ] master-port=1_Switch_Studio name=5_WifiAP
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode \
    band=2ghz-b/g/n channel-width=20/40mhz-Ce country=switzerland \
    disconnect-timeout=10s frame-lifetime=10 frequency=2427 hw-protection-mode=\
    rts-cts hw-retries=15 mode=ap-bridge wireless-protocol=802.11 wmm-support=\
    enabled
set [ find default-name=wlan2 ] adaptive-noise-immunity=ap-and-client-mode \
    band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee country=switzerland \
    disconnect-timeout=10s frame-lifetime=10 hw-protection-mode=rts-cts \
    hw-retries=15 mode=ap-bridge wmm-support=enabled
/interface pppoe-client
add add-default-route=yes disabled=no interface=4_WAN name=Wifx_PPoE password=\
    [hidden] use-peer-dns=yes user=[hidden]

/ip pool
add name=dhcp_pool1 ranges=172.20.20.20-172.20.20.50
add name=dhcp_pool2 ranges=172.20.21.20-172.20.21.50
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=lan1 lease-time=1d name=dhcp1
add address-pool=dhcp_pool3 disabled=no interface=lan2 lease-time=1d name=dhcp2
/queue tree
add name="Internetwork Control" packet-mark=priority_2 parent=Wifx_PPoE \
    priority=2
add name=Critical packet-mark=priority_3 parent=Wifx_PPoE priority=3
add name="Flash Override" packet-mark=priority_4 parent=Wifx_PPoE priority=4
add name=Flash packet-mark=priority_5 parent=Wifx_PPoE priority=5
add name=Immediate packet-mark=priority_6 parent=Wifx_PPoE priority=6
add name=Priority packet-mark=priority_7 parent=Wifx_PPoE priority=7
add name=Routine packet-mark=priority_8 parent=Wifx_PPoE
add name="Network Control" packet-mark=priority_1 parent=Wifx_PPoE priority=1 \
    queue=default
/snmp community
set [ find default=yes ] addresses=::/0,0.0.0.0/0
/system logging action
set 1 disk-stop-on-full=yes
add name=Observium remote=172.20.0.17 target=remote
/caps-man manager
set ca-certificate=auto certificate=auto enabled=yes
/interface bridge port
add bridge=lan1 interface=1_Switch_Studio
add bridge=lan2 interface="cap1 WW"
add bridge=lan2 interface="cap2 WW"
add bridge=lan2 interface=3_OLD_Wifi_AP
/ip address
add address=172.20.20.254/24 interface=lan1 network=172.20.20.0
add address=172.20.21.254/24 interface=lan2 network=172.20.21.0
/ip dhcp-client
add add-default-route=no dhcp-options=hostname,clientid disabled=no interface=\
    5_WifiAP use-peer-dns=no use-peer-ntp=no
/ip dhcp-server network
add address=172.20.20.0/24 dns-server=172.20.20.254 gateway=172.20.20.254
add address=172.20.21.0/24 dns-server=172.20.21.254 gateway=172.20.21.254
/ip dns
set allow-remote-requests=yes
/ip firewall address-list
add address=172.20.0.0-172.20.19.254 list=CQ
add address=172.20.30.0.0-172.20.80.254 list=CQ
add address=10.0.0.0/8 list=local
add address=172.16.0.0/12 list=local
add address=192.168.0.0/16 list=local
/ip firewall filter
add action=drop chain=input dst-port=53 in-interface=Wifx_PPoE protocol=tcp \
    src-address-list=!local
add action=drop chain=input dst-address-list=!local dst-port=23 protocol=tcp \
    src-port=""
add action=drop chain=input dst-address-list=!local dst-port=22 protocol=tcp
add action=drop chain=input dst-address-list=!local dst-port=21 protocol=tcp
/ip firewall mangle
add action=set-priority chain=postrouting comment="Respect DSCP tagging" \
    new-priority=from-dscp-high-3-bits passthrough=yes
add action=set-priority chain=postrouting comment="Prioritize ACKs" \
    new-priority=2 packet-size=0-123 passthrough=yes protocol=tcp tcp-flags=ack
add action=set-priority chain=postrouting comment=\
    "Set Pri 8 on packets with no tag at all" dscp=0 new-priority=8 \
    passthrough=yes priority=0
add action=mark-packet chain=postrouting comment=pri_1 new-packet-mark=\
    priority_1 passthrough=no priority=1
add action=mark-packet chain=postrouting comment=pri_2 new-packet-mark=\
    priority_2 passthrough=no priority=2
add action=mark-packet chain=postrouting comment=pri_3 new-packet-mark=\
    priority_3 passthrough=no priority=3
add action=mark-packet chain=postrouting comment=pri_4 new-packet-mark=\
    priority_4 passthrough=no priority=4
add action=mark-packet chain=postrouting comment=pri_5 new-packet-mark=\
    priority_5 passthrough=no priority=5
add action=mark-packet chain=postrouting comment=pri_6 new-packet-mark=\
    priority_6 passthrough=no priority=6
add action=mark-packet chain=postrouting comment=pri_7 new-packet-mark=\
    priority_7 passthrough=no priority=7
add action=mark-packet chain=postrouting comment=pri_8 new-packet-mark=\
    priority_8 passthrough=no priority=8
/ip firewall nat
add action=masquerade chain=srcnat dst-address-list=!local src-address-list=\
    local
/ipv6 address
add from-pool=ipv6test interface=lan1
add from-pool=ipv6test interface=lan2
add disabled=yes from-pool=ipv6test interface=LO
/ipv6 dhcp-client
add interface=Wifx_PPoE pool-name=ipv6test request=prefix
/ipv6 firewall filter
add action=accept chain=input comment=ICMPv6 protocol=icmpv6
add action=accept chain=input comment="DHCPv6 client" dst-port=546 \
    in-interface=Wifx_PPoE protocol=udp
add action=accept chain=input comment=Winbox dst-port=8291 protocol=tcp
add action=accept chain=input comment="SNMP IN" src-address=\
    2001:872:ff76:1000::17/128
add action=drop chain=input comment="Drop the rest"
add action=accept chain=forward comment="Accept forward" in-interface=lan1
add action=accept chain=forward comment="Accept established" connection-state=\
    established,related out-interface=lan1
add action=drop chain=forward comment="Drop forward" out-interface=lan1
add action=accept chain=forward comment="Accept forward" in-interface=lan2
add action=accept chain=forward comment="Accept established" connection-state=\
    established,related out-interface=lan2
add action=drop chain=forward comment="Drop forward" out-interface=lan2
add action=accept chain=output comment="Accept output"
/ipv6 firewall mangle
add action=change-dscp chain=postrouting comment="Prioritize ACKs" new-dscp=23 \
    packet-size=0-123 passthrough=yes protocol=tcp tcp-flags=fin
add action=change-dscp chain=postrouting comment=\
    "Set DSCP 0 on packets with no tag at all" ingress-priority=0 new-dscp=0 \
    passthrough=yes priority=0
/ipv6 nd
add advertise-dns=yes hop-limit=64 interface=lan1
add advertise-dns=yes hop-limit=64 interface=lan2
/system clock
set time-zone-name=Europe/Zurich
/system logging
add action=disk topics=pppoe
add action=Observium topics=critical
add action=Observium topics=error
add action=Observium topics=pppoe
add action=Observium topics=warning
/system ntp client
set primary-ntp=172.20.0.1
/system routerboard settings
set cpu-frequency=720MHz protected-routerboot=disabled
 
tomtom80
newbie
Posts: 43
Joined: Sun Jan 06, 2008 12:48 am

Re: IPv6 Implementation in Dual Stack Environment

Mon Sep 18, 2017 10:23 pm

I am new as well to Mikrotik, but I have a good working system using Dual stack and PPoE, so I share my config with you.
I hope you can find good idea for your setup... 8)
That seems to be the config of the client. Can you post the server config? How does the server assign IPv6 address to the pppoe clients?

Regards.
 
mbeauverd
just joined
Posts: 18
Joined: Mon Oct 03, 2016 10:46 am

Re: IPv6 Implementation in Dual Stack Environment

Mon Sep 18, 2017 10:51 pm

I dont have the server config ... Sorry ...

Who is online

Users browsing this forum: DanMos79 and 67 guests