Community discussions

 
WirelessRudy
Forum Guru
Forum Guru
Topic Author
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Possible bug in CCR1016-12G v6.37.1

Sun Nov 06, 2016 10:07 pm

We are running this CCR with some 650 PPPoE tunnels and up to 320Mbps aggregated traffic as our main gateway to the internet.
The machine runs fine for months and 3 weeks ago updated to 6.37.1

Tonight, while just looking at my Dude (that runs on a virtual CHR device only connecte by ether to this CCR) I noticed I could not login to my main router from within the Dude.
Then I tried to login by winbox from my PC (on a separate LAN incoming another port of this CCR), no result.
Then I treid to mac-winbox login from same PC. No result.
I then logged into a adjacent switch (sits between office network (=my pc) and this CCR) and here neigbours doesn't show the CCR on its normal port. Luckily some old vlan (for some tests) was also running and here I could 'see' the CCR and could login to the box by mac.
I logged in and checked the log. Nothing strange to be found. I checked the firewall, the IP address, the ports everything exactly normal....

I then called my assistent that has access to the CCR through a tunnel that comes in through a complete different port (vpls tunnel) and he also could not log in.
He then also noted that (like I also noted now) that Dude didn't work anymore.

We were both puzzled what happened. Internet for all clients including ourselves was still running fine! (So something on the 'input' chain must prevent access to the CCR.

He tried to login by winbox through his PPPoE tunnel and got "snmp,warning timeout while waiting for program 20" message?????


Anyway, he could not understand why Dude didn't run on an other device (PC running 2 CHR machines, one of them runs only Dude) but he managed at least to reboot this CHR. (Took almost a minute before the reboot command was accepted)
After that the Dude came back up both with him as me.

One minute later without any further interference or actions from out sides suddenly all access to the CCR came back!
All workes fine again.....

WHAT HAPPENED???

The log shows nothing. No failed login attempts, nothing strange. Only the usual connecting and dropping of PPPoE tunnels.

We are puzzled! Is this going to happen again? Anybody has seen the same or similar?


The network kept running but loosing all control and all monitor is almost the same as loosing the whole network......
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.

Who is online

Users browsing this forum: No registered users and 55 guests