Community discussions

 
waynemillskidals
just joined
Topic Author
Posts: 15
Joined: Sat Dec 03, 2016 12:51 pm

Simple home setup - wireless roaming between APs

Sat Dec 03, 2016 1:01 pm

Hi

I have two hAP units,

One is doing ppoe on my VDSL modem but also acting as a wireless access point

I have another access point on a power line adapter at the other end of the house providing wireless access - however what I want is for them to do wireless roaming so clients seamlessly goto the strongest access point when in range

Can someone advise what would be the best way to achieve this?
 
JB172
Member
Member
Posts: 306
Joined: Fri Jul 24, 2015 3:12 pm
Location: AWMN

Re: Simple home setup - wireless roaming between APs

Sun Dec 04, 2016 12:07 am

In both hAPs you can do the following:
/interface wireless access-list
add authentication=no forwarding=no interface=AP signal-range=-120..-80
add interface=AP signal-range=-79..120
where AP is the name of your WLAN
 
waynemillskidals
just joined
Topic Author
Posts: 15
Joined: Sat Dec 03, 2016 12:51 pm

Re: Simple home setup - wireless roaming between APs

Sun Dec 04, 2016 9:29 am

thanks for the reply..

From what I can see what you suggest would be kicking a client of if its signal is poor? is this the best way to achieve what I am doing? Is there no seamless layer 2 handover configuration using WDS / MESH or Bridging which would be better?

Thanks for any advice
 
ste
Forum Guru
Forum Guru
Posts: 1813
Joined: Sun Feb 13, 2005 11:21 pm

Re: Simple home setup - wireless roaming between APs

Sun Dec 04, 2016 9:46 am

thanks for the reply..

From what I can see what you suggest would be kicking a client of if its signal is poor? is this the best way to achieve what I am doing? Is there no seamless layer 2 handover configuration using WDS / MESH or Bridging which would be better?

Thanks for any advice
The best way is the wireless client doing this in an intelligent way.
You can influence the behavior for windows: http://www.intel.com/content/www/us/en/ ... 05546.html

There are APs which habe some mechanisms for seamless roaming. But for seamless roaming APs have to use the same Frequency. So you get interference problems where they overlap.
 
andriys
Forum Guru
Forum Guru
Posts: 1187
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: Simple home setup - wireless roaming between APs

Sun Dec 04, 2016 5:59 pm

From what I can see what you suggest would be kicking a client of if its signal is poor? is this the best way to achieve what I am doing? Is there no seamless layer 2 handover configuration using WDS / MESH or Bridging which would be better?
Roaming is always a function of client in WiFi networks, i.e. it's client who always decides when to roam and what AP to connect to. What other vendors refer to as a seamless roaming (zero-handoff, single channel architecture, etc.) is, technically, not a roaming, but rather a trick to force client to believe it always speaks to the same single AP (i.e. does not roam at all), while in fact different radios may talk to the client at different times/locations. Mikrotik does not support such tricks (at least as of now).

Kicking clients off is not the best way to force client to roam to a different AP. Some clients may behave rather poorly in such conditions, introducing noticeable delays and disconnections when being kicked off. A better approach would be to reduce the transmit power of your APs, which will make your client natively roam earlier.
 
waynemillskidals
just joined
Topic Author
Posts: 15
Joined: Sat Dec 03, 2016 12:51 pm

Re: Simple home setup - wireless roaming between APs

Sun Dec 04, 2016 6:03 pm

Thanks for all the responses.

Just to say I tried this method

/interface wireless access-list
add authentication=no forwarding=no interface=AP signal-range=-120..-80
add interface=AP signal-range=-79..120

And tested with my samsung s7 whilst moving around the house, when it performs much better and when it connects to the next AP I only lose 1 ICMP Ping during the transition.
 
luca1234567
just joined
Posts: 3
Joined: Tue May 15, 2018 1:27 am

Re: Simple home setup - wireless roaming between APs

Fri Feb 22, 2019 2:54 pm

I read now this post.

I would have a doubt, it would not be more correct to use -81 instead of -79
/interface wireless access-list
add authentication=no forwarding=no interface=AP signal-range=-120..-80
add interface=AP signal-range=-81..120

Correct ?
Last edited by luca1234567 on Sat Feb 23, 2019 1:27 am, edited 1 time in total.
 
2frogs
Long time Member
Long time Member
Posts: 540
Joined: Fri Dec 03, 2010 1:38 am

Re: Simple home setup - wireless roaming between APs

Sat Feb 23, 2019 1:03 am

No, -79 would be correct. -81 will fall between -120 and -80 and therefore conflict.

Who is online

Users browsing this forum: MSN [Bot] and 101 guests