Community discussions

MUM Europe 2020
 
trampen
just joined
Topic Author
Posts: 12
Joined: Tue Mar 07, 2006 10:06 pm
Location: Poland

Telnet hotspot's user authentication - how to use it?

Sat Oct 21, 2006 10:57 pm

Hi!

Regarding to description from 2.9 OS manual:
"The HTTP PAP method also makes it possible to authenticate by requesting the page
/login?username=username&password=password . In case you want to log in using telnet connection,
the exact HTTP request would look like that: GET
/login?username=username&password=password HTTP/1.0 (note that the request is
case-sensitive)"

I would like to use telnet option to authenticate user.
First of all I have established radio channel and IP address assigned. Then in my Win XP I run command:

telnet 10.4.6.126 80
(where 10.4.6.126 is IP address assigned to wlan1 MT's wireless interface)

then I paste:
GET /login?username=username&password=password HTTP/1.0

Unfortunately it returns error:

"HTTP/1.0 503 unknown method
Connection: close
Content-Length: 119
Date: Sat, 21 Oct 2006 19:41:46 GMT
Expires: Thu, 01 Jan 1970 00:00:00 GMT

<html>
<head><title>Error 503: unknown method</title></head>
<body>
<h1>Error 503:
unknown method</h1>
</body>
</html>"

What do I make wrong that there appear such error?

Thanks for any advice.
Marek
 
User avatar
tneumann
Member
Member
Posts: 394
Joined: Sat Apr 16, 2005 6:38 pm
Location: Germany

Sat Oct 21, 2006 11:43 pm

Do you have login-by=http-pap,... enabled in the hotspot profile for that hotspot?

--Tom
 
trampen
just joined
Topic Author
Posts: 12
Joined: Tue Mar 07, 2006 10:06 pm
Location: Poland

Sun Oct 22, 2006 4:28 am

login-by=http-pap is active of course

Users are successfully authenticated based website login/password but are not able to login via telnet service.

Marek

Who is online

Users browsing this forum: hamedta, jatoledano and 117 guests