Community discussions

MikroTik App
just joined
Topic Author
Posts: 5
Joined: Mon Dec 19, 2016 1:14 pm

ipv6 /56 split to /64

Wed Dec 21, 2016 11:23 am


I'm trying to configure ipv6 and I'm having some issues.

I'm pretty new to ipv6

My Isp provides me with a /56 ipv6 subnet. He does not provide anything else, no SLAAC, no dhcp v6, just static range assigned and terminated to my network port.

I'd like to split that into multiple /64 subnets
Internally on my ccr traffic between the multiple /64 works fine.
My router is able to ping and access the internet through ipv6.
My different lan clients are not able to access the internet through ivp6.
The different lan clients are however able to reach different subnets created as well as the different gateways (lans / wan) defined.

How do I route traffic from a /56 to a /64 and vice versa.
I've tried everything usefull that I've already found on this forum but to no avail.
The closest post I've found with similar issues is the following but without a solution to the problem ... v6#p523293

at this point I've set up an ip adress on the wan and ip addresses on different lans.

the range assigned xxxx:xxxx:6:400::1/56

Ip address
/ipv6 address print
 #    ADDRESS                                     FROM-POOL INTERFACE           ADVERTISE
 0  G xxxx:xxxx:6:410:e68d:8cff:fe3d:38e5/64                 LAN4        yes      
 1  G xxxx:xxxx:6:402:e68d:8cff:fe3d:38e9/64                 LAN3        yes      
 2  G xxxx:xxxx:6:404:e68d:8cff:fe3d:38e9/64                 LAN2        yes      
 3  G xxxx:xxxx:6:406:e68d:8cff:fe3d:38e9/64                 LAN1        yes      
 4  G xxxx:xxxx:6:401::255/64                                         WAN          no  
routing table
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, o - ospf, b - bgp, U - unreachable 
 #      DST-ADDRESS              GATEWAY                  DISTANCE
 0 A S  ::/0                     fe80::2d0:xxxx       0
 1 X S  ::/0                     xxxx:xxxx:6:400::1               0
 2 A SU xxxx:xxxx:6:400::/56                                   1
 3 ADC  xxxx:xxxx:6:401::/64      WAN                     0
 4 ADC  xxxx:xxxx:6:402::/64      LAN3                    0
 5 ADC  xxxx:xxxx:6:404::/64      LAN2                    0
 6 ADC  xxxx:xxxx:6:406::/64      LAN1                    0
 7 ADC  xxxx:xxxx:6:410::/64      LAN4                    0
Flags: X - disabled, I - invalid, * - default 
 0  * interface=all ra-interval=3m20s-10m ra-delay=3s mtu=unspecified reachable-time=unspecified retransmit-interval=unspecified ra-lifetime=30m 
      hop-limit=unspecified advertise-mac-address=yes advertise-dns=no managed-address-configuration=no other-configuration=no 
I've tried setting default router ::/0 to the xxxx:xxxx:6:400::1 or the the link local address. (the ccr can reach the internet on either gateway adress...)
I've also tried defining or not defining xxxx:xxxx:6:400::/56 as unreachable.

Neither of these options makes a difference.

At this point there are no firewall rules that are blocking anything.

I've tried playing with Neighbor Discovery but that doesn't change anything either.

So how can I translate the /56 to a /64 range and back so that my routing works ?

Member Candidate
Member Candidate
Posts: 115
Joined: Tue Oct 04, 2011 1:46 pm

Re: ipv6 /56 split to /64

Wed Dec 21, 2016 2:58 pm

The one thing that stands out is that there is no interface specified in the default route. Such as:
 /ipv6 route> print detail
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, o - ospf, b - bgp, U - unreachable
 0 ADS  dst-address=::/0 gateway=fe80::201:5cff:fe96:4c46%ether1-gateway gateway-status=fe80::201:5cff:fe96:4c46%ether1-gateway reachable distance=1 scope=30 target-scope=10
Also, unless you need the router itself to be directly accessible from the internet, there is no point in putting the 401::/64 on the WAN interface; link-local is fine.

Who is online

Users browsing this forum: Jotne, onnoossendrijver and 145 guests