Community discussions

MikroTik App
 
proximus
Member Candidate
Member Candidate
Topic Author
Posts: 113
Joined: Tue Oct 04, 2011 1:46 pm

RB750Gr3 - OpenVPN Client - Works on other RB models, but not on this one.

Tue Jan 03, 2017 4:25 am

I have been attempting to use the OpenVPN Client on the RB750Gr3, per this setup: https://support.hidemyass.com/hc/en-us/ ... ient-Setup

This works perfectly on a RB2011.
This works perfectly on a hAP Lite (RB941-2nD).

This does not work on a RB750Gr3.
* The OVPN Client establishes the tunnel and obtains an IP address.
* The OVPN tunnels tx/rx packets increment.
If I do a packet capture on the tunnel interface, I see the LAN client request and the responses from the internet hosts. But, the responses never make it back to the LAN client. The packet capture shows a huge amount of retransmissions and "spurious retransmissions" of packets within ms of each other, in Wireshark. It gives the appearance of packets looping and never exiting back out the LAN interface.

Has anybody else had success with this setup on this specific RB?
Is it possible the multi-core, multi-thread architecture of the RB750Gr3 is causing the issues???

I have tried this on 6.37.3 and 6.38.

Yes, I have disabled FastTrack, all my other mangle rules and queues, etc, etc.
 
snowdogging
just joined
Posts: 7
Joined: Tue Dec 20, 2016 6:23 pm

Re: RB750Gr3 - OpenVPN Client - Works on other RB models, but not on this one.

Wed Jan 04, 2017 7:49 pm

What's your MTU size?
 
proximus
Member Candidate
Member Candidate
Topic Author
Posts: 113
Joined: Tue Oct 04, 2011 1:46 pm

Re: RB750Gr3 - OpenVPN Client - Works on other RB models, but not on this one.

Wed Jan 04, 2017 8:42 pm

The default 1500 MTU works fine on the RB2011 and hAP Lite. But, just to be sure, I have already tried various 1300 and 1400 MTU sizes on the RB750Gr3 with no change in behavior.

Here is a functional tunnel on the hAP:
mtu.jpg
You do not have the required permissions to view the files attached to this post.
 
majestic
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Mon Dec 05, 2016 11:19 am

Re: RB750Gr3 - OpenVPN Client - Works on other RB models, but not on this one.

Wed Jan 04, 2017 10:18 pm

I have been attempting to use the OpenVPN Client on the RB750Gr3, per this setup: https://support.hidemyass.com/hc/en-us/ ... ient-Setup

This works perfectly on a RB2011.
This works perfectly on a hAP Lite (RB941-2nD).

This does not work on a RB750Gr3.
* The OVPN Client establishes the tunnel and obtains an IP address.
* The OVPN tunnels tx/rx packets increment.
If I do a packet capture on the tunnel interface, I see the LAN client request and the responses from the internet hosts. But, the responses never make it back to the LAN client. The packet capture shows a huge amount of retransmissions and "spurious retransmissions" of packets within ms of each other, in Wireshark. It gives the appearance of packets looping and never exiting back out the LAN interface.

Has anybody else had success with this setup on this specific RB?
Is it possible the multi-core, multi-thread architecture of the RB750Gr3 is causing the issues???

I have tried this on 6.37.3 and 6.38.

Yes, I have disabled FastTrack, all my other mangle rules and queues, etc, etc.
Hi there,

I have the exact same router as you and I am connected with OpenVPN AES-256-CBC to work without any problems.

This is the guide which I followed to set this up which worked perfectly.

https://support.hidemyass.com/hc/en-us/ ... ient-Setup

Company I work for isn't hide my ass but their guide was clear and easy to follow/adapt to own openvpn config settings.
[simon@RB750Gr3_2] /system resource> print 
                   uptime: 2d7h48m30s
                  version: 6.37.3 (stable)
               build-time: Nov/28/2016 11:11:46
         factory-software: 6.36.1
              free-memory: 202.8MiB
             total-memory: 256.0MiB
                      cpu: MIPS 1004Kc V2.15
                cpu-count: 4
            cpu-frequency: 880MHz
                 cpu-load: 0%
           free-hdd-space: 6.3MiB
          total-hdd-space: 16.0MiB
  write-sect-since-reboot: 3668
         write-sect-total: 4656
               bad-blocks: 0%
        architecture-name: mmips
               board-name: hEX
                 platform: MikroTik
 5  R  name="WORK-ADMIN-VPN" type="ovpn-out" mtu=1500 actual-mtu=1500 mac-address=02:XX:3A:XX:XX:04 fast-path=no last-link-down-time=jan/02/2017 13:23:58 
       last-link-up-time=jan/02/2017 13:23:59 link-downs=3 
HTH
 
proximus
Member Candidate
Member Candidate
Topic Author
Posts: 113
Joined: Tue Oct 04, 2011 1:46 pm

Re: RB750Gr3 - OpenVPN Client - Works on other RB models, but not on this one.

Wed Jan 04, 2017 10:31 pm

Cool, thanks. That seems to rule out something platform specific to the RB750Gr3. Guess I'll need to strip the config down a bit more and see if it will kick in.

Oh well, the little hAP Lite does 17Mbps with OVPN .. ok for proof-of-concept.
 
majestic
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Mon Dec 05, 2016 11:19 am

Re: RB750Gr3 - OpenVPN Client - Works on other RB models, but not on this one.

Thu Jan 05, 2017 10:31 am

Cool, thanks. That seems to rule out something platform specific to the RB750Gr3. Guess I'll need to strip the config down a bit more and see if it will kick in.

Oh well, the little hAP Lite does 17Mbps with OVPN .. ok for proof-of-concept.
If you purge your openVPN related bits from the firewall and other related bits then follow the guide I posted, it should work.

Best of luck and let us know if any of us can try and help you further.

Who is online

Users browsing this forum: Google [Bot] and 83 guests