Page 1 of 1

[BUG] Watchdog timer does not disable properly

Posted: Wed Jan 25, 2017 10:05 am
by Wyz4k
Hi there,

Just found a bug with the watch dog timer that is present in v6.38 at least.

Setup:
Set a watch dog timer to ping an address, say 8.8.8.8. Tick enable watchdog timer.
So far this works as intended.
However if you go back and untick watchdog timer, it still resets if it's unable to ping 8.8.8.8.
You have to remove the IP as well to get it to stop resetting.

Re: [BUG] Watchdog timer does not disable properly

Posted: Mon Apr 08, 2019 4:58 pm
by sinisa
This is still the same in 6.44.2

Hi there,

Just found a bug with the watch dog timer that is present in v6.38 at least.

Setup:
Set a watch dog timer to ping an address, say 8.8.8.8. Tick enable watchdog timer.
So far this works as intended.
However if you go back and untick watchdog timer, it still resets if it's unable to ping 8.8.8.8.
You have to remove the IP as well to get it to stop resetting.

Re: [BUG] Watchdog timer does not disable properly

Posted: Fri Jul 12, 2019 11:13 pm
by Phyllo
Not to bring a dead thread to life again, but I have to echo that this bug definitely still exists.

Re: [BUG] Watchdog timer does not disable properly

Posted: Sun Sep 29, 2019 3:19 pm
by ovidiu
6.45.3 I have this problem too

Re: [BUG] Watchdog timer does not disable properly

Posted: Sun Sep 29, 2019 8:42 pm
by Zacharias
That is no Bug...

If you enable the watchdog timer then if the device for some reason gets unresponsive for a minute it will recover by rebooting it self..
If you set a watch address, if it wont reply 6 sequential pings the device will also auto reboot.... if you don't set a watch address then this feature is disabled.

As you can see those are two different features...

https://wiki.mikrotik.com/wiki/Manual:System/Watchdog