Page 1 of 1

Winbox empty (Resolved)

Posted: Thu Feb 02, 2017 9:38 am
by himvas
I have RB3011. It's working fine, but when I connect by Winbox it shows all pages empty (no interfaces, no addresses and so on).
For SSH connection I can see all.
Also I have some wAPs - WInbox connection for them works fine.

I connect to IP address, not MAC.
WInbox version 3.10.

I deleted 'Mikrotik' folder from AppData - it didn't help.

Re: Winbox empty

Posted: Thu Feb 02, 2017 11:16 am
by p3rad0x
Does it stay blank and then disconnect from winbox?

Re: Winbox empty

Posted: Thu Feb 02, 2017 1:31 pm
by strods
In Winbox loader use Tool/Clear Cache and then try to connect again.

Re: Winbox empty

Posted: Thu Feb 02, 2017 4:01 pm
by himvas
Problem resolved.

Source was in network adapter in my computer.
All was fine till today morning, when problem began, I don't know what triggered it - there was no changes for some months.
But when I turn off all default turned on offloads for TCP/IP in onboard Realtek based network card problem disappears.

Also, as a symptom, - when I clear Winbox cache, program began to download plugins and it was VERY slow - about 1 Kbyte/s ! And this for Gigabit LAN!

Re: Winbox empty (Resolved)

Posted: Mon Apr 27, 2020 3:54 am
by Mikrotikate
Based on my experience, the reason for this behaviour may just be bad 802.11n support, on 2.4Ghz wlan interfaces.


I have spent most of this weekend trying to understand the cause for this behaviour.

I'll spare you the headache. Here is a list of symptoms, what i tried to do, and the final solution.


List of symptoms:
1. While connecting using winbox to the ip/MAC, winbox is stuck at "Downloading descriptors"
2. When it connects, most of the time existing session windows are empty
3. When it's connected, opening a new terminal window returns nothing
4. Random winbox disconnects
5. High weird network latencys
6. Some WebPages (not Google) take a lot of time to open, and most of the time they don't open completely.

What i have tried to do:
1. RB reset
2. Tried several bridge/no bridge configurations for wlan1
3. Tried MAC Connection/IP Connection, all the same.
4. Tried clearing the "Appdata" folder and "clear cache" in Winbox loader, al lthe same.
5. Firmware upgrades to latest 6.45.8
6. Package upgrades to latest 6.45.8
7. Configuration reset, without default configuration.
Started from scratch and added only wlan1 in "default settings"
8. Tried exchanging the power supply, to another with 24V/1200ma, same thing, so its not the power supply.
9. I have 3 hap AC, updated all to the last 6.45.8, same problem in all of them, so it's not bad hardware/power supply.
10. Tried removing wlan chains, and leave just one chain, no help.
11. Used another computer to connect, same issue, so its not the computer.
12. Finally tried to disable 2.4Ghz "N" Band Modes. BINGO.

The final solution:
Don't use 802.11n on 2.4Ghz Mikrotik Interfaces.

Problem gone, low latency network and stable connection with 2Ghz-only-G.

Re: Winbox empty (Resolved)

Posted: Fri Nov 13, 2020 4:30 pm
by dakotabcn
Hello
I have this problem, i connecta via VPN L2TP and have this problem
I not use Wifi, via local lan works fine, via VPN show empty, this router not have wireless
any idea?

Re: Winbox empty (Resolved)

Posted: Sat Nov 21, 2020 10:54 pm
by aryalee
Hi

Update 1:
The problem was large MTU set between two routers and since I was connecting to R2 through R1, I got disconnected continuously. I reduced MTU and problem solved.

Original Post:

I just did the laziest thing I could.
1. Connected via Winbox and so many empty windows like "ip route", "ip addresses", ... inside Winbox opened.
2. From "Session" menu I chose "Close All Windows" and then I exited Winbox.
3 Connected to Winbox again and everything was fine :)