Page 1 of 1

error sending email: error talking to server ??

Posted: Mon Nov 06, 2006 5:32 am
by firebat
I'm getting the following message when trying to send an email to my PostCase SMTP server running on the same machine as DUDE. Dude can send emails without an issue:

error sending email: error talking to server

I have the SMTP IP address and the from address set in tool e-mail> . I try a simple email like and get the error. I tried specifying the server and from address directly as well:

send to="xxx@yahoo.com" subject="test" body="test"


How do I tell what the error is? The log doesn't tell me much.

Posted: Mon Nov 06, 2006 2:38 pm
by janisk
maybe try to fill more fields like to, from, server, subject, body.

check if you can ping server from router, check if you have no firewall filters

Posted: Mon Nov 06, 2006 10:29 pm
by firebat
Yep, tried all of that (I even diabled the firewall on the PC). There server is pingable as it is directly attached to the mikrotik's interface. I'm hoping there is some more logs somewhere that can tell me what the issue is. Is there a logging verbosity setting available?

Posted: Tue Nov 07, 2006 10:08 am
by janisk
if you havent changed logs - then id router relay tries to send e-mail but fails log says why. it is very brief, but still a message.

you could try sending mail through any other smtp server (atleast try)

and post - what log say if you have info topic (alone) enabled after your attempt fail.

Posted: Wed Nov 08, 2006 8:42 am
by firebat
Which log are you referring to? The Router event log just prints out:

error sending email: error talking to server

Is there another log? Since RouterOS doesn't do SMTP authenication, I can't send mail to other servers as well. My SMTP server is attached directly to a router interface and nothing is being blocked on that interface.

Posted: Fri Nov 10, 2006 10:39 am
by firebat
APC UPSs in my network can send mail to the SMTP server that is running on the DUDE machine so I know it is accepting mail.

Miktrotik folks: Can you suggest how to debug this issue?

Email Problem - Error talking to Server

Posted: Mon Jan 22, 2007 5:46 pm
by reliableComputer
I'm curretnly running 2.9.35, with all settings pointing to my SMTP server, and yet it still doesn't go.

No firewalls between the two, and the SMTP relay doesn't require authentication.

I assume other people have had luck in getting the email feature to work. Did you need to have a real dumb smtp server to do it? Currently running RedHat Sendmail.

Thanks for the help.

-Keith-

Posted: Mon Jan 22, 2007 6:05 pm
by reliableComputer
Answered my own question, and wanted to let everybody else know, in case you have the same problem.

Apparently, when MikroTik talks to the SMTP server it sends the radio name as its EHLO request.

In my case, this was causing sendmail to say it was an invalid domain, and killing the connection.

The "fix" is to change the identity to radioname.yourdomain giving your actual domain name. Then is sent right on through. My script will merely change the identity before & after sending the message.

Hope that helps somebody.

-Keith-

Posted: Wed Jan 24, 2007 7:04 am
by firebat
Still doesn't work. I still get the same system error. Can you post the script that you use? I'm using the following for a test:

/tool e-mail send from="xxxxx@comcast.net" server="192.168.x.x" body="Router down" subject="Router at second floor is down" to="xxxxx@yahoo.com"


Dude has no issue using the same server.