Community discussions

MUM Europe 2020
 
rviteri
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 84
Joined: Fri Nov 18, 2011 5:53 pm

PPTP server stops accepting connections after a few days, IPSEC works fine all of the time

Thu Mar 23, 2017 2:35 am

Hello,

I have a set up where one router accepts a few pptp connections for site to site connectivity. Unfortunately, about 8 days or so of running the tunnels the server stops accepting connections. This is quite irritating as I have to restart the router.

Regardless, L2TP works fine with everthing remaining the same.

Any thoughts about this?

I am running version 6.37.2
 
Van9018
Long time Member
Long time Member
Posts: 519
Joined: Mon Jun 16, 2014 6:26 pm
Location: Canada - Abbotsford

Re: PPTP server stops accepting connections after a few days, IPSEC works fine all of the time

Fri Mar 24, 2017 1:02 am

First upgrade to latest firmware. If problem persists you can use Tools > Torch to confirm your incoming PPTP packets are making it to your WAN. Then file a bug report with support@mikrotik.com (also send rtf support file from your device).

- Two clients behind the same public IP can't connect to your PPTP server.
- What's the workaround, a reboot? Or disable/enable PPTP server?
 
rviteri
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 84
Joined: Fri Nov 18, 2011 5:53 pm

Re: PPTP server stops accepting connections after a few days, IPSEC works fine all of the time

Sun Mar 26, 2017 9:46 pm

The only workaround is to reboot the router. I have not seen any changes in the changelogs with regards to VPN connections.
 
Van9018
Long time Member
Long time Member
Posts: 519
Joined: Mon Jun 16, 2014 6:26 pm
Location: Canada - Abbotsford

Re: PPTP server stops accepting connections after a few days, IPSEC works fine all of the time

Tue Mar 28, 2017 9:37 pm

I have 6.37.1 but I use SSTP for site-to-site without any issues. Mikrotik will probably want you to try the latest packages before submitting an issue to their support.

Also turn on logging for PPTP, see if it says anything interesting.

a convenient work around could be to set the routers to reboot every few days.

Who is online

Users browsing this forum: dioeyandika, faxxe, MSN [Bot] and 90 guests