Community discussions

 
teracom
just joined
Topic Author
Posts: 2
Joined: Sat Feb 11, 2017 12:13 pm

OpneVPN server binding issues

Tue Apr 04, 2017 3:21 pm

I have a couple of openvpn server binding which should be picking up the ovpn incoming connection and running it under the server binding. This works for the most part, but often when the connection drops for some reason and the client automatically reconnects, the mikrotik does not 're-associate' the incoming client connection with the correct server binding. This then causes further issues, as the server binding is added to a bridge. Hence, when the client connection is not associated with the correct server binding, its not added to the bridge.

it shows up as <ovpn-'username'>. Funnily enough, when you kill that (<opvn-x>) connection and the client auto-reconnects, it then adds it to the correct server binding and that server binding changes to the running state.

Its as it the server binding only works every now and then.

I've seen this on a couple of mikrotik's before. Has anyone else has the same issues? If so, is there a workaround/fix?

Thanks

J
 
sveno
newbie
Posts: 40
Joined: Mon May 14, 2012 8:29 pm

Re: OpneVPN server binding issues

Sat Dec 02, 2017 9:30 am

I have the same issue. Is there a known workaround for this?
Is there another way to add a vpn server binding to the bridge or have the VPN client connections be part of the bridge?

I have this on a RB running v6.40.4 - haven't tested elsewhere.
 
emptybox
just joined
Posts: 3
Joined: Fri Aug 21, 2015 4:59 pm

Re: OpneVPN server binding issues

Mon Dec 18, 2017 4:58 pm

Same problem here, is pretty annoying.
Did you manage to resolve this ?
 
sveno
newbie
Posts: 40
Joined: Mon May 14, 2012 8:29 pm

Re: OpneVPN server binding issues

Mon Dec 25, 2017 11:05 am

The only idea I have is to make a script:
1. delete all interfaces in the bridge to keep it tidy
2. add necessary interfaces to the bridge
 
nelfou
just joined
Posts: 17
Joined: Wed Mar 22, 2017 3:10 pm

Re: OpneVPN server binding issues

Wed Jun 05, 2019 7:13 pm

same problem with l2tp server binding.

running v6.44.2

I guess I should not count on this feature then.
 
McSee
Frequent Visitor
Frequent Visitor
Posts: 67
Joined: Tue Feb 26, 2019 12:49 pm

Re: OpneVPN server binding issues

Wed Jun 05, 2019 9:27 pm

same problem with l2tp server binding.

running v6.44.2

I guess I should not count on this feature then.
You can set only-one=yes in PPP Profile for that user to prevent second connection.
 
nelfou
just joined
Posts: 17
Joined: Wed Mar 22, 2017 3:10 pm

Re: OpneVPN server binding issues

Thu Jun 06, 2019 9:53 am

Interesting. That would mean the client reconnects before the server could unbind it.

Thanks for the tip I'm trying this. If no further news from me then that's fixed for me ;)

Who is online

Users browsing this forum: No registered users and 35 guests