Community discussions

 
akram
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 64
Joined: Wed Aug 10, 2005 4:58 pm

emule port - but something weird

Sat Nov 11, 2006 8:18 pm

i have open emule port on my router but suddunly i found that i'm taking low ids ,i delete the NAT line and recreate but till the same low id

i dunno what happen?

this is the NAT Line for my ip

;;; Emule Akram TCP
chain=dstnat dst-address=84.36.214.134 protocol=tcp dst-port=4711 action=dst-nat
to-addresses=172.16.1.202 to-ports=4711

any help to fix this?
 
User avatar
111111
Member Candidate
Member Candidate
Posts: 194
Joined: Thu Oct 05, 2006 1:39 am
Location: BG,SOFIA

Sun Nov 12, 2006 1:27 am

add same and for UDP
 
akram
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 64
Joined: Wed Aug 10, 2005 4:58 pm

Sun Nov 12, 2006 12:12 pm

i have add the udp Line too

;;; Emule Akram UDP
chain=dstnat dst-address=84.36.214.134 protocol=udp dst-port=4721 action=dst-nat
to-addresses=172.16.1.202 to-ports=4721

same low id ??

i was working fine but now i dunno what happen

any help
 
advantz
Member Candidate
Member Candidate
Posts: 187
Joined: Thu Jul 08, 2004 4:11 am

Tue Nov 14, 2006 12:40 pm

why only forward ports?

try this first :
chain=dstnat dst-address=84.36.214.134 action=dst-nat
to-addresses=172.16.1.202 to-ports=0-65535

still got low id??
 
akram
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 64
Joined: Wed Aug 10, 2005 4:58 pm

Tue Nov 14, 2006 9:20 pm

i tried it but still lowid
 
User avatar
kolorasta
Member Candidate
Member Candidate
Posts: 299
Joined: Sun Jun 25, 2006 11:55 pm
Location: Argentina

Mon Nov 20, 2006 9:14 pm

;;; emule
chain=dstnat in-interface=WAN dst-address=PUBLIC.IP.HERE protocol=tcp dst-port=4662 action=dst-nat to-addresses=LOCAL.IP. HERE to-ports=4662

in emule disable UDP connection... only TCP...
and in "in-interface" put the name of the public interface of your MT... and in ports put the port # u r using in emule

does it work now?
 
akram
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 64
Joined: Wed Aug 10, 2005 4:58 pm

Tue Nov 21, 2006 12:45 pm

ok i'll try it and post the result
 
akram
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 64
Joined: Wed Aug 10, 2005 4:58 pm

Tue Nov 21, 2006 1:09 pm

i tired it but still the same
 
User avatar
kolorasta
Member Candidate
Member Candidate
Posts: 299
Joined: Sun Jun 25, 2006 11:55 pm
Location: Argentina

Tue Nov 21, 2006 3:50 pm

do u use masquerade?

i use nat, but i don´t use masquerade... i don't know if it is because of that

and you must ensure that your isp is giving you a public ip... if your isp is natting you, there is nothing you can do to avoid having a low id
 
akram
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 64
Joined: Wed Aug 10, 2005 4:58 pm

Tue Nov 21, 2006 4:21 pm

yes i use masqurade
 
User avatar
kolorasta
Member Candidate
Member Candidate
Posts: 299
Joined: Sun Jun 25, 2006 11:55 pm
Location: Argentina

Tue Nov 21, 2006 10:14 pm

see what i've got in my mt

 0   ;;; nat
     chain=srcnat src-address=xx.xx.xx.xx/xx(local network here) action=src-nat 
     to-addresses=xx.xx.xx.xx(public ip here) to-ports=0-65535 

 1  ;;; emule
     chain=dstnat in-interface=WAN dst-address=xx.xx.xx.xx(public ip here) protocol=tcp 
     dst-port=4662 action=dst-nat to-addresses=xx.xx.xx.xx(ip of emule machine) to-ports=4662 
4662 is the port i use for my mule

hope this works
 
User avatar
111111
Member Candidate
Member Candidate
Posts: 194
Joined: Thu Oct 05, 2006 1:39 am
Location: BG,SOFIA

Wed Nov 22, 2006 1:33 am

If you use firewall rules added with MT web check you will have problem 100%
disable like this

/ ip firewall filter
add chain=input action=drop comment="Drop everything else" disabled=yes 
add chain=customer action=drop comment="Drop and log everything else" disabled=yes
post result

Who is online

Users browsing this forum: No registered users and 68 guests