Community discussions

MUM Europe 2020
 
User avatar
airstream
Member Candidate
Member Candidate
Topic Author
Posts: 188
Joined: Fri Feb 03, 2006 6:33 am
Location: New Zealand

1 WAN many on LAN and PCQ

Wed Nov 22, 2006 4:07 am

Hi there,

After several unsuccessful attempts, I'm asking for some guidance.

We have 1 main WAN for customers authenticated via PPPoE coming into LAN. All clients are assigned an IP address from a IP pool. How do I set PCQ rules to balance out connections from our clients headed for the internet, so not one client is hogging all the network etc?

Cheers for any pointers.
Keep tryin' its bound to work!!
-----
-----
ROOT@COSMOS> Reality.sys corrupted -- Reboot Universe (Y/N)?
>_
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6621
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Wed Nov 22, 2006 9:23 am

Mark all required clients traffic in mangle, traffic that will be divided between these clients. Add PCQ queues to share bandwidth between them,
http://www.mikrotik.com/testdocs/ros/2. ... p#6.54.6.3
What does not work for you, specify your problem.
 
User avatar
airstream
Member Candidate
Member Candidate
Topic Author
Posts: 188
Joined: Fri Feb 03, 2006 6:33 am
Location: New Zealand

Wed Nov 22, 2006 9:39 pm

Hi Sergejs,

Thanks for your reply, The part where I get stuck is specifying the incoming interface:
/queue tree add name=Download parent=Local max-limit=10240000
/queue tree add parent=Download queue=pcq-download packet-mark=users
As customers are connection via PPPoE, there is no "local" parent interface, as all PPPoE connections have their own dynamic interface created with the logon. How can i catch a particular ip subnet (assigned to PPPoE clients) in place of one interface?

Cheers
Keep tryin' its bound to work!!
-----
-----
ROOT@COSMOS> Reality.sys corrupted -- Reboot Universe (Y/N)?
>_
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6621
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Thu Nov 23, 2006 8:19 am

Airstream, I think you can use 'global-in' and 'global-out' interface as incoming/outgoing interfaces, use chain=prerouting to marck clients packets.
 
simonne
just joined
Posts: 10
Joined: Tue Jan 25, 2011 7:38 pm

Re: 1 WAN many on LAN and PCQ

Sun Feb 06, 2011 5:23 pm

It's a weird thing, I have the same situation, and - when I use global-out and global-in, at both queues I have sum upload+download, I'm mangling on prerouting, with and without adress list, and with one milion tries and ideas, I'm using masquarade so I have to use global-in and global-out, I have three different interfaces, and on each I have other pppoe-concetrator, what should I do to use pcq?

Who is online

Users browsing this forum: Bergante, bpwl, Google [Bot], joerg0085, petrcz and 135 guests