Page 1 of 1

mmAP & WAP AC Bricked when Firmware Update to 6.39.2

Posted: Tue Jun 20, 2017 9:10 pm
by learnyee
Ok this happened in both my mAP & WAP AC.

What happened:
1. Whenever I received a new unit, I would 1st upgrade it with firmware version 6.38.5, by manually downloading the routeros-mipsbe-6.38.3.npk and all_packages-mipsbe-6.38.3.zip, and transfer it to the router using WinBox
2. During the transfer of all the upgrade files, tr069-client-6.38.3-mipsbe.npk, ups-6.38.3-mipsbe.npk, user-manager-6.38.3-mipsbe.npk, and wireless-6.38.3-mipsbe.npk from all_packages-mipsbe-6.38.3.zip will failed to copy over to the router for whatever reason even there is still storage space on the router.
3. What I did here was, reboot the router, let the router upgrade the main system firmware to 6.38.3, then retransfer the failed files said above again (4 files from the zip file), then reboot the router again to upgrade the rest of the components.
4. What I did here was generally configuring the router by importing my set of standard config, etc etc, the usual stuffs.
5. Then I will use the Quick Set->Check For Update->Download and Install, and auto Reboot.
6. Voila, the router will stuck forever in the power cycle loop, and the only way to unbrick the router is to reboot the router in backup bootloader and boot into the NetInstall, which I managed to recover my WAP AC by flashing the routeros-mipsbe-6.39.2.npk (reboot, etc etc). The transfer all the files from the all_packages-mipsbe-6.39.2.zip to ensure all the components in the router are up to date.

I observed that this happened in router with just 16MB of storage and with FULL set of FEATURES installed for whatever reason. This does not happened to the RB2011, RB951G and RB951 as far as I had observed(which I had deployed many units). Maybe someone can test this out and if it is an confirmed issue, do kindly assist to report to Mikrotik.

and ok, excuse me, now I need to unbrick my mAP....