Community discussions

MikroTik App
 
Saleh9416
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 73
Joined: Wed Feb 03, 2016 6:21 am

PCC load balancing problem

Fri Aug 18, 2017 9:32 am

Hello!

I have 2 satellite modems with different static IP addresses and different gateways! and I'm using PCC method for unequal 2 Wan load balancing (Wan1= 10Mbit | Wan2= 5Mbit).

At first, I've noticed that it works but not stable! When it's working most of the time I don't get full speed. And while watching videos on Youtube only one link is active! Also while downloading sometimes both link work, sometimes just one link.

Here's my configuration:
/ip address
add address=10.138.22.154/29 interface=WAN1
add address=10.138.26.125/29 interface=WAN2
add address=10.10.100.1/22 interface=LAN

/ip dns
set allow-remote-requests=yes cache-size=5000KiB max-udp-packet-size=4096 servers=8.8.8.8,8.8.4.4

/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_con
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_con
add action=mark-routing chain=output connection-mark=WAN1_con new-routing-mark=to_WAN1
add action=mark-routing chain=output connection-mark=WAN2_con new-routing-mark=to_WAN2
add chain=prerouting dst-address=10.138.22.152/29 in-interface=LAN
add chain=prerouting dst-address=10.138.26.120/29 in-interface=LAN
add action=mark-connection chain=prerouting dst-address-type=!local hotspot=auth in-interface=LAN new-connection-mark=WAN1_con per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting dst-address-type=!local hotspot=auth in-interface=LAN new-connection-mark=WAN2_con per-connection-classifier=both-addresses-and-ports:2/1
add action=mark-connection chain=prerouting dst-address-type=!local hotspot=auth in-interface=LAN new-connection-mark=WAN1_con per-connection-classifier=both-addresses-and-ports:2/2
add action=mark-routing chain=prerouting connection-mark=WAN1_con in-interface=LAN new-routing-mark=to_WAN1
add action=mark-routing chain=prerouting connection-mark=WAN2_con in-interface=LAN new-routing-mark=to_WAN2 

/ip firewall nat
add action=masquerade chain=srcnat out-interface=WAN1
add action=masquerade chain=srcnat out-interface=WAN2

/ip route
add check-gateway=ping distance=1 gateway=10.138.22.153 routing-mark=to_WAN1
add check-gateway=ping distance=1 gateway=10.138.26.124 routing-mark=to_WAN2
add check-gateway=ping distance=1 gateway=10.138.22.153
add check-gateway=ping distance=2 gateway=10.138.26.124
Any help, please!
Last edited by Saleh9416 on Sun Aug 20, 2017 10:26 am, edited 1 time in total.
 
irghost
Member
Member
Posts: 302
Joined: Sun Feb 21, 2016 1:49 pm

Re: PCC load balancing problem

Fri Aug 18, 2017 9:48 am

add action=mark-connection chain=prerouting dst-address-type=!local hotspot=auth in-interface=LAN new-connection-mark=WAN1_con per-connection-classifier=both-addresses-and-ports:2/2
when we are dividing the numbers into 2 the Divide remaining are just 0 and 1
in your case u must Use 3/0 3/1 3/2
 
Saleh9416
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 73
Joined: Wed Feb 03, 2016 6:21 am

Re: PCC load balancing problem

Fri Aug 18, 2017 10:02 am

add action=mark-connection chain=prerouting dst-address-type=!local hotspot=auth in-interface=LAN new-connection-mark=WAN1_con per-connection-classifier=both-addresses-and-ports:2/2
when we are dividing the numbers into 2 the Divide remaining are just 0 and 1
in your case u must Use 3/0 3/1 3/2
Hello irghost!

I changed it to 3/0 3/1 3/2 but the problem persists!
 
irghost
Member
Member
Posts: 302
Joined: Sun Feb 21, 2016 1:49 pm

Re: PCC load balancing problem

Fri Aug 18, 2017 10:19 am

add action=mark-connection chain=prerouting dst-address-type=!local hotspot=auth in-interface=LAN new-connection-mark=WAN1_con per-connection-classifier=both-addresses-and-ports:2/2
when we are dividing the numbers into 2 the Divide remaining are just 0 and 1
in your case u must Use 3/0 3/1 3/2
Hello irghost!

I changed it to 3/0 3/1 3/2 but the problem persists!
PCC loadbalance
Per Connection
more connection = better balance
 
Saleh9416
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 73
Joined: Wed Feb 03, 2016 6:21 am

Re: PCC load balancing problem

Fri Aug 18, 2017 9:40 pm

PCC loadbalance
Per Connection
more connection = better balance[/quote]

Does that mean what's happening in my case is normal?!
 
libyatik
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Wed Jun 28, 2017 4:31 am

Re: PCC load balancing problem

Sat Aug 19, 2017 4:48 am

pcc will dispatch connections between wans but will Not combine the speeds in 15mbps thats another story
 
Saleh9416
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 73
Joined: Wed Feb 03, 2016 6:21 am

Re: PCC load balancing problem

Sun Aug 20, 2017 10:28 am

pcc will dispatch connections between wans but will Not combine the speeds in 15mbps thats another story
إمنوّر
 
Subchanazhubaidi
just joined
Posts: 1
Joined: Mon Jan 08, 2018 8:32 am

Re: PCC load balancing problem

Mon Jan 08, 2018 8:40 am

I wanna ask about the best way how to test PCC feature ?? , **im sorry im a newbie in mikrotik and i wanna learn more about it
 
tangram
Member Candidate
Member Candidate
Posts: 132
Joined: Wed Nov 16, 2016 9:55 pm

Re: PCC load balancing problem

Mon Jan 08, 2018 3:18 pm

Easiest way that I can think of is just let it split the traffic :)

2 ;;; Load-Balancing here // Split 1/2
chain=prerouting action=mark-routing new-routing-mark=RDS_Route passthrough=yes src-address-list=LAN connection-mark=LAN_WAN per-connection-classifier=both-addresses:2/1 log=no log-prefix=""

13 ;;; Load-Balancing here // Split 1/2
chain=prerouting action=mark-routing new-routing-mark=UPC_Route passthrough=yes src-address-list=LAN connection-mark=LAN_WAN per-connection-classifier=both-addresses:2/0 log=no log-prefix=""

/ip firewall mangle print stats
12 ;;; Load-Balancing here // Split 1/2
prerouting mark-routing 6 116 930 61 914
13 ;;; Load-Balancing here // Split 1/2
prerouting mark-routing 6 746 746 57 425

Who is online

Users browsing this forum: dioeyandika, NetHorror, raiser and 72 guests