Community discussions

MikroTik App
 
Mimiko
just joined
Topic Author
Posts: 18
Joined: Sat May 20, 2017 3:28 pm

VLAN trunk between Mikrotik and DGS-1210-28/ME

Tue Aug 22, 2017 3:07 pm

Hello.

My goal is connect Mikrotik CRS125-24G-1S-2HnD to D-Link DGS-1210-28/ME to handle multiple VLANs to allow different LAN and WLAN clients to connect to different VLANs based on some policy. Here is my configuration:
/interface> export
# aug/22/2017 14:48:19 by RouterOS 6.40.1
# model = CRS125-24G-1S-2HnD
/interface bridge
add name=bridge-9
add name=bridge-10
add name=bridge-8
add name=bridge-1
add name=bridge-11
/interface wireless
# managed by CAPsMAN
# channel: 2427/20-Ce/gn(20dBm), SSID: LAN10, local forwarding
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no mode=station-pseudobridge ssid=MikroTik wireless-protocol=nv2-nstreme-802.11
add mac-address=6E:3B:6B:2B:5D:0B master-interface=wlan1 mode=station name=wlan2
# managed by CAPsMAN
# SSID: LAN9, local forwarding
add disabled=no mac-address=6E:3B:6B:2B:5D:0A master-interface=wlan1 mode=station name=wlan3
/interface vlan
add interface=ether24 name=vlan-9 vlan-id=9
add interface=ether24 name=vlan-10 vlan-id=10
add interface=ether24 name=vlan-8 vlan-id=8
add interface=ether24 name=vlan-1 vlan-id=1
add interface=ether24 name=vlan-11 vlan-id=11
/interface ethernet
set [ find default-name=ether1 ] master-port=ether24
set [ find default-name=ether2 ] master-port=ether24
set [ find default-name=ether3 ] master-port=ether24
set [ find default-name=ether4 ] master-port=ether24
set [ find default-name=ether5 ] master-port=ether24
set [ find default-name=ether6 ] master-port=ether24
set [ find default-name=ether7 ] master-port=ether24
set [ find default-name=ether8 ] master-port=ether24
set [ find default-name=ether9 ] master-port=ether24
set [ find default-name=ether10 ] master-port=ether24
set [ find default-name=ether11 ] master-port=ether24
set [ find default-name=ether12 ] master-port=ether24
set [ find default-name=ether13 ] master-port=ether24
set [ find default-name=ether14 ] master-port=ether24
set [ find default-name=ether15 ] master-port=ether24
set [ find default-name=ether16 ] master-port=ether24
set [ find default-name=ether17 ] master-port=ether24
set [ find default-name=ether18 ] master-port=ether24
set [ find default-name=ether19 ] master-port=ether24
set [ find default-name=ether20 ] master-port=ether24
set [ find default-name=ether21 ] master-port=ether24
set [ find default-name=ether22 ] master-port=ether24
set [ find default-name=ether23 ] master-port=ether24
/interface ethernet switch trunk
add member-ports=ether24,ether23 name=trunk-uplink
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge filter
/interface bridge port
add interface=ether1
add interface=ether2
add interface=ether3
add interface=ether4
add interface=ether5
add interface=ether6
add interface=ether7
add interface=ether8
add interface=ether9
add interface=ether10
add interface=ether11
add interface=ether12
add interface=ether13
add interface=ether14
add interface=ether15
add interface=ether16
add interface=ether17
add interface=ether18
add interface=ether19
add interface=ether20
add interface=ether21
add interface=ether22
add interface=ether23
add interface=sfp1
add bridge=bridge-9 interface=vlan-9
add bridge=bridge-10 interface=vlan-10
add bridge=bridge-8 interface=vlan-8
add bridge=bridge-1 interface=vlan-1
add bridge=bridge-11 interface=vlan-11
add interface=ether24
add bridge=bridge-10 interface=wlan1
add bridge=bridge-9 interface=wlan3
/interface bridge settings
set use-ip-firewall-for-vlan=yes
/interface ethernet switch egress-vlan-tag
add tagged-ports=trunk-uplink,ether1,switch1-cpu vlan-id=8
add tagged-ports=trunk-uplink,ether1,switch1-cpu vlan-id=9
add tagged-ports=trunk-uplink,ether1,switch1-cpu vlan-id=10
add tagged-ports=trunk-uplink,ether1,switch1-cpu vlan-id=1
add tagged-ports=trunk-uplink,ether1,switch1-cpu vlan-id=11
/interface ethernet switch egress-vlan-translation
add customer-vid=10 new-customer-vid=0 ports=\
    ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether11,ether12,ether13,ether14,ether15,ether16,ether18,ether19,ether20,ether21,ether22
add customer-vid=9 customer-vlan-format=untagged-or-tagged new-customer-vid=0 ports=ether2,ether17
/interface ethernet switch ingress-vlan-translation
add customer-vid=0 new-customer-vid=10 ports=\
    ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether11,ether12,ether13,ether14,ether15,ether16,ether18,ether19,ether20,ether21,ether22
add customer-vid=0 new-customer-vid=9 ports=ether2,ether17
/interface ethernet switch vlan
add ports="trunk-uplink,ether1,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether11,ether12,ether13,ether14,ether15,ether16,ether18,ether19,ether20,ether21\
    ,ether22,switch1-cpu" vlan-id=10
add ports=trunk-uplink,ether1,ether12,switch1-cpu vlan-id=11
add ports=trunk-uplink,ether1,ether12,switch1-cpu vlan-id=8
add ports=trunk-uplink,ether1,ether2,ether12,ether17,switch1-cpu vlan-id=9
add ports="trunk-uplink,ether1,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether11,ether12,ether13,ether14,ether15,ether16,ether18,ether19,ether20,ether21\
    ,ether22,switch1-cpu" vlan-id=1
This configuration works as expected and excelent if ports 23 and 24 are connected to trunked and agregated two ports on DGS-3100-24. If I connect ports 23 and 24 to two trunked and agregated ports on DGS-1210-28/ME then Mikrotik does not respond or send packets even if link is active, nor I can connect using Mikrotik's MAC to manage.

If I remove:
/interface bridge port
add bridge=bridge-9 interface=vlan-9
add bridge=bridge-10 interface=vlan-10
add bridge=bridge-8 interface=vlan-8
add bridge=bridge-1 interface=vlan-1
add bridge=bridge-11 interface=vlan-11
then the link is working and LAN clients are connected as expected, but wireless clients does not have connection.

Could someone give a suggestion how to allow wireless clients to VLANs when connecting to DGS-1210-28/ME ?

Who is online

Users browsing this forum: bennyuk, Bing [Bot], EvGn, SiB and 83 guests