Community discussions

 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Fast Browsing .. Normal long time downloading

Sat Dec 02, 2006 2:37 am

All I want is as simple as this drawing :
Image

thats mean giving highest available bandwidth for the client for the first 10 sec then lowering his band to a specific value ..

this will be very helpfull to give a fast browsing and a fair enough downloading ..

the question is ........... how to do that ??
 
User avatar
mneumark
Member
Member
Posts: 375
Joined: Thu Jun 08, 2006 7:20 am
Location: Escalon, CA
Contact:

Sat Dec 02, 2006 8:18 am

Your best bet would be setup a queue tree for that interface if you want all customers to have it or apply it to a single address.

http://www.mikrotik.com/testdocs/ros/2.9/root/queue.php

http://wiki.mikrotik.com/wiki/Bandwidth ... and_Queues
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Sat Dec 02, 2006 9:32 pm

I want to apply it to each client alone .. and i dont think its possible with Qtree ..
I already using PCQ it works fine but it just dividing the band equally , not exactly what i need for this quality of service ..
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Sun Dec 03, 2006 1:57 am

i dont think its possible !!!!! if its not please reply ...
 
User avatar
jose
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Thu Sep 22, 2005 4:56 am

Sun Dec 03, 2006 8:02 pm

Sam

I've done in linux with the wondershaper script http://lartc.org/wondershaper/, this script priorize intercative traffic over massive downloads.

In MT i've tried to replicate the idea with low success, I just mangled packets belonging to very large connections and i made a queue tree to give them less priority than packets belonging to smaller connections, of course syn, icmp and packets less than 64k had the first prio

I think there is a better solution but I could not find,
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Sun Dec 03, 2006 10:10 pm

well , your idea seems good to me jose , i think its a good solution ..
can you write the code needed in mangle , and how can you recognize the BIG connection from the small one .. please ..


note : how come MT team don't know how to solve such an important matter !!!!!
 
User avatar
111111
Member Candidate
Member Candidate
Posts: 194
Joined: Thu Oct 05, 2006 1:39 am
Location: BG,SOFIA

Mon Dec 04, 2006 1:43 am

I'm not sure but
burst time and limit
isn't give that option or it is only for WiFi
/ queue simple
add name="name" target-addresses=xx.xx.xx.xx/32 dst-address=0.0.0.0/0 interface=LAN parent=none direction=both priority=8 \
    queue=default/default limit-at=0/0 max-limit=2048000/2048000 burst-limit=4096000/4096000 burst-time=1m/1m total-queue=default \
    disabled=no
Last edited by 111111 on Wed Dec 06, 2006 3:18 am, edited 4 times in total.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Mon Dec 04, 2006 9:07 am

samsoft08,
if you will look at the 'queues' documentation, you will find that burts will perform required actions,
http://www.mikrotik.com/testdocs/ros/2. ... 4339867584
you will need to create separate queue for each user (either simple or queue tree).
Queue tree will certainly require mangle rules.
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Mon Dec 04, 2006 1:53 pm

Dear sergejs , as far as I know , BURST will flip the speed between the max-limit and the burst-limit every n second .. so i dont think it will satisfy my needs ..

I already using mangle+Qtree to equalizing connection betwen clients with PCQ , but of course without burst enabled ..

i dont want to flip the speed every n second , all i want is to give the browser higher priority than the large files downloaders who'll eat the bandwidth ..

and because both kinds of browsing and downloading traffics are HTTP so I cant recognize it by mangle , thats why i want to get a method to give the small HTTP traffic higher priority ..
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Mon Dec 04, 2006 2:01 pm

go and read manual again.

as sergejs have said - burst time is what you need. and is best coise for you right now.

any other posibity will et very complicated - and more complicated it gets more cpu time is used to manage packets and more possible errors in configuration rendering your configuration useless.


one thought - per connection limiting (burst time works at the beginning, afterwards limit starts to work, but you have to additionally limit bandwidth per user so there is no such possibility that user with more connections get more bandwith)
 
User avatar
sidney
just joined
Posts: 24
Joined: Fri Sep 15, 2006 12:15 pm
Location: South africa - Pretoria East

Mon Dec 04, 2006 3:01 pm

We using PCQ upload and download

I sent up a Master Queue with priority 7 as per sample
then each customer the parent = the master queue
so far works great as if one customer is buzy downloading
it limits them to about 400kbps as the queue goes red
and the others still carry on with their uploads and downloads

lags: X - disabled, I - invalid, D - dynamic
0 name="Master queue" dst-address=0.0.0.0/0 interface=all parent=none
direction=both priority=7 queue=PCQ_upload/PCQ_download
limit-at=512000/1000000 max-limit=1000000/2000000 total-queue=PCQ_total
total-limit-at=1024000 total-max-limit=2048000
total-burst-limit=4096000 total-burst-threshold=1536
total-burst-time=4s

1 name="Redbooks" target-addresses=10.0.50.18/32 dst-address=0.0.0.0/0
interface=all parent=Master queue direction=both priority=8
queue=PCQ_upload/PCQ_download limit-at=256000/512000
max-limit=512000/1000000 total-queue=PCQ_total total-limit-at=256000
total-max-limit=512000 total-burst-limit=1024000
total-burst-threshold=384000 total-burst-time=4s

2 name="Josef" target-addresses=10.0.50.1/32 dst-address=0.0.0.0/0
interface=all parent=Master queue direction=both priority=8
queue=PCQ_upload/PCQ_download limit-at=256000/512000
max-limit=512000/1000000 total-queue=PCQ_total

3 name="Prof Makinde" target-addresses=10.0.50.2/32 dst-address=0.0.0.0/0
interface=all parent=Master queue direction=both priority=8
queue=PCQ_upload/PCQ_download limit-at=256000/512000
max-limit=512000/1000000 total-queue=PCQ_total total-limit-at=256000
total-max-limit=512000 total-burst-limit=1024000
total-burst-threshold=384000 total-burst-time=4s

theses are sum of my client as i set them up
hope this might help but some one might have a beter idea

sidney
 
User avatar
polokus
newbie
Posts: 35
Joined: Fri Dec 23, 2005 7:04 am

Mon Dec 04, 2006 4:21 pm

Dear sergejs , as far as I know , BURST will flip the speed between the max-limit and the burst-limit every n second .. so i dont think it will satisfy my needs
I think we have a common problem, and got the same treatment (uses burst) but i don't like burst it will filp every "n seconds", but i have an idea of how to distinguish a connection for browsing pages (.html,.asp,etc) and for download (zips,mp3s,etc) mark the connection with a code say "xx" and limit the connection to say 200kbytes so that the mark will be triggered when that connection already exceeded 200kbyte, the connection will be marked with the code and create a simple queue which catches the code and the ip address of the client. With this rule every new connection will have fast speed until they exceeded the 200kbyte mark.
So you got fast browsing (for pages < 200kbyte) and slow download (files > 200kbyte) at the same time.

Hope helps, and please tell me the command if you know how to implement that idea

Regards
 
cmit
Forum Guru
Forum Guru
Posts: 1552
Joined: Fri May 28, 2004 12:49 pm
Location: Germany

Tue Dec 05, 2006 9:09 am

Where did you get the impression that using bursting will "flip" your connection speed every n seconds?

Best regards,
Christian Meis
Best regards,
Christian Meis
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Tue Dec 05, 2006 9:27 am

it seems by hitting hard his head to keyboard and not reading manual or other technical documentation about burst. (sorry if offending someone)


maybe i could tr to explain burst, maybe, a bit easier way:


a tale of good burst time :)
once upon the time there where one user and admin.
when user starts new session of net surfing he opens web page that way he initiates all that fancy equipment to deliver him 1 and 0 :roll: but since he has not a "gazzillions" of money his network connection is speed limited. since he hasn't sued net before (for some time) good admin allows him to exceed his allowed data rate and load web page faster and not use net infrastructure fr some time while reading contents of web page. if user continues to download then after some time his average data rate come to limit he had paid for his connection speed drops to preset limit and no more fast loading pages, until he stops downloading and lets admins routers to rest from him for some time, so next time after rest period - user is able to get burst again as average download speed has droped below burst threshold. so user is happy - fast opening web pages and admin is happy too - since his routers can rest for some time, if admin does not want to let his hardware to rest he connects more users as if he had set hard limits and users all the time opens new pages to read them later, becose networking is slow,
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Tue Dec 05, 2006 10:59 am

actually yes, burst does just what you need. you are mistaken in your assumptions.
 
User avatar
jose
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Thu Sep 22, 2005 4:56 am

Tue Dec 05, 2006 2:38 pm

Hey guys

You don´t catch the main idea.

I know burst works as it should, but sometimes we need more tools to do the the job.

for instance a user is downloading a very large file, so the "heavy user" is capped to their max allowed bandwidth without disturbing other "light users" This behaviour is fair but is not so good for the heavy user because his/her big download interfere with his/her normal browsing.

Let´s suppose the computer of some user is running windows update in the background so that user suffers a degradation of the service because he is already taken all allowed bandwidth.

This problem is more evident when you are providing internet service to some cyber cafe or someone who is going to share their connection, someone inside begins to download something then the customer call to complain that nobody can surf, then you check and respond to the customer that he is using ALL asigned bandwith.

What about if the box sharing the internet would go reducing slowly the rate of any connection so EVEN the heavy user can surf without any problem.

I repeat, the wondershaper script do "exactly" this job, please read SOMETIMES the documentation script. I know the solution I made in mikrotik is not so straight but I will post If nobody has a better idea
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Tue Dec 05, 2006 2:41 pm

how does the router know which download is BIG and what does it do then? slow down only the one download?
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Tue Dec 05, 2006 3:41 pm

janisk , it seems by wasting your time telling silly stories and not trying to understand the main point (sorry if offending someone)

I guess even the MT experts didnt catch the idea !!!
i know most of the sattellite internet providers done this .. we can see it every day when we connect to a sat terminal , download will begin high then after seconds it will stay on a specific value ..

so , its not impossible , but it cant be done with burst , because burst will FLIP between high value and low one , yes it will , check it for those who said : who said that ??

i think we need more advanced idea to solve this problem ..
jose , i cant get the code of wondershaper , can u post it here please ..
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Tue Dec 05, 2006 3:44 pm

NO it won't! burst will make your download slow down to a specified value after a specified time!
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Tue Dec 05, 2006 3:57 pm

OMG.

There was ideal illustration to how burst works in the QoS part of Mikrotik Training

To Normis - could you ,please, get it from your trainer and past it in (I have it on the paper, but I don't have scanner here)

To samsoft08, polokus - you simple have problems with proper Burst-treshold adjustment (it must be less than max-limit ;) )
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Tue Dec 05, 2006 3:58 pm

Image

there you go. misconfiguration is the number one reason for complaints.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Tue Dec 05, 2006 4:06 pm

Thanks, as you can see in the picture burst-time is not the duration of the burst - it is time per which is calculated this "average rate"
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Tue Dec 05, 2006 4:21 pm

so if you already have limitations per user like 2mbit for user A and 3 for user B

maybe you can think of way that user connections (each) get a queue and has its burst, so if user opens one connection it get burst and then it slows down, then another connection is made and traffic is divided :roll: i think it is possible with ROS.

drawbacks: your heavy download will be slowed down painfully at a cost that everybody else can utilise network if none really downloaded.

and that satellite method you described - IS A GOOD CONFIGURED BURST

all you have to do is READ THE MANUAL and choose appropriate queue type. AND configure burst that it is actually usable and has it bonuses delivered.

or go and search the net for technology that is actually in use that does what you wanted. IMHO all you will find is burst with different name like ultraburst, superburst etc. etc.
 
User avatar
sidney
just joined
Posts: 24
Joined: Fri Sep 15, 2006 12:15 pm
Location: South africa - Pretoria East

Tue Dec 05, 2006 4:25 pm

Thanks as my sample i am using 8s burst on mater queue
and 4s on my clients
ags: X - disabled, I - invalid, D - dynamic
0 name="Master queue" dst-address=0.0.0.0/0 interface=all parent=none
direction=both priority=7 queue=PCQ_upload/PCQ_download
limit-at=512000/1000000 max-limit=1000000/2000000 total-queue=PCQ_total
total-limit-at=1024000 total-max-limit=2048000
total-burst-limit=4096000 total-burst-threshold=1536
total-burst-time=8s

1 name="Redbooks" target-addresses=10.0.50.18/32 dst-address=0.0.0.0/0
interface=all parent=Master queue direction=both priority=8
queue=PCQ_upload/PCQ_download limit-at=256000/512000
max-limit=512000/1000000 total-queue=PCQ_total total-limit-at=256000
total-max-limit=512000 total-burst-limit=1024000
total-burst-threshold=384000 total-burst-time=4s

is this a good rate or what is a beter burst time should i use
 
User avatar
jose
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Thu Sep 22, 2005 4:56 am

Tue Dec 05, 2006 11:37 pm

From mikrotik documentation
"Let us consider that we have a setup, where max-limit=256000, burst-time=8, burst-threshold=192000 and burst-limit=512000. When a user is starting to download a file via HTTP, we can observe such a situation:"

Here is the graphic:

Image

As you can see the http download is consuming ALL asigned bandwidth to the user, so that user can not surf untill the download is finished because the user is downloading at 256kbps. In other words "downloads hurt interactive traffic to that user", so I don´t want this this behaviour
 
User avatar
111111
Member Candidate
Member Candidate
Posts: 194
Joined: Thu Oct 05, 2006 1:39 am
Location: BG,SOFIA

Wed Dec 06, 2006 3:49 am

how funny is hire some one understand other on
pic1 Image
pic2 Image

what is so hard to understand pic1 begin at 12 sec at pic2

jose if user can't browse when download big files,
his download manager can be set to speed under his speed limit
(in this case problem is on hes/shes PC/MAC)
if the speed is not enought, it is time to pay for more.

Are you administrators or only lamers,
configuration is not a 1 button and you shoud click it
read manual thing read again and think better of it then do what you thing to do
this is formula (eat and drink it 1 pill per day)

sorry if some one have been affected, pained ;)
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Wed Dec 06, 2006 8:15 am

Thanks as my sample i am using 8s burst on mater queue
and 4s on my clients
ags: X - disabled, I - invalid, D - dynamic
0 name="Master queue" dst-address=0.0.0.0/0 interface=all parent=none
direction=both priority=7 queue=PCQ_upload/PCQ_download
limit-at=512000/1000000 max-limit=1000000/2000000 total-queue=PCQ_total
total-limit-at=1024000 total-max-limit=2048000
total-burst-limit=4096000 total-burst-threshold=1536
total-burst-time=8s

1 name="Redbooks" target-addresses=10.0.50.18/32 dst-address=0.0.0.0/0
interface=all parent=Master queue direction=both priority=8
queue=PCQ_upload/PCQ_download limit-at=256000/512000
max-limit=512000/1000000 total-queue=PCQ_total total-limit-at=256000
total-max-limit=512000 total-burst-limit=1024000
total-burst-threshold=384000 total-burst-time=4s

is this a good rate or what is a beter burst time should i use


Bust on PCQ??? Sorry, but I can't imagine practical need for that!
Burst is working PER QUEUE not per user in this case
Last edited by macgaiver on Wed Dec 06, 2006 8:24 am, edited 1 time in total.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Wed Dec 06, 2006 8:24 am

...
As you can see the http download is consuming ALL asigned bandwidth to the user, so that user can not surf untill the download is finished because the user is downloading at 256kbps. In other words "downloads hurt interactive traffic to that user", so I don´t want this this behaviour
Where did you get it from? In manual there is description of ideal situation with only one download connection and only one queue with burst.

Burst is like a BONUS - if you spear some of the traffic in last burst-time seconds, you will be able to use this spear traffic now, if it is available.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Wed Dec 06, 2006 9:37 am

Here is a real test for the BURST :
burst limit = 200k
burst time = 30 sec
burst threshold = 90k
max limit = 100k

Image

as you see , will calculate every 30 sec the average rate , and enable burst if the average is lower than the threshold , so it keeps calculating every 30 sec , and thats not exactly what we need ..

beside in the test I found it will apply this formula for all the connection for the single user , for the user not for each connection !!!!!

I dont know is it so hard to give a user connection high speed at the first 10 sec only , each connection , not the total user traffik ..

... I tested the Burst with PCQ , it apply the burst for the total connections of the user , not each connection alone ..
Last edited by samsoft08 on Wed Dec 06, 2006 9:59 am, edited 1 time in total.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Wed Dec 06, 2006 9:43 am

what if you will have 1000 connections, do you have unlimited bandwidth available?
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Wed Dec 06, 2006 9:56 am

...For each connection...

Let us make it clear - so if your customer currently uses 99Kbps and and make 10 new connections he should get 200Kbps. But if we will take torrent for example - it constantly creates new connections - so your customer will constantly be able to use 200Kbps - COOL!

About the picture - set burst-threshold=50k and burst time=20sek - stop the traffic for 20sek and start it over - you will be able to see 5sek burst, stop it for less time - burst will be smaller - you will not be able to see spikes anymore.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Wed Dec 06, 2006 10:25 am

it doesnt matter even if i have 1000 connections , I'm talking about the max available bandwidth , and i only want to speed up the connection first 10 sec ..

every user when he open a site he will get the max speed available , and for every site he'll open .. even if there is more than one user opening sites at the same second they'll share the max speed for the first 10 sec , after the first sec if connection still making download it will return to the max limit specified for it ..

my friends , i'm forced to find a solution , to give those users who only surfing sites the fastest speed , and for those who are the downloaders a fair speed , and that because of the very expensive bandwith we are buying 1Mbit/sec = 3000 $ .... we are using the satellite :(
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Wed Dec 06, 2006 10:58 am

It is not a burst anymore - it is traffic prioritization.

Use mangle to mark first.. lets say 200Kb of TCP connection and place it with higher priority over all other "old" ( more than 200Kb) connections.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
Hellbound
Long time Member
Long time Member
Posts: 509
Joined: Tue Oct 26, 2004 11:21 am

Wed Dec 06, 2006 11:47 am

how does the router know which download is BIG and what does it do then? slow down only the one download?
That's called A.I bandwidth shaping, something that our company is working on it. It is very difficult but there are some ways. specially when you're on Transparent proxy.
 
User avatar
jose
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Thu Sep 22, 2005 4:56 am

Wed Dec 06, 2006 11:02 pm

jose if user can't browse when download big files,
his download manager can be set to speed under his speed limit
(in this case problem is on hes/shes PC/MAC)
if the speed is not enought, it is time to pay for more.

Are you administrators or only lamers,
configuration is not a 1 button and you shoud click it
read manual thing read again and think better of it then do what you thing to do
this is formula (eat and drink it 1 pill per day)
111111,

I have some residential, corporate and cyber cafe users, so I can´t say them "Your problem is in your PC or Mac".

The solution I have when I provide service to some machines behind a corporate user is putting a Ipcop box with wondershaper installed on it, believe me it works; the interactive traffic is priorized over downloads and I install the server in matter of minutes. the customer never knows what is inside of the box because the apliance is turned on or off by pressing the power button.

samsoft08 I am going to put my mangle and queue rules here but I think you will be more confused because my setup is somewhat complicated ex. I have o couple of internet pipes one of them through pppoe and I am doing load balancing with persistent connections.

To have internet service I had to deploy a wireless network with several hops to get service from our neghbor country, so I think you could do it so.

In simple terms you have to do the following:

1 Mangle pakets according the prio you are going to give them, remember if you are doing web proxy in the same MT box use the prerouting chain to mangle packets, else forward chain. also remember you can just shape the packets leaving your router.

2 The mangled packets queue them thorugh queue trees.

3. drop p2p or aply them a prio


/ ip firewall mangle
add chain=forward out-interface=pppoeperu action=mark-packet \
new-packet-mark=upload_packet passthrough=yes comment="Uplods" disabled=no
add chain=forward out-interface=ether1 action=mark-packet \
new-packet-mark=upload_packet passthrough=yes comment="paquetes de la otra \
ruta" disabled=no
add chain=forward protocol=icmp packet-mark=upload_packet action=mark-packet \
new-packet-mark=vhgprio passthrough=no comment="icmp up" disabled=no
add chain=forward protocol=tcp tcp-flags=syn packet-mark=upload_packet \
action=mark-packet new-packet-mark=vhgprio passthrough=no comment="syn up" \
disabled=no
add chain=forward protocol=udp dst-port=53 packet-mark=upload_packet \
action=mark-packet new-packet-mark=vhgprio passthrough=no comment="Dns up" \
disabled=no
add chain=forward protocol=tcp packet-mark=upload_packet packet-size=0-64 \
action=mark-packet new-packet-mark=hgprio passthrough=no comment="paquetes \
menores a 64k up" disabled=no
add chain=forward protocol=tcp dst-port=22-23 packet-mark=upload_packet \
action=mark-packet new-packet-mark=hgprio passthrough=no comment="ssh y \
telnet up" disabled=no
add chain=forward protocol=tcp packet-mark=upload_packet \
connection-bytes=204800-4294967295 action=mark-packet \
new-packet-mark=lowprio passthrough=no comment="coneccion up de mas de \
200k tiene low prio" disabled=no
add chain=forward protocol=tcp dst-port=80 packet-mark=upload_packet \
action=mark-packet new-packet-mark=normal passthrough=no comment="http dst \
80 up" disabled=no
add chain=forward protocol=tcp dst-port=443 packet-mark=upload_packet \
action=mark-packet new-packet-mark=normal passthrough=no comment="https \
up" disabled=no
add chain=forward protocol=udp packet-mark=upload_packet action=mark-packet \
new-packet-mark=normal passthrough=no comment="udp up" disabled=no
add chain=forward protocol=tcp dst-port=25 packet-mark=upload_packet \
action=mark-packet new-packet-mark=lowprio passthrough=no comment="smtp \
up" disabled=no
add chain=forward protocol=tcp dst-port=110 packet-mark=upload_packet \
action=mark-packet new-packet-mark=lowprio passthrough=no comment="pop3 \
up" disabled=no
add chain=forward protocol=tcp dst-port=20-21 packet-mark=upload_packet \
action=mark-packet new-packet-mark=lowprio passthrough=no comment="ftp up" \
disabled=no
add chain=forward packet-mark=upload_packet action=mark-packet \
new-packet-mark=vlowprio passthrough=no comment="forward resto up" \
disabled=no
add chain=forward out-interface=av action=mark-packet \
new-packet-mark=down_packet passthrough=yes comment="Downloads \(upload \
hacia local\)" disabled=no
add chain=forward protocol=icmp packet-mark=down_packet action=mark-packet \
new-packet-mark=vhgprio-d passthrough=no comment="icmp down" disabled=no
add chain=forward protocol=tcp tcp-flags=syn packet-mark=down_packet \
action=mark-packet new-packet-mark=vhgprio-d passthrough=no comment="Syn \
down" disabled=no
add chain=forward protocol=udp src-port=53 packet-mark=down_packet \
action=mark-packet new-packet-mark=vhgprio-d passthrough=no comment="Dns \
down" disabled=no
add chain=forward protocol=tcp packet-mark=down_packet packet-size=0-64 \
action=mark-packet new-packet-mark=hgprio-d passthrough=no \
comment="paquetes menores a 64k down" disabled=no
add chain=forward protocol=tcp src-port=22-23 packet-mark=down_packet \
action=mark-packet new-packet-mark=hgprio-d passthrough=no comment="ssh y \
telnet down" disabled=no
add chain=forward protocol=tcp packet-mark=down_packet \
connection-bytes=204800-4294967295 action=mark-packet \
new-packet-mark=lowprio-d passthrough=no comment="Coneccion Down de mas de \
200k tiene low prio" disabled=no
add chain=forward protocol=tcp src-port=80 packet-mark=down_packet \
action=mark-packet new-packet-mark=normal-d passthrough=no comment="http \
src 80 down" disabled=no
add chain=forward protocol=tcp src-port=443 packet-mark=down_packet \
action=mark-packet new-packet-mark=normal-d passthrough=no comment="https \
down" disabled=no
add chain=forward protocol=udp packet-mark=down_packet action=mark-packet \
new-packet-mark=normal-d passthrough=no comment="udp down" disabled=no
add chain=forward protocol=tcp src-port=25 packet-mark=down_packet \
action=mark-packet new-packet-mark=lowprio-d passthrough=no comment="smtp \
down" disabled=no
add chain=forward protocol=tcp src-port=20-21 packet-mark=down_packet \
action=mark-packet new-packet-mark=lowprio-d passthrough=no comment="ftp \
down" disabled=no
add chain=forward protocol=tcp src-port=110 packet-mark=down_packet \
action=mark-packet new-packet-mark=lowprio-d passthrough=no comment="pop3 \
down" disabled=no
add chain=forward packet-mark=down_packet action=mark-packet \
new-packet-mark=vlowprio-d passthrough=no comment="forward resto down" \
disabled=no


/ queue tree
add name="bw-up" parent=global-out packet-mark="" limit-at=0 queue=default \
priority=1 max-limit=450000 burst-limit=0 burst-threshold=0 burst-time=0s \
disabled=no
add name="vhgprio-dw" parent=downloads packet-mark=vhgprio-d limit-at=0 \
queue=default priority=1 max-limit=1480000 burst-limit=0 burst-threshold=0 \
burst-time=0s disabled=no
add name="vhgprio-up" parent=bw-up packet-mark=vhgprio limit-at=0 \
queue=default priority=1 max-limit=450000 burst-limit=0 burst-threshold=0 \
burst-time=0s disabled=no
add name="hgprio-dw" parent=downloads packet-mark=hgprio-d limit-at=0 \
queue=default priority=2 max-limit=1460000 burst-limit=0 burst-threshold=0 \
burst-time=0s disabled=no
add name="hgprio-up" parent=bw-up packet-mark=hgprio limit-at=0 queue=default \
priority=2 max-limit=450000 burst-limit=0 burst-threshold=0 burst-time=0s \
disabled=no
add name="normal-dw" parent=downloads packet-mark=normal-d limit-at=0 \
queue=default priority=3 max-limit=1750000 burst-limit=0 burst-threshold=0 \
burst-time=0s disabled=no
add name="normal-up" parent=bw-up packet-mark=normal limit-at=400000 \
queue=default priority=3 max-limit=445000 burst-limit=0 burst-threshold=0 \
burst-time=0s disabled=no
add name="low-dw" parent=downloads packet-mark=lowprio-d limit-at=0 \
queue=default priority=4 max-limit=600000 burst-limit=0 burst-threshold=0 \
burst-time=0s disabled=no
add name="vlowprio-dw" parent=downloads packet-mark=vlowprio-d limit-at=64000 \
queue=default priority=8 max-limit=128000 burst-limit=0 burst-threshold=0 \
burst-time=0s disabled=no
add name="lowprio-up" parent=bw-up packet-mark=lowprio limit-at=128000 \
queue=default priority=4 max-limit=196000 burst-limit=0 burst-threshold=0 \
burst-time=0s disabled=no
add name="vlowprio-up" parent=bw-up packet-mark=vlowprio limit-at=64000 \
queue=default priority=8 max-limit=128000 burst-limit=0 burst-threshold=0 \
burst-time=0s disabled=no
add name="downloads" parent=av packet-mark="" limit-at=0 queue=default \
priority=1 max-limit=1750000 burst-limit=0 burst-threshold=0 burst-time=0s \
disabled=no
 
User avatar
sidney
just joined
Posts: 24
Joined: Fri Sep 15, 2006 12:15 pm
Location: South africa - Pretoria East

Thu Dec 07, 2006 12:01 pm

/ ip firewall mangle
add chain=forward out-interface=pppoeperu action=mark-packet \
new-packet-mark=upload_packet passthrough=yes comment="Uplods" disabled=no
add chain=forward out-interface=ether1 action=mark-packet \
new-packet-mark=upload_packet passthrough=yes comment="paquetes de la otra \
ruta" disabled=no
Jose i am trying your setup but need to know on your mangle you use the out-interface as ether1 is that your main surply line as our bridge to our tower is on ether2 should i just change it

thanks sidney
 
User avatar
jose
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Thu Sep 22, 2005 4:56 am

Thu Dec 07, 2006 2:46 pm

pppoeperu and ether1 are WAN connections, av is the private connection.

This is just an example, you should not have to cut and paste in your MT box because every one have a particular setup. In my case I have a couple of wateways doing load balancing with persistent connections as described in the MT wiki, so I had to delete the rules intended to mark routing in mangle to make the code clear. Also in this box I am not shaping to my customers yet. this box just joins both wateways and delivers just one load balanced and priorized internet to the box doing shapping 200k away. so av interface it is a wireless connection as you could imagine.

Also in the mangle rules you have to mark p2p traffic and doing droping and or shapping.


this is the code that marks connections greater than 200k

add chain=forward protocol=tcp packet-mark=down_packet \
connection-bytes=204800-4294967295 action=mark-packet \
new-packet-mark=lowprio-d passthrough=no comment="Coneccion Down de mas de \
200k tiene low prio" disabled=no

add chain=forward protocol=tcp packet-mark=upload_packet \
connection-bytes=204800-4294967295 action=mark-packet \
new-packet-mark=lowprio passthrough=no comment="coneccion up de mas de \
200k tiene low prio" disabled=no


btw I would appreciate any comments or suggestions to my mangle rules
 
User avatar
sidney
just joined
Posts: 24
Joined: Fri Sep 15, 2006 12:15 pm
Location: South africa - Pretoria East

Thu Dec 07, 2006 3:28 pm

Thanks Jose

i don't just cut and paste we have a AP running fine with clients on so not
bug them with new changes i use a rb532 at home as a station and within the
house i made a small ap useing the wife an kids pc's as ginnie pigs so once
i play with the setting and it works well then i put it to the test on main AP
thats how i tryed (as per sample above ) useing the simple queues making the master queue priority 7 and then the clients no 8 and some client get to 300k then it goes red and keeps them there as other client can still carry on working
this is how i have learnt mikrotik by playing with it

Sidney
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Sat Dec 09, 2006 9:02 pm

i read this article about QoS :
" Priority queuing is a method whereby the engineer can decide which packets are more likely to be thrown away rather than the router making indescriminant decisions. "

http://www.rhyshaden.com/qos.htm
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Wed Dec 13, 2006 3:45 am

WHAT IF a client uses any download accelerator ? which split a single file to 10 connections , let's say each connection will be 90kb/s then his total will be 900kb/s !!! but each connection still SMALL relatively ..

any new idea ? how to make MT a real traffic shaper which gives the browsing-only clients the highest priority without displaying PAGE CANNOT BE DISPLAYED on thier screen when some downloader are making a big download ?
 
User avatar
jose
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Thu Sep 22, 2005 4:56 am

Wed Dec 13, 2006 4:45 am

You can limit the number of connections for each ip within a subnet. it depends of the profile of each one of your customers, for instance I let every residential customer can have up to 20 simultaneous connections, but every corporate customer can have up to 80 simulteneous connections. this you can do it in /ip firewall filter.

Mikrotik it is a powerfull tool but the learning curve is somewhat tricky. If you have just one gateway you can try a simpler product with some traffic priorization inside until you have a deeper knowledege, please PM me if you are interested.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Wed Dec 13, 2006 8:39 am

WHAT IF a client uses any download accelerator ? which split a single file to 10 connections , let's say each connection will be 90kb/s then his total will be 900kb/s !!! but each connection still SMALL relatively ..

any new idea ? how to make MT a real traffic shaper which gives the browsing-only clients the highest priority without displaying PAGE CANNOT BE DISPLAYED on thier screen when some downloader are making a big download ?
It doesnt! If you set a total limit on your customer, then no matter how many connections he will open, the total speed will not exceed the limitation. I really suggest you to visit a training, because every statement you make here is incorrect. Have you even tried to configure queues, or read the manual?
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Wed Dec 13, 2006 8:14 pm

incorrect ? please sir wht is the incorrect ?
it's not an invention made by me , it exists , and used by many satellite providers ..

limiting nubmer of connections will not help , in this case 1 connection may exceed 200 kb !! while 10 connections may not reach total of 150kb !!!!!!

please normis , i like MT and i found it powerfull but there is a rule in life NOTHING is PERFECT .. and i know this rule and i know MT is not perfect and i know MT team trying hard to improve this OS ..

I think if we can make a limiting by TIME it will solve this matter .. like if we have this case :
client01 is downloading a 20Mb file by connection conn01 ..
## I dont like to limit client01 total band because i want client01 to get all the available band if only him is online ..
## I already limiting the no of conn , but his download made by 1 connection only ..
## I dont want to make prioritized shaping because may be there is another client who is just browsing and his connection reaches the same of conn01 ..
## If I applied BURST it will lower the rate of the total band of client01 not only this connection , so his browsing will be very slow ..
## I tried every trick in the book even PCQ but it doesnt help ..

so I think the only way to solve this is by somthing like this :
** IF conn01.time > 15sec then conn01.maxlimit = 50kbps
this is just an idea it maybe totaly wrong , i dont know .

please dont tell me READ the manual pleeeeeeeeeeeeeeeease ..
 
titius
Member
Member
Posts: 338
Joined: Mon Oct 17, 2005 11:43 am
Location: Titel Serbia

Thu Dec 14, 2006 1:00 am

thing that you want to do cant be done ON MT.

Or it is very hard to achieve that. BURST is the only and a very nice solution, and no in MT customer cant download wuth for example 128kbits and surf with 128kbits at the same time. Burst will make fo example first 20 seconds 256kbits speed and then drop it to 128kbits.

ON MT you CANT filter file extensions if you could do that than you will be able to make what you are asking.

Maybe it is a nice suggestion, make MT to reckognize file extensions :)
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Thu Dec 14, 2006 11:04 am

i would suggest to use BURST, and remember - every new connection WILL slow down other connection, unless your bandwidth is NOT limited.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Thu Dec 14, 2006 11:08 am

samsoft, you are still incorrect in your description. it will work as you want if you configure it according to what we said in this topic. please hire a consultant do do this for you, it seems that you just don't understand my suggestions

http://www.mikrotik.com/consultants.html

and yes RTM!
 
titius
Member
Member
Posts: 338
Joined: Mon Oct 17, 2005 11:43 am
Location: Titel Serbia

Thu Dec 14, 2006 11:27 pm

ok so at the end we can make ROS to shape downloads and leave surfing at max speed per a single user??
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Fri Dec 15, 2006 9:29 am

what is `surfing` and how do you distinguish it from `downloading`? surfing is downloading html and php files. RouterOS can make the user download faster while the bandwidth is available, and then slow down when other users start to download something. it also can allow faster download for a certain amount of time, and then slow it down after some seconds. it can also give limits to the user according to the number of other users downloading. it can also limit the number of connections it opens.

you cannot give unlimited surfing speed to all users, it is impossible even in theory! you will run out of bandwidth! if you have 1Mbit upling, and 100 users that all want unlimited surfing, you will kill the bandwidth and your users will slow down because of it. it is simply not possible.
 
User avatar
GWISA
Member
Member
Posts: 394
Joined: Tue Jan 31, 2006 2:37 pm
Location: Johannesburg, South Africa

Fri Dec 15, 2006 11:29 am


ON MT you CANT filter file extensions if you could do that than you will be able to make what you are asking.

Maybe it is a nice suggestion, make MT to reckognize file extensions :)
But you can, to a degree, with MIME values...

For instance, use "video/x-msvideo" in firewall filter rule advanced/content field for avi files...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Fri Dec 15, 2006 11:30 am

it is possible with webproxy access lists.
 
titius
Member
Member
Posts: 338
Joined: Mon Oct 17, 2005 11:43 am
Location: Titel Serbia

Fri Dec 15, 2006 2:30 pm

Normis,

I know that surfing is downloading :), but when surfing, I for example want to download *.rar and size of that file is 120 MB, when I start download BURST will allow first n seconds 128kbps and after n seconds it will shape me to 64kbps, AND NOW IS THE QUESTION :), can MT ROS, shape that *.rar download to 64kbps and let me surf tha web with 128kbps, tha is the question
that "samsoft08" asked.

For me BURST works like a charm, but just want to make clear, surf is download ok, but extensions HTML and RAR are not the same things.

And proxy access lists well.... I havent looked at it yet :)
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Fri Dec 15, 2006 4:09 pm

Let me explain hoew to realize QoS in 2 steps


1) traffic prioritization - mangle traffic by type (first 200k, last 200k, p2p, icmp etc) in prerouting and prioritize it in global-in (using only queue tree) - WITHOUT ANY LIMITATION - only priorities - this way all packets will be arranged in to your determined sequence!

2) traffic shaping - RE-MANGLE traffic by users in mangle chain forward, and place limitation on the interface queues (using PCQ for example) - this way you will be dropping last traffic from the sequence you made earlier

Thats all folks!!! It took me one Mikrotik Advanced QoS training + 2 weeks to handle
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Fri Dec 15, 2006 8:51 pm

please normis , leave the manual and consultation .. and just tell me if its not possible , i'm wasting my time with trying ..

ok , can I use burst for EACH CONNECTION alone , not for EACH USER and not for TOTAL BANDWIDTH ..
and can I apply that burst with PCQ ? that burst for EACH CONNECTION.
note : without using SIMPLE QUEUE couse i dont want to limit the user bandwidth ..
 
titius
Member
Member
Posts: 338
Joined: Mon Oct 17, 2005 11:43 am
Location: Titel Serbia

Sat Dec 16, 2006 1:50 am

come on buddy, what do you want for a few bucks ;), mikrotik is a great software but it cant do everything.
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Sat Dec 16, 2006 1:57 am

so its a matter of cost !!! well , i have to apologize .
 
titius
Member
Member
Posts: 338
Joined: Mon Oct 17, 2005 11:43 am
Location: Titel Serbia

Sat Dec 16, 2006 2:00 am

no it is a matter of immagination ;) and practice
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Sat Dec 16, 2006 2:05 am

is there any method to calculate the connection time ?
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Sat Dec 16, 2006 2:05 am

is there any method to calculate the connection time ?
 
User avatar
jose
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Thu Sep 22, 2005 4:56 am

Sat Dec 16, 2006 2:21 am

Sam

Why do you close your mind?

With the tools you have in MT is enough to provide a shaping/priorization of the bandwidth either satellite or fiber. I tell you this because I have used both satellite and fiber wateways where bandwidth is expensive in my country and
I can see a BIG difference when the shaping rules are disabled.

regards
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Sat Dec 16, 2006 9:15 pm

ok jose, with your open minded please answer me : can I use burst for EACH CONNECTION alone , not for EACH USER and not for TOTAL BANDWIDTH ..
and can I apply that burst with PCQ ? that burst for EACH CONNECTION.
note : without using SIMPLE QUEUE couse i dont want to limit the user bandwidth ..
 
wildbill442
Forum Guru
Forum Guru
Posts: 1050
Joined: Wed Dec 08, 2004 7:29 am
Location: Sacramento, CA

Sat Dec 16, 2006 11:17 pm

incorrect ? please sir wht is the incorrect ?
it's not an invention made by me , it exists , and used by many satellite providers ..
samsoft08,

Many satellite providers cap the amount of data users can download. Basically you get say 600kbps that you're subscribed for, but after you download 10GB of data you get knocked down to 100kbps.

So it may appear like it's happening for downloads, but its just that those users are hitting the maximum allowed bandwidth for a single day. Read the "fair use policies" for some of the bigger Satellite ISP's in the US (starband, direcway, wildblue).

They all use a similar method to limit those who "hog" bandwidth or go over their allowed bandwidth for the day and drop them down to a lower transfer rate.

I believe Mikrotik is capable of this, I haven't had the need for it because Fiber is so readily available and cheap here. ;)

As far as limiting bandwidth per connection ... that made me chuckle ...

(I believe the daily limit for satellite connections is much lower than 10GB/day)
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Sun Dec 17, 2006 12:17 am

fair use policies is another subject .. its not what i need here ..
 
titius
Member
Member
Posts: 338
Joined: Mon Oct 17, 2005 11:43 am
Location: Titel Serbia

Sun Dec 17, 2006 1:09 pm

Look Sam,

You cant burst single connection, the end.
 
jo2jo
Forum Veteran
Forum Veteran
Posts: 958
Joined: Fri May 26, 2006 1:25 am

Sun Dec 17, 2006 5:34 pm

why not do a simple queue for EACH Ip address or a group of IPs...

and allow bursting on that so you could have 2 or more ppl bursting at one time
:beep :beep :beep
 
titius
Member
Member
Posts: 338
Joined: Mon Oct 17, 2005 11:43 am
Location: Titel Serbia

Sun Dec 17, 2006 11:02 pm

jo2jo this is not a problem please read first post :)
 
User avatar
plam40
newbie
Posts: 29
Joined: Tue Feb 21, 2006 1:27 pm
Location: Greece

TOO MANY WORDS AND NO SOLUTION ?

Wed Dec 20, 2006 8:48 pm

I THOUGHT THE FOURUMS ARE MADE TO PROVIDE PEOPLE A CONECTION TO OTHER PEOPLE HAVING COMMON PROBLEM AND FOUND A SOLUTION TO IT ... I FIND IT VERY MEAN TO WAIST TIME WRITING IN A FORUM JUST TO SAY TO THE "OTHER GUY" THAT HE "DOESN"T KNOW" ... WELL IF HE KNEW HE WOULDN'T BE ASKING ... WOULD HE ? GUYS WITH ALL THESE POST YOU STILL DID NOT TRY TO UNDERSTAND THAT PERSON OR YOU UNDERSTOOD HIM BUT BECAUSE OF NO SOLUTION YOU ARE HIDING BEHIND PHRASES LIKE " READ THE MANUAL " READ , READ , READ . WHAT IS WRONG WITH ASKING FOR HELP ? NO BODY I OBLIGATED TO ANSWER IF HE DOES NOT FEEL LIKE !!! WHY SHOULD ONE ASK FOR HELP IF HE IS GOING TO RECIEVE ONLY POST TELLING HIM WHER THE MANUAL IS ... WHAT IF A GUY HAD SAME PROBLEM AND FOUND A SOLUTION... THAT TOOK HIM A WEEK OF HARD THINKING . WHY NOT SHARE HIS EXPIRIANCE AND NO OTHER GUY LOSE SAME TIME FOR ACHIEVING SAME RESULTS ... THAT IS HOW THE PROGRES IS BEING STOPPED ... WELL I THINK I SHOULD EXPLAIN IT MORE SIMPLE SO YOU WILL GET A BETTER PICTURE !

LET SAY I AM SURFING THE WEB (downloading .htm .html) AND VOILA I FOUND A FILE I WANT TO DOWNLOAD >>> I PRES GET THE FILE ... THE FILE IS DOWNLOADING ( .AVI) AT THE MEAN TIME I DECIDE TO READ THE NEWS ON BBC ... BUT THE PAGE IS SOO SOO SLOW ! Whyyy ?
BECAUSE MY FILE IS EATING NEARLY ALL MY LIMIT ... WHAT IS WRONG ...
IS THERE A WAY TO MAKE THIS FILE GO SLOWER FOR 5 SECONDS UNTIL THE PAGE WITH THE NEWS IS LOADED AND THEN GO TO SAME SPEED AGAIN ... UNTIL I DECIDE TO OPEN ANOTHER PAGE ...
MAY BE THIS WILL HELP YOU UNDERSTAND WHAT HIS SIMPLE PROBLEM IS .

I REALLY HOPE YOU CHANGE THE PURPUSE OF WRITING IN THE FORUM.
THERE IS NO MEANING OF WRITNG SOMETHING THAT WOULD NOT HELP ANY ONE !!!

SORRY IF I AM OFFENDING SOME PEOPLE. BUT THIS IS SECOND TIME I SEE SAME RREACTION OF PEOPLE ON THE FOURUM AND MY PERSONAL OPINION IS CLEAR- I DO NOT LIKE THIS !!!

THANKS FOR READING
 
titius
Member
Member
Posts: 338
Joined: Mon Oct 17, 2005 11:43 am
Location: Titel Serbia

Thu Dec 21, 2006 12:12 am

IN ROUTER OS >> NO THERE IS NOT << ;)
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Thu Dec 21, 2006 11:00 am

1. do not use caps, we always can set bigger font if we like to.

2. yes, this feature you describe would be very effective, if some could implement this without big overhead as it is possible now. and there are many complications if you try to implement it.

3. "the other guy" who asked question was replied with solution that he did not evaluate or misunderstood and did not nothing about problem - just trashing in the forum.

4. problem as i see it - there is limited bandwidth available for unlimited amount of downloaders as all connections download someting, no matter how long and at what speed - they are downloading file after file, and web browser or any other program decides what to do with these files - interpret it and show it to person or save it silently, or provide user with some save dialog, does not matter. Big downloads usualu downloads for a long time, and as tcp does - it tries to get more and more bandwidth for transfer, so if you have no limitations - at the end one big download will conquer all the bandwidth available.

5. now the conclusion
if you set some simple bandwidth limitations there will be always some leftover to use for burst, so if someone is trying to open web page (do small download of multiple small files) then he will get burst for limited amount of time - web page opens quickly and everyone is happy - one who downloads big file will continue at constant speed and other guy will browse.
if you manage to create even more complicated configuration then you can split bandwidth available to one user in parts, so he can download big files and effectively browse (do casual, small downloads of files)

6. if you have more information about habitat of problem, this time networking you can come up with different solutions. but if you DON'T you will whine all the time that there is lack of options. and as showed this topic many users here have their opinion about certain features - that they will not reconsider.

7. if you know a solution that is used somewhere else - then provide with information, and not just simple guesses, how this is accomplished, what is the price of solution. who is providing solution
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Thu Dec 21, 2006 11:23 am

3. "the other guy" who asked question was replied with solution that he did not evaluate or misunderstood and did not nothing about problem - just trashing in the forum.

first : the other guy got a nick name ..
second : you think that was a solution for a problem you didnt understand .. how can you solve a problem you cannot understand ??
third : as i read ur reply , you still dont understand the problem and suggesting some solutions got nothing to deal with the main problem ..... for god sake we know LIMIT , BURST , CONN LIMIT .........please
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Thu Dec 21, 2006 11:30 am

this is good, that you understand terms and know how to configure these properties correctly to achieve results you want.

the problem you described suits burst very well, but solution you want to is not possible.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Thu Dec 21, 2006 2:03 pm

i made example as far as i could understand your need. Correct me if i am wrong!

EDIT:

forgot to add link :oops:
here: http://forum.mikrotik.com//viewtopic.ph ... highlight=
 
User avatar
plam40
newbie
Posts: 29
Joined: Tue Feb 21, 2006 1:27 pm
Location: Greece

Thu Dec 21, 2006 7:18 pm

Just would like to say excuse me for using CAPS ...
 
User avatar
Equis
Forum Veteran
Forum Veteran
Posts: 888
Joined: Mon Jun 06, 2005 6:48 am

Thu Dec 21, 2006 11:49 pm

Hello

Just a theory

What if you had a pcq rule based on src port alone and not src IP address?

Then have bursting set on that?

(talking out of thin air, perhaps someone could add to idea?)

:)
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Fri Dec 22, 2006 9:22 am

Hello

Just a theory

What if you had a pcq rule based on src port alone and not src IP address?

Then have bursting set on that?

(talking out of thin air, perhaps someone could add to idea?)

:)
You will have burst only on the total queue, but inside the queue connections will be arranged in groups by src-port, each group will get equal part of the total queue traffic.

Just use example that was provided by Janisk :
http://forum.mikrotik.com/viewtopic.php?t=12870
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
ofasa
Member Candidate
Member Candidate
Posts: 104
Joined: Tue Jul 20, 2004 11:42 pm

Fri Dec 22, 2006 11:24 am

What you need can only be achieved in MT if bursting is added to PCQs. Possibly this can be added?
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Fri Dec 22, 2006 12:27 pm

why would you add additional burst to configuration i created? :shock: :shock:

try to explain your thought, and did you check at all what that configuration does? :twisted:

this configuration differs from burst with that - if you download is bigger that some predefined value - it will never ever hit more bandwidth level, while if using burst mode, if download average download speed drops below burst threshold, you could again get burst for your download.
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Fri Dec 22, 2006 1:47 pm

this example is not more than a new version of the other PRIORITIZED QUEUE which is not the solution here ..

Priority queuing is a method whereby the engineer can decide which packets are more likely to be thrown away rather than the router making indescriminant decisions
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Fri Dec 22, 2006 1:51 pm

did you test it?

did you evaluated?

it seems you do not know what are you doing :twisted:

and as i wrote in post - that i assumed that there is ONLY available 5Mbits up and 5Mbits down traffic, so, that is the limitation. and no packets are dropped , as far as i have tested, since you complain that packets where dropped - i see you do not have a clue what is going on in that example :twisted:

so stop flaming here - that nothing works or attend training and learn about QoS.
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Sat Dec 23, 2006 10:07 am

it seems that u have shares in MT ?? :lol:

MT is good but its not perfect .. it can do every thing but its not the top software in everything .. dont forget price/performence !!!!!

the summery of your example is prioritizing packets , whatever you do in mangle , at the end you make packet goes depending on the priority , this wouldnt give me the curve that I posted at first ..

the solution is so so easy , let any CONNECTION get the MAX speed it can get for n second , then limit this connection to a specific speed for whatever time it takes ..... but i need someone who can TRANSLATE that in MT .. thats all ..
 
advantz
Member Candidate
Member Candidate
Posts: 187
Joined: Thu Jul 08, 2004 4:11 am

Sat Dec 23, 2006 3:51 pm

squid feature : body size, come in handy in this case...

e.g body size larger than 1Mb -> set queue to 64kbps otherwise set 256kbps...
of course simple html and php usually doesn't have size larger than 1Mb

mikrotik didn't have this! :D
Tag Name reply_body_max_size
Usage reply_body_max_size (KB)

Description
This option specifies the maximum size of a reply body. It can be used to prevent users from downloading very large files, such as MP3's and movies. The reply size is checked twice. First when we get the reply headers, we check the content-length value. If the content length value exists and is larger than this parameter, the request is denied and the user receives an error message that says "the request or reply is too large." If there is no content-length, and the reply size exceeds this limit, the client's connection is just closed and they will receive a partial reply.
Default reply_body_max_size 0
If this parameter is set to zero (the default), there will be no limit imposed.

Caution
Downstream caches probably cannot detect a partial reply if there is no content-length header, so they will cache partial responses and give them out as hits. You should NOT use this option, if you have downstream caches.
 
titius
Member
Member
Posts: 338
Joined: Mon Oct 17, 2005 11:43 am
Location: Titel Serbia

Sat Dec 23, 2006 6:06 pm

that is the point mikrotik cant dio what samsoft asks ;)
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Sun Dec 24, 2006 5:26 pm

this is a smart solution .... thanks advantz ... i hope that MT team would not ignore this issue ...
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Wed Dec 27, 2006 8:50 am

if you want limitations OFF for some time then it is BURST as you can set time limits there

if you want limitations OFF for some amount of data use my example and adjust to what you r network is able to handle. but leaving some space for "long downloads"

like you have 36MBit/s duplex

then using my example set main queues to 36000000, and then for short set like 25000000 and maximum of 36000000 and rest packet queues set like 11000000 and max limit of 36000000
you can even more adjust these settings to your liking.

if you knew MT configuration, if you knew what can be done then this request:

[quote=samsoft08]the solution is so so easy , let any CONNECTION get the MAX speed it can get for n second , then limit this connection to a specific speed for whatever time it takes
[/quote]

you would BY YOURSELF altered settings of "rest" queue to something like limit-at 0 and max-limit=<size of queue>

as i see you cannot handle this task by yourself, as it is obvious (at least for me), your knowledge is very limited about QoS and i would recommend to hire a consultant for further challenges. :twisted:
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Thu Dec 28, 2006 2:27 pm

janisk how come you are such an expert and you couldn't understand an easy task like this ??
anyway i'm not waiting your advice to hire a consultant , i know very well my limitation but at least i can THINK ..

one last think read advantz reply and you MAY understand whts going on in the world ..
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Thu Dec 28, 2006 2:42 pm

please state at what points my solution does not solve your problem?

arguments like - i do not like this, i no not want solution that already exist, i want alternative - will not be counted.

as i saw your problem

1) user with new connection gets lots of traffic - it is so
2) user with old/long download have lots of traffic is none is browsing - it is so
3) traffic is divided evenly to user - it is so.
4) it should be highly adjustable - it is.

am i missing anything? or you will change you rules once again?

p.s. consultant is your friend :roll:

p.p.s. i am not consultant
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Thu Dec 28, 2006 3:07 pm

hey anybody knows how to close a topic !!!!!!!!!!!!!!!!
I QUIT ...
I 'll sell my MT ..
I'll uses d-link router ..
please ..
 
Ozelo
Member
Member
Posts: 338
Joined: Fri Jun 02, 2006 3:56 am

Fri Dec 29, 2006 12:50 am

Funny... *period*

Wait a minute, I find this thread useful useful on various aspects. Specialy cuz that chart (not the manual one) bring more light where is not completely dark. Anyway, I would like to say that I do use MT ROS QoS and there is no packet drop at all. Lets say, a full 20mbits link usage made by traffic A and traffic B types. The link is full already, traffic A has high priority than traffic B, but traffic A has a queue type pfifo of 10 packets and traffic B has a queue type pfifo of 5000 packets. I dont know really how bad can be the very high latency you can get with big fifo queues for some kind of traffics, but while the low prio traffic fills that big queue, the high prio traffic flow like a charm. Of course, if the low prio queue gets totaly filled it would drop packets away. I barely see my QoS low prio traffic reaching about half of that and bursts rocks! Ive seen some queue types holding about 50 mbytes of data before start droping packets. You may see wierd stuff arround about it, but thats the idea. I love MT, plus I have about a hundred of them and also, WORKs very well for me so far. Thanks. :)
 
mmx
just joined
Posts: 12
Joined: Thu Dec 21, 2006 12:07 pm

Fri Dec 29, 2006 1:09 pm

What DLINK model are you using for QoS?
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Sat Dec 30, 2006 5:03 pm

do you know what does 20Mbit in satellite world means ???????????
i'll whorship MT if i have 3Mbit not 20Mbit !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
actually ....i won't use any Qos if i have 3Mbit ..............................
 
titius
Member
Member
Posts: 338
Joined: Mon Oct 17, 2005 11:43 am
Location: Titel Serbia

Sat Dec 30, 2006 6:10 pm

Oh yes you will ;).
 
advantz
Member Candidate
Member Candidate
Posts: 187
Joined: Thu Jul 08, 2004 4:11 am

Sun Dec 31, 2006 3:28 am

I think the only solution for samsoft08 for now is queue tree or simple queues with parent.
 
titius
Member
Member
Posts: 338
Joined: Mon Oct 17, 2005 11:43 am
Location: Titel Serbia

Sun Dec 31, 2006 5:48 am

yes it is, or SQUID along with MikroTik
 
User avatar
samsoft08
Long time Member
Long time Member
Topic Author
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Sun Dec 31, 2006 5:08 pm

my friends , please , I peg you , leave this idea , its just an idea ..

Who is online

Users browsing this forum: MSN [Bot] and 63 guests