Community discussions

MikroTik App
 
undecided
Member Candidate
Member Candidate
Topic Author
Posts: 107
Joined: Mon May 16, 2011 11:07 am

Hotspot MAC Authorization failure

Thu Aug 24, 2017 9:48 am

Hi all, I've got a problem with users not authorizing with my Mikrotik hotspot database. I'm using the built-in radius with MAC auth, I have 1000's of user accounts and have currently 300+ active. Every time I reboot the router I get only around half my active users re-authenticating, if I look under the Hosts tab on the Mikrotik I see the remaining users with the "H" (not authorized) and if I open their accounts in user manager I see they have airtime, I then have to remove their airtime and re-add it to the account, they will then authenticate and come up as authorized on the hotspot.

/ip hotspot profile
add hotspot-address=10.1.12.254 http-cookie-lifetime=4w2d login-by=mac,cookie,http-chap,trial,mac-cookie name=hsprof1 trial-uptime-limit=10m trial-user-profile=trial use-radius=yes
/ip hotspot
add address-pool=dhcp_pool3 disabled=no idle-timeout=none interface=hotspot name=hotspot profile=hsprof1

Anyone else suffer similar? I was on v6.39 and I've now upgraded firmware and software to latest and still the issue persists.
 
billjellis
newbie
Posts: 37
Joined: Mon Dec 15, 2014 11:04 pm

Re: Hotspot MAC Authorization failure

Thu Dec 07, 2017 5:59 pm

I am having a similar issue i am using a 3rd party captive portal. The guest devices shows up time of 2 days but an idle time of 1 day and they cannot get connected. I delete the entry in hosts and they then get the captive portal. Ideas?

Thanks
Bill
 
Andree
just joined
Posts: 2
Joined: Fri Dec 01, 2017 3:58 am

Re: Hotspot MAC Authorization failure

Sat Dec 09, 2017 11:29 am

Rather, the RADIUS server is single-threaded and does not have time to answer all at once. You need to repeat the requests later and look at the RADIUS query log. What is not suitable for self-authorization via the web profile of the hotspot?

Who is online

Users browsing this forum: altermeinhausbrennt, ofca and 63 guests