Community discussions

MikroTik App
 
mitchmix99
just joined
Topic Author
Posts: 7
Joined: Tue Aug 29, 2017 12:26 pm

PPPoE best use of public IPs

Tue Aug 29, 2017 12:41 pm

Hello - hopefully a straight forward one....

We have several relay sites that have wireless access points with CPE connected.
Some of the CPE (but not all) want a static IP.
I am doing this with PPPoE and running PPPoE at each relay rather than centrally (I have reasons for doing it like this).
I have a /25 public IP range that I wish to use as sparingly as possible. As some sites might only need 1 or 2 CPE with public IPs, how is best to achieve this without wasting public IPs on subnet's that are larger than what I need?

At the moment, I give clients a static IP per ppp secret rather than using a pool as that works well for a per user basis of public IPs.

/ppp secret add local-address=1XX.XXX.XXX.112 name=user1@relay1 password=somepassword \
profile=My-Standard remote-address=1XX.XXX.XXX.113

/interface pppoe-server server
add default-profile=My-Standard disabled=no interface=My-PPPoE max-mru=\
1492 max-mtu=1492 mrru=1600 service-name=MyService

The main bit I'm struggling with is the use of the local-address . I can give remote address (what the client gets) as a /32 and that's efficient. If each PPPoE needs a local-address, that's fine, I just want confirmation that it is the case or if there's a better way of doing things.

Do I need to use a local-address on each site so there is some reference on the router to the public IP or can I drop this and just a /32 on the PPPoE remote address and leave it at that?

Any points would be appreciated.

Thanks
MM99
 
User avatar
pukkita
Trainer
Trainer
Posts: 3037
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: PPPoE best use of public IPs

Tue Aug 29, 2017 12:59 pm

I am doing this with PPPoE and running PPPoE at each relay rather than centrally (I have reasons for doing it like this).
I have a /25 public IP range that I wish to use as sparingly as possible. As some sites might only need 1 or 2 CPE with public IPs, how is best to achieve this without wasting public IPs on subnet's that are larger than what I need?
Just make PPPoE server assign them to the customers as the remote PTP end. I assume you're running OSPF between all relays and provider edge router.
The main bit I'm struggling with is the use of the local-address . I can give remote address (what the client gets) as a /32 and that's efficient. If each PPPoE needs a local-address, that's fine, I just want confirmation that it is the case or if there's a better way of doing things.

Do I need to use a local-address on each site so there is some reference on the router to the public IP or can I drop this and just a /32 on the PPPoE remote address and leave it at that?
Local address is only used by the relay and customer pppoe end. No, it hasn't to be different, usual practice is using the same one (usually on a loopback device) used for router ID for all PPPoE users.

You can use any IP though.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
mitchmix99
just joined
Topic Author
Posts: 7
Joined: Tue Aug 29, 2017 12:26 pm

Re: PPPoE best use of public IPs

Tue Aug 29, 2017 2:27 pm

Hi Pukkita,

Thanks for the info.

Yes, we run OSPF between all relay sites.

So I could just pick one of my public IP addresses and use this as the "local-address" on all the PPPoE servers at each relay? The local-adderss doesn't actually serve any routing function?

Thanks for the quick reply.

MM99
 
User avatar
pukkita
Trainer
Trainer
Posts: 3037
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: PPPoE best use of public IPs

Tue Aug 29, 2017 3:26 pm

No, not for the local address, but for remote-address of the specific customer needing it. Local address should/could be the same for all pppoe users on a given router, and it's usually a private one as it won't be using by anything else than local traffic between its pppoe users and the router.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
mitchmix99
just joined
Topic Author
Posts: 7
Joined: Tue Aug 29, 2017 12:26 pm

Re: PPPoE best use of public IPs  [SOLVED]

Tue Aug 29, 2017 6:04 pm

OK great. That clears it up for me.

Thanks

Who is online

Users browsing this forum: Baidu [Spider], carlosdaff, gourgovind, ingdaka and 44 guests