Community discussions

MikroTik App
 
User avatar
laxmimikrotik
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Tue Apr 25, 2017 1:44 pm

Mikroitk BGP Dual Loadbalancing problems

Sun Sep 10, 2017 8:36 am

I have configured these below configuration in my mikrotik core router but the problem is here
my outgoing traffic is going properly based on the PBR but my incoming traffic is not coming properly
based on my incoming filter rule.Sometimes it's coming properly but sometimes it's not coming
properly .



/routing bgp instance
set default as=333

/ip address
add address=1.1.1.2/30 comment=IDEA interface=ether1 network=1.1.1.0
add address=2.2.2.2/30 comment=VODA interface=ether2 network=2.2.2.0

/ip firewall address-list
add address=102.0.0.0/24 list=IDEA_OUT
add address=103.0.0.0/24 list=IDEA_OUT
add address=100.0.0.0/24 list=VODA_OUT
add address=101.0.0.0/24 list=VODA_OUT



/ip firewall mangle
add action=mark-routing chain=prerouting new-routing-mark=IDEA_OUT passthrough=\
yes src-address-list=IDEA_OUT
add action=mark-routing chain=prerouting new-routing-mark=VODA_OUT passthrough=\
yes src-address-list=VODA_OUT


/ip route
add distance=1 gateway=1.1.1.1 routing-mark=IDEA_OUT
add distance=1 gateway=2.2.2.1 routing-mark=VODA_OUT
add distance=3 gateway=2.2.2.1,1.1.1.1


/routing bgp peer
add in-filter=IDEA_IN name=IDEA out-filter=IDEA_OUT remote-address=1.1.1.1 \
remote-as=222 ttl=default
add in-filter=VODA_IN name=VODA out-filter=VODA_OUT remote-address=2.2.2.1 \
remote-as=111 ttl=default

/routing bgp network
add network=100.0.0.0/24 synchronize=no
add network=101.0.0.0/24 synchronize=no
add network=102.0.0.0/24 synchronize=no
add network=103.0.0.0/24 synchronize=no


/routing filter
add action=accept chain=IDEA_IN prefix=0.0.0.0/0
add action=accept chain=VODA_IN prefix=0.0.0.0/0
add action=accept chain=IDEA_OUT prefix=102.0.0.0/24
add action=accept chain=IDEA_OUT prefix=103.0.0.0/24
add action=accept chain=IDEA_OUT prefix=100.0.0.0/24 set-bgp-prepend=4
add action=accept chain=IDEA_OUT prefix=101.0.0.0/24 set-bgp-prepend=4
add action=discard chain=IDEA_OUT prefix=0.0.0.0/0
add action=accept chain=IDEA_OUT prefix=100.0.0.0/24
add action=accept chain=VODA_OUT prefix=101.0.0.0/24
add action=accept chain=IDEA_OUT prefix=102.0.0.0/24 set-bgp-prepend=4
add action=accept chain=IDEA_OUT prefix=103.0.0.0/24 set-bgp-prepend=4
add action=discard chain=IDEA_OUT prefix=0.0.0.0/0



Sometimes my IDEA traffic is coming on VODAFONE and sometimes VODAFONE traffic is coming on IDEA link
Thanks.
-------------------------------
Every problem Has Solution .
ip-noc Team.
MTCNA ,MTCRE,
 
amity2kare
newbie
Posts: 35
Joined: Tue Feb 13, 2007 4:24 pm
Location: INDIA

Re: Mikroitk BGP Dual Loadbalancing problems

Mon Sep 25, 2017 4:53 pm

What exactly are you tryig to achieve? If you need simple load balancing, maybe you should try advertising all 4 pools to both Voda and Idea and using prepend to balance traffic. Maybe if you explained your requirement in some more details, we could help.

Who is online

Users browsing this forum: atakacs, biomesh, sindy and 98 guests