Community discussions

MikroTik App
 
User avatar
Jesse6
just joined
Topic Author
Posts: 6
Joined: Fri Nov 17, 2017 6:35 pm
Location: Brazil

Customers suggestions to RouterOS' IPv6 module

Sat Nov 18, 2017 2:18 am

As a guy who is always aiming the future of internet, I think Mikrotik team should give some more focus on improving IPv6 funcionality in RouterOS, because IPv6 is right here, right now, it is working, and it is already the new Internet Standard; so, I've opened this topic for suggestions, and debate about how RouterOS' IPv6 can become better. Here is what I miss when using IPv6 on RouterOS implementation:

- VRF (i.e., also mark-routing and routing-mark) support for IPv6 (I've seen a long long time ago (about 7 years or more) an old topic with someone answering that Mikrotik team can't have VRF implementations because of Linux Kernel not properly supporting it on IPv6);
- Radius integration with DHCPv6-PD delegated prefix, and IPv6 Firewall Address-list manipulation in Radius, it is useful in many ways (this is actually what freezes me on implementing IPv6, the inability to properly work this functions with Radius server);
- Customizable lease-time for dynamic DHCPv6 servers, created by pool, for example (the actual 'default' is 3d 00:00:00);
- /127 implementation (as I said before, harmful or not, it will continue to be optional, but having it, makes Mikrotik compatible with more network scenarios, and equipment);
- IPv6 VPN services support (I don't know what exactly work or not with IPv6 addresses, but, I remember trying to configure SSTP with IPv6 address, and failing).

Any suggestions, clarification, agreement or disagreement are welcome, even better if it comes from Mikrotik team.
 
patrick7
Member
Member
Posts: 302
Joined: Sat Jul 20, 2013 2:40 pm

Re: Customers suggestions to RouterOS' IPv6 module

Sat Nov 18, 2017 2:22 am

It will be fixed with RouterOS v7 (TM)
 
User avatar
Jesse6
just joined
Topic Author
Posts: 6
Joined: Fri Nov 17, 2017 6:35 pm
Location: Brazil

Re: Customers suggestions to RouterOS' IPv6 module

Sat Nov 18, 2017 6:49 pm

I have to add that: the option to define preferred source address for each routing is very interesting too, and I miss it when I use private IPv6 to do point-to-point (fc00::/7), and the router tries to generate traffic to internet using fc00::/7, and, of course, it fails. Example:

Code: Select all

/ipv6 addres add address=2001:db8::c001/64 comment="Public network" interface=ether1;
/ipv6 address add address=fd00::2/126 comment="Private serial link" interface=ether2;
/ipv6 route add gateway=fd00::1 distance=254 comment="Default route to private gateway";
With the example above, when I try to ping IPv6 internet using router, it uses the IP fc00::2 (that is private) instead of using 2001:db8::c001. With the following, it will work correctly:

Code: Select all

/ipv6 addres add address=2001:db8::c001/64 comment="Public network" interface=ether1;
/ipv6 address add address=fd00::2/126 comment="Private serial link" interface=ether2;
/ipv6 route add gateway=fd00::1 distance=254 pref-src=2001.db8::c001 comment="Default route to private gateway";
 
whitbread
Member Candidate
Member Candidate
Posts: 109
Joined: Fri Nov 08, 2013 9:55 pm

Re: Customers suggestions to RouterOS' IPv6 module

Sun Nov 19, 2017 8:11 am

IMHO IPv6 is a dead concept.

Either IPv8 comes to life or I will die before being forced to use IPv6...
 
User avatar
Jesse6
just joined
Topic Author
Posts: 6
Joined: Fri Nov 17, 2017 6:35 pm
Location: Brazil

Re: Customers suggestions to RouterOS' IPv6 module

Thu Nov 23, 2017 12:55 pm

I feel sorry for your cancer, man. But, perhaps, before you die, you should read this: https://tools.ietf.org/html/rfc8200. The relevant concept about it is: "the IP version 6 is the new internet standard."
 
paulohf
just joined
Posts: 7
Joined: Tue Dec 09, 2008 5:28 pm

Re: Customers suggestions to RouterOS' IPv6 module

Fri Feb 09, 2018 3:21 am

It will be fixed with RouterOS v7 (TM)
What is the forecast for release of version 7?
These features are extremely important to many ISPs.
 
User avatar
acruhl
Member
Member
Posts: 368
Joined: Fri Jul 03, 2015 7:22 pm

Re: Customers suggestions to RouterOS' IPv6 module

Fri Feb 09, 2018 5:42 am

Heh, you're new.

"Fixed in v7" is a euphemism for "it will be a while", or less optimistic, "it will never happen".
Stuff.

Who is online

Users browsing this forum: Bing [Bot], eworm, Google [Bot], sindy and 62 guests