Community discussions

MUM Europe 2020
 
jeroenvt
just joined
Topic Author
Posts: 2
Joined: Thu Nov 23, 2017 1:59 pm

hAP mini looses all settings after reboot

Thu Nov 23, 2017 2:05 pm

I have a Mikrotik hAP mini, which I can configure via the web-interface and change any setting (SSID, passwords , etc). However, every time that I reboot (either via the webinterface, or by switching power off) all my settings are lost and the default factory settings are loaded instead. In the mean time, I have tried many things, like resetting by holding the reset button for 5 sec during boot, or a netinstall by holding the button for 15 seconds, but nothing helped. What could be the problem?
 
satspy
just joined
Posts: 4
Joined: Sun Sep 10, 2006 11:37 pm
Location: Vinkovci
Contact:

Re: hAP mini looses all settings after reboot

Wed Jan 24, 2018 10:44 am

Hi !

I have same problems, 6.41 version.

Two pieces of device, both looses all settings after power cut.
Help !!

Best regards !
 
User avatar
LucZWFM
Member Candidate
Member Candidate
Posts: 127
Joined: Tue Dec 26, 2017 10:47 pm
Location: Bergen op Zoom, The Netherlands

Re: hAP mini looses all settings after reboot

Wed Jan 24, 2018 12:55 pm

I have this problem with some SXT5HPnD devices and was never able to find out what's wrong...

The problem occours when doing the setting via webfig, maybe I should try with Winbox and see what happens...
Volunteer Techie @ZuidWest FM / ZuidWest TV, Stichting Repeater Bergen op Zoom & WRLP CB Repeater
 
jeroenvt
just joined
Topic Author
Posts: 2
Joined: Thu Nov 23, 2017 1:59 pm

Re: hAP mini looses all settings after reboot

Wed Jan 24, 2018 7:43 pm

I have found a workaround by opening a "New Terminal" from the Webfig, or ssh directly into the router. At some point I opened a terminal from the Webfig interface. Then, to my surprise it did not give the command prompt directly, but it first displayed the full defconf script. I had to scroll down to the end (pressing space bar) before I got to the command prompt. Then I changed some settings again (not in the terminal, but in Webfig) and the settings that I changed suddenly remained after a reboot! And I did not see this line “Starting_defconf_script_” in the log file anymore. I do not know exactly why it helped to open a terminal, but it seems to me that somewhere this defconf scripts was stuck in a wrong place. I had an email exchange with Mikrotik Support. And the problem seems to be in the WebFig interface. A potential fix will be included in RouterOS version 6.41c.
 
User avatar
LucZWFM
Member Candidate
Member Candidate
Posts: 127
Joined: Tue Dec 26, 2017 10:47 pm
Location: Bergen op Zoom, The Netherlands

Re: hAP mini looses all settings after reboot

Thu Jan 25, 2018 9:40 am

Thanks Jeroen! I was about to throw away a device.
Volunteer Techie @ZuidWest FM / ZuidWest TV, Stichting Repeater Bergen op Zoom & WRLP CB Repeater
 
ctcjdnadmin
just joined
Posts: 1
Joined: Thu Sep 13, 2018 10:00 am

Re: hAP mini looses all settings after reboot

Thu Sep 13, 2018 10:11 am

I have 2 hex on version 6.43 and both lost their configuration after a power blackout..... :(

Who is online

Users browsing this forum: MSN [Bot] and 114 guests