Community discussions

 
wpsd2006
just joined
Topic Author
Posts: 3
Joined: Sat Feb 04, 2017 11:15 am

Multiple VLAN on one port connected to AP

Sat Nov 25, 2017 6:58 am

Hi I have RB951G-2HnD and Tplink Access Point TL-WA901ND

Mikrotik port
Ether 1 - GW1
Ether 2 - GW2
Ether 3 - Client Network 1 192.168.100.0/24 (port connected to Tplink AP)
Ether 4 - Client Network 2 172.168.100.0.24
Ether 5 - Client Network 3 192.168.1.0/24

Each Client network cannot access the other client network, I block it using firewall forward rule
Since Tplink AP can use multiple SSID with VLAN , I want to create separate SSID for all Client Network.

The AP is connected to Ether 3 using cable
I setup three VLAN on top of interface Ether 3, then bridge the VLAN with other corresponding interface.

Somehow the AP cannot connect to mikrotik for every SSID, and It doesn't get DHCP.
/interface vlan add vlan-id=1 interface=ether3 name=ether3-vlan1
/interface vlan add vlan-id=2 interface=ether3 name=ether3-vlan2
/interface vlan add vlan-id=3 interface=ether3 name=ether3-vlan3

/interface bridge add name=vlan1-bridge
/interface bridge port add bridge=vlan1-bridge interface=ether3-vlan1
/interface bridge port add bridge=vlan1-bridge interface=ether3

/interface bridge add name=vlan2-bridge
/interface bridge port add bridge=vlan1-bridge interface=ether3-vlan2
/interface bridge port add bridge=vlan1-bridge interface=ether4

/interface bridge add name=vlan3-bridge
/interface bridge port add bridge=vlan1-bridge interface=ether3-vlan3
/interface bridge port add bridge=vlan1-bridge interface=ether5
 
User avatar
pukkita
Trainer
Trainer
Posts: 2982
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Multiple VLAN on one port connected to AP

Sat Nov 25, 2017 12:54 pm

Run Tools > Torch on ether3, tick "Show VLAN id", do you see the expected VLAN IDs there?

Post a full export.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum

Who is online

Users browsing this forum: MSN [Bot] and 100 guests