Community discussions

 
hassanjutt2002
just joined
Topic Author
Posts: 4
Joined: Wed Oct 11, 2017 9:56 am

Block/limit youtube

Thu Dec 07, 2017 9:07 am

Dear all,

I am using mikotik RB2011UiAS router, configured as load balancing with 3 Wan connection using PCC method. I need to limit Youtube bandwidth for Lan user and also for wireless user including mobile phone app. The CPU usage is also increasing day by day. Total users are approximately 100 in my network. Please share the procedure to implement this, also kindly share how to block youtube and facebook or other sites for some users but allowing some local IP address that are connected to my network. I need solution that will also help me to reduce the CPU usage.

Looking forward for quick response.

Thank you in advance.
 
User avatar
Jotne
Forum Veteran
Forum Veteran
Posts: 864
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: Block/limit youtube

Thu Dec 07, 2017 4:25 pm

Youtube and many other sites now use HTTPS. There are not any good solution anymore to block/limit HTTPS.
.
Use Splunk to monitor your MikroTik Router

MikroTik->Splunk
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8176
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Block/limit youtube

Thu Dec 07, 2017 4:27 pm

Youtube and many other sites now use HTTPS. There are not any good solution anymore to block/limit HTTPS.
What's new in 6.41rc61 (2017-Dec-06 08:15):

*) firewall - added "tls-host" firewall matcher;
So it's almost there :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
Jotne
Forum Veteran
Forum Veteran
Posts: 864
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: Block/limit youtube

Thu Dec 07, 2017 9:42 pm

So it's almost there :)
You have any information on how this works?
.
Use Splunk to monitor your MikroTik Router

MikroTik->Splunk
 
hassanjutt2002
just joined
Topic Author
Posts: 4
Joined: Wed Oct 11, 2017 9:56 am

Re: Block/limit youtube

Fri Dec 08, 2017 7:43 am

I am waiting to solve this problem cause I need to manage my bandwidth. Let everyone post his/her possible recommendation here to resolve it.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8176
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Block/limit youtube

Fri Dec 08, 2017 8:24 am

You have any information on how this works?
Well, something like this, I believe:
/ip firewall filter
add chain=forward dst-port=443 protocol=tcp tls-host=youtube.com action=reject
add chain=forward dst-port=443 protocol=tcp tls-host=*.youtube.com action=reject
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
HenryChinaski
just joined
Posts: 9
Joined: Mon Sep 25, 2017 10:00 pm

Re: Block/limit youtube

Wed Dec 13, 2017 7:46 pm

Hi

i have tested rules with tls-host and is not matching any traffic.

Anyone knows what tls-host feature really is?

Thanks
 
tnt2
just joined
Posts: 18
Joined: Wed Jun 23, 2010 2:47 pm

Re: Block/limit youtube

Tue Dec 19, 2017 12:29 am

hi,
dont working for me too - 6.41rc66

chupaka can you help, please.
 
netbus
newbie
Posts: 34
Joined: Mon Sep 04, 2017 12:42 pm

Re: Block/limit youtube

Wed Jan 31, 2018 3:54 pm

Google (Youtube) uses QUIC protocol not TCP.
"tls-host" is only to tcp applicable
 
User avatar
maximan
Trainer
Trainer
Posts: 548
Joined: Sat May 29, 2004 12:10 am
Location: Rio Cuarto, Argentina
Contact:

Re: Block/limit youtube

Wed Jan 31, 2018 4:33 pm

Google (Youtube) uses QUIC protocol not TCP.
"tls-host" is only to tcp applicable
Is true if you use Chrome (or Opera 16), if not, use TLS.

M.
MKE Solutions> > The Base of knowledge in spanish.
Academia de Entrenamientos: Training Center
 
netbus
newbie
Posts: 34
Joined: Mon Sep 04, 2017 12:42 pm

Re: Block/limit youtube

Wed Jan 31, 2018 7:21 pm

you are right but currently, tls-host is not matching any TLS connection.
 
dmon47
just joined
Posts: 2
Joined: Fri Nov 11, 2011 12:43 pm

Re: Block/limit youtube

Thu Feb 01, 2018 1:47 pm

TLS Host does not work in RouterOS 6.41.
Use last RouterOS 6.42rc15 (Release candidate).
 
netbus
newbie
Posts: 34
Joined: Mon Sep 04, 2017 12:42 pm

Re: Block/limit youtube

Thu Feb 01, 2018 2:06 pm

TLS Host does not work in RouterOS 6.41.
Use last RouterOS 6.42rc15 (Release candidate).
I can confirm, working in rc15
 
mag2020
Trainer
Trainer
Posts: 79
Joined: Sat Nov 30, 2013 8:49 am

Re: Block/limit youtube

Thu Feb 01, 2018 9:54 pm

TLS Host does not work in RouterOS 6.41.
Use last RouterOS 6.42rc15 (Release candidate).
I can confirm, working in rc15
You are right. The Feb2018 Newsletter however mentioned that this feature is available from ROS v6.41 but that may not be totally correct. The option was available but it was not functional.

Who is online

Users browsing this forum: stef84 and 21 guests