Community discussions

 
gbudny
just joined
Topic Author
Posts: 12
Joined: Tue Feb 09, 2016 10:57 am
Location: Poland, Katowice

OpenFlow Baginner

Sun Dec 10, 2017 4:25 pm

Hi everyone!

Has anyone of you ever made working OpenFlow on RoterOS with ODL.
I cant figure out what is wrong with my setup.

I have ODL latest Carbon release placed on physical PC 192.168.56.101
I have CHR 6.40.5 placed on VirtualBox.
Ping between is OK.

I have installed and enabled OpenFlow on CHR.

I got strange ODL Karaf log and cant figure out what is wrong.
Any type of advise/hint would be very nice to make working OpenFlow on RouterOS.
# dec/10/2017 14:20:24 by RouterOS 6.40.5
# software id = 
#
#
#
/interface bridge
add name=bridge1 protocol-mode=none
/interface ethernet
set [ find default-name=ether2 ] name=ether3
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/openflow
add controllers=192.168.56.101 datapath-id=2/08:00:27:35:A0:07 disabled=no \
    name=oflow2
/interface bridge port
add bridge=bridge1
add bridge=bridge1 interface=ether3
/ip dhcp-client
add disabled=no interface=ether1
add dhcp-options=hostname,clientid interface=bridge1
add dhcp-options=hostname,clientid interface=bridge1
/openflow port
add disabled=no interface=ether3 switch=oflow2
/system logging
add topics=event
2017-12-10 15:20:53,880 | WARN  | entLoopGroup-9-8 | OFFrameDecoder                   | 295 - org.opendaylight.openflowjava.openflow-protocol-impl - 0.9.2.Carbon | Closing connection.
2017-12-10 15:20:53,881 | INFO  | entLoopGroup-9-8 | SystemNotificationsListenerImpl  | 306 - org.opendaylight.openflowplugin.impl - 0.4.2.Carbon | ConnectionEvent: Connection closed by device, Device:/192.168.56.102:41189, NodeId:null
2017-12-10 15:21:03,887 | INFO  | entLoopGroup-9-1 | ConnectionAdapterImpl            | 295 - org.opendaylight.openflowjava.openflow-protocol-impl - 0.9.2.Carbon | Hello received
2017-12-10 15:21:03,895 | WARN  | entLoopGroup-9-1 | OFFrameDecoder                   | 295 - org.opendaylight.openflowjava.openflow-protocol-impl - 0.9.2.Carbon | Unexpected exception from downstream.
java.io.IOException: An existing connection was forcibly closed by the remote host
	at sun.nio.ch.SocketDispatcher.read0(Native Method)[:1.8.0_151]
	at sun.nio.ch.SocketDispatcher.read(SocketDispatcher.java:43)[:1.8.0_151]
	at sun.nio.ch.IOUtil.readIntoNativeBuffer(IOUtil.java:223)[:1.8.0_151]
	at sun.nio.ch.IOUtil.read(IOUtil.java:192)[:1.8.0_151]
	at sun.nio.ch.SocketChannelImpl.read(SocketChannelImpl.java:380)[:1.8.0_151]
	at io.netty.buffer.PooledUnsafeDirectByteBuf.setBytes(PooledUnsafeDirectByteBuf.java:288)[158:io.netty.buffer:4.1.8.Final]
	at io.netty.buffer.AbstractByteBuf.writeBytes(AbstractByteBuf.java:1100)[158:io.netty.buffer:4.1.8.Final]
	at io.netty.channel.socket.nio.NioSocketChannel.doReadBytes(NioSocketChannel.java:367)[160:io.netty.transport:4.1.8.Final]
	at io.netty.channel.nio.AbstractNioByteChannel$NioByteUnsafe.read(AbstractNioByteChannel.java:118)[160:io.netty.transport:4.1.8.Final]
	at io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:642)[160:io.netty.transport:4.1.8.Final]
	at io.netty.channel.nio.NioEventLoop.processSelectedKeysOptimized(NioEventLoop.java:565)[160:io.netty.transport:4.1.8.Final]
	at io.netty.channel.nio.NioEventLoop.processSelectedKeys(NioEventLoop.java:479)[160:io.netty.transport:4.1.8.Final]
	at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:433)[160:io.netty.transport:4.1.8.Final]
	at io.netty.util.concurrent.SingleThreadEventExecutor$5.run(SingleThreadEventExecutor.java:858)[159:io.netty.common:4.1.8.Final]
	at io.netty.util.concurrent.DefaultThreadFactory$DefaultRunnableDecorator.run(DefaultThreadFactory.java:144)[159:io.netty.common:4.1.8.Final]
	at java.lang.Thread.run(Thread.java:748)[:1.8.0_151]
2017-12-10 15:21:03,895 | WARN  | entLoopGroup-9-1 | OFFrameDecoder                   | 295 - org.opendaylight.openflowjava.openflow-protocol-impl - 0.9.2.Carbon | Closing connection.
2017-12-10 15:21:03,895 | INFO  | entLoopGroup-9-1 | SystemNotificationsListenerImpl  | 306 - org.opendaylight.openflowplugin.impl - 0.4.2.Carbon | ConnectionEvent: Connection closed by device, Device:/192.168.56.102:41190, NodeId:null
Best Regards
Grzegorz Budny

Who is online

Users browsing this forum: Bing [Bot] and 31 guests