Page 1 of 1

QoS and Queue tree

Posted: Thu Dec 14, 2017 3:39 pm
by digit
Two Question regarding QoS and Queue tree. I have check many tutorial on forum, web site, youtube. Most are using queue to throttle or divide bandwidth. Can’t find any example on how to achieve my goal, maybe my idea is wrong…

1)

Site 1
100Mb/100Mb internet
PBX with coper line to telco 192.168.100.56
IP phone
192.168.100.0/24

Site 2
ether1 = WAN
ether2 = LAN
20Mb/20Mb internet
IP phone
192.168.101.0/24

L2TP tunnel S1 to S2 with static routing

On Site 2 I need some bandwidth management because of limited bandwidth

I am puzzled because VoIP traffic doesn’t go out on ether1-wan, it goes out on l2tp-tosite1. I don’t have any Voip traffic on ether1-wan.

Do I need two stage queue tree where first I prioritize l2tp traffic over other on ether1-wan then on l2tp-site1 tunnel I prioritize voip over other ?

Right now I mark packet to/from PBX and change priority, is that OK ?
/ip firewall address-list
add address=192.168.100.56 list=PBX

/ip firewall mangle
add action=mark-packet chain=forward comment="QoS - VoIP In" new-packet-mark=voip-inbound passthrough=no src-address-list=PBX
add action=mark-packet chain=forward comment="QoS - VoIP Out" dst-address-list=PBX new-packet-mark=voip-outbound passthrough=no
add action=mark-packet chain=forward comment="WAN - All other traffic" in-interface=ether1 new-packet-mark=no-mark-inbound
add action=mark-packet chain=forward comment="WAN - All other traffic" new-packet-mark=no-mark-outbound out-interface=ether1

/queue tree
add name="Inbound - VoIP" packet-mark=voip-inbound parent=global priority=1 queue=default
add name="Inbound - Other" packet-mark=no-mark-inbound parent=global queue=default
add name="Outbound - VoIP" packet-mark=voip-outbound parent=global priority=1 queue=default
add name="Outbound - Other" packet-mark=no-mark-outbound parent=global queue=default

2)

I do understand how to set up pcq so each queue get equal bandwidth allocation. Is it possible to allocate 1Mb/1Mb to VOIP and allow other to “borrow” if VOIP is not in use.

Like if VOIP fight with other, it get prioritize up to 1Mb/1Mb. After 1Mb/1Mb VOIP and other fight with equal strength.

Re: QoS and Queue tree

Posted: Wed Mar 20, 2019 10:33 pm
by jkyawesome
I have the same Question. Is there a solution to this question in Mikrotik Land?

Re: QoS and Queue tree

Posted: Wed Mar 20, 2019 11:43 pm
by neutronlaser
Yes

Re: QoS and Queue tree

Posted: Thu Mar 21, 2019 12:24 am
by sebastia
Configure tunnel with "dscp: inherit", use that to mangle / mark traffic and finally prioritise / shape