Community discussions

 
silodk
just joined
Topic Author
Posts: 2
Joined: Fri Jan 19, 2018 9:23 am
Location: Kolding, DK

Show user ip on lan side

Fri Jan 19, 2018 9:28 am

Hi all,

I have a Mikrotik router and a Synology nas.
Before I got the MK router I was able to see the IP of users logged into my NAS.
Now when users log in to my NAS from outside my lan I can only see the router local ip address.

I want to be able to see the users real internet IP in the logfile of my NAS.
I don't know what that option is called or how to fix it.

Thank you very much..

Br. Simon
 
User avatar
matiaszon
Member
Member
Posts: 305
Joined: Mon Jul 09, 2012 9:26 am

Re: Show user ip on lan side

Sat Jan 20, 2018 3:34 pm

Post result of:
/ip firewall export hide-sensitive
 
solar77
Member
Member
Posts: 437
Joined: Thu Feb 04, 2016 11:42 am
Location: Scotland

Re: Show user ip on lan side

Sat Jan 20, 2018 5:12 pm

if you used dst-nat for your NAS, you should see the external IP when they going through the fireware and the NAS device should see it too.
MTCNA MTCTCE UEWA
 
Sob
Forum Guru
Forum Guru
Posts: 4812
Joined: Mon Apr 20, 2009 9:11 pm

Re: Show user ip on lan side

Sun Jan 21, 2018 1:22 am

Most likely there's just:
/ip firewall nat
add action=masquerade chain=srcnat
instead of proper:
/ip firewall nat
add action=masquerade chain=srcnat out-interface=<WAN>
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply.
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1795
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: Show user ip on lan side  [SOLVED]

Sun Jan 21, 2018 3:08 am

Most likely there's just:
/ip firewall nat
add action=masquerade chain=srcnat
instead of proper:
/ip firewall nat
add action=masquerade chain=srcnat out-interface=<WAN>
Like this is even more precise
add action=masquerade chain=srcnat out-interface=<WAN> src-address-type=!local
 
silodk
just joined
Topic Author
Posts: 2
Joined: Fri Jan 19, 2018 9:23 am
Location: Kolding, DK

Re: Show user ip on lan side

Tue Jan 23, 2018 2:47 pm

add action=masquerade chain=srcnat out-interface=<WAN> src-address-type=!local
Thank you very much. The last one here worked perfect! You are GREAT!

Who is online

Users browsing this forum: No registered users and 121 guests