Community discussions

 
User avatar
gpienaar
newbie
Topic Author
Posts: 33
Joined: Sun Dec 10, 2006 2:05 pm
Location: South Africa

OSPF and PPPOE nightmare!

Tue Jan 02, 2007 8:42 pm

I have 10 towers running OSPF on RB532! I also run PPPOE on all the towers! The address range 10.22.x.y is running as backbone and all the 192.168.x.y is the pool addresses for PPPOE clients. Under OSPF is only the 10.22.x.y specified as backbone (example=10.22.1.y/24 for tower 1, 10.22.1.y/24 and 10.22.2.y/24 for tower 2 and 10.22.2.y/24 and 10.22.3.y for tower 3 etc.)

The PPPOE address range does not form part of Backbone! Why under routes do you see all the PPPOE client routes?
 
User avatar
savagedavid
Trainer
Trainer
Posts: 310
Joined: Thu Aug 25, 2005 12:58 pm
Location: Cape Town, South Africa
Contact:

Tue Jan 02, 2007 9:57 pm

That is how OSPF works. If you specify the "Distribute Connected Routes" setting it will do that. It is designed to work like that. Are your backbone routes built dynamically? You could try specifying Redistribute Static Routes if not.
 
User avatar
gpienaar
newbie
Topic Author
Posts: 33
Joined: Sun Dec 10, 2006 2:05 pm
Location: South Africa

Tue Jan 02, 2007 11:23 pm

Hi Dave! :D

Nice to hear from you! How will I be able then to do the PPPOE thing with OSPF?
 
User avatar
gottin
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Fri Feb 25, 2005 8:33 am
Location: Bulgaria
Contact:

Wed Jan 03, 2007 12:03 pm

If you don't want 192.168.x.y routers to be distributed - try to create and apply a filter.
Find valuable information at mikrotikos.blogspot.com
 
User avatar
gpienaar
newbie
Topic Author
Posts: 33
Joined: Sun Dec 10, 2006 2:05 pm
Location: South Africa

Wed Jan 03, 2007 11:29 pm

:? How does a filter work in ospf?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24258
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Thu Jan 04, 2007 1:47 pm

 
User avatar
HarvSki
Member
Member
Posts: 388
Joined: Fri May 28, 2004 3:37 pm
Location: London, UK

Thu Jan 04, 2007 2:33 pm

I have this problem too, any more infor would be good as currently I'm distributing conected route which are obviously including my PPPoE connections. Quite a bit of flapping is going on!
 
User avatar
gpienaar
newbie
Topic Author
Posts: 33
Joined: Sun Dec 10, 2006 2:05 pm
Location: South Africa

Thu Jan 04, 2007 9:17 pm

I do not want to create a OSPF on or inside a PPPOE link!

Sorry Normis! I realy do not understand what you trying to say! :roll:

Is their any body that have implemented OSPF on a large scale on Mikrotik and also run PPPOE links to the clients?

Out of a admin point of view and a expandability on towers and rudundancy ( feed network from as many telco switches as possible) integration with dude, this is the way to run a large WISP. Their is so many things on OSPF that can be set, but no proper manuals or examples. It seems to me that their is very little people that actualy know how to set up OSPF properly. (areas, virtual AP's, etc)

Any body disagree? Please let me know!

Regards

Mr G
PS! do not give links that is not related!
 
User avatar
tneumann
Member
Member
Posts: 394
Joined: Sat Apr 16, 2005 6:38 pm
Location: Germany

Thu Jan 04, 2007 10:09 pm

gpienaar,

are you running routing-test or the legacy routing package?
I do not want to create a OSPF on or inside a PPPOE link!
Ok, so what do you want, then? Is your problem that a route to each PPPoE client is propagated through your entire network as soon as the new client connects? What do you expect to happen instead? Do you not want these client routes to be propagated at all (then how would you reach the client?) Or do you not want the routes to be propagated individually as host routes (one for each logged-in PPPoE client) but instead want to only propagate a summary route for each PPPoE client address pool from every PPPoE-enabled AP?

--Tom
 
User avatar
gpienaar
newbie
Topic Author
Posts: 33
Joined: Sun Dec 10, 2006 2:05 pm
Location: South Africa

Fri Jan 05, 2007 8:08 am

gpienaar,

are you running routing-test or the legacy routing package?
I do not want to create a OSPF on or inside a PPPOE link!
Ok, so what do you want, then? Is your problem that a route to each PPPoE client is propagated through your entire network as soon as the new client connects? What do you expect to happen instead? Do you not want these client routes to be propagated at all (then how would you reach the client?) Or do you not want the routes to be propagated individually as host routes (one for each logged-in PPPoE client) but instead want to only propagate a summary route for each PPPoE client address pool from every PPPoE-enabled AP?

--Tom
Yes if client connect via PPPOE, his route is being propagated through network, I do not want this!

Yes - this is what I want - The routes to be propagate a summary route for each PPPoE client address pool from every PPPoE-enabled AP?

Regards

Mr G
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Fri Jan 05, 2007 9:01 am

First of all you must use routing-test package!

each PPPoE server must be ABR (in separate Area)

Then go to the "/routing ospf area range" and specify summary network with option "advertise=yes" then this area will distribute only summary route and get rid of all specific routes that applies under that summary route

If you would like not to advertise some specific routes you should use option "advertise=no"
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
gpienaar
newbie
Topic Author
Posts: 33
Joined: Sun Dec 10, 2006 2:05 pm
Location: South Africa

Sat Jan 06, 2007 12:26 am

First of all you must use routing-test package!

each PPPoE server must be ABR (in separate Area)

Then go to the "/routing ospf area range" and specify summary network with option "advertise=yes" then this area will distribute only summary route and get rid of all specific routes that applies under that summary route

If you would like not to advertise some specific routes you should use option "advertise=no"
Thanks McGaiver!!

You are the first person that actualy contribute to OSPF! I have tried a few things that you have sugested!

It works fine with ABR's that border to the backbone area! BUT, I have a long chain of different areas in series, this is a problem for me, currently I run the long series chain all on backbone area. I know this is wrong, that is why i seek help from the more experience OSPF Guru's like your self!

Do you think I should run virtual links to backbone area from the areas that is a few hops away?

Any more ideas will be apreciated!

Regards

Mr G
 
User avatar
tneumann
Member
Member
Posts: 394
Joined: Sat Apr 16, 2005 6:38 pm
Location: Germany

Sat Jan 06, 2007 2:34 am

gpienaar,

can you describe your network topology in more detail?

You can not have a chain of non-backbone areas in OSPF. Every non-backbone area must be connected to the backbone. You can not have a non-backbone area behind another non-backbone area. You should not try to use virtual links to try to get around this restriction. Virtual links are more of a last resort emergency fix to temporarily repair a multi-area OSPF network during outages that would otherwise make areas discontinous etc., but virtual links should never be part of your OSPF design as such.

You say that you're currently running "a long series chain on backbone area". Well, I don't see what's wrong with this, as long as it looks something like this
|RouterA|----(backbone)---|RouterB|---(backbone)---|RouterC|---(backbone)--->
      |                         |                        |
      v                         v                        v
(area 10:PPPoE)           (area 20:PPPoE)          (area 30:PPPoE)
A chain of routers where the backhaul links form the OSPF backbone and each router has another area that includes the PPPoE address pool so that it can be easily summarized as a range.


--Tom
 
User avatar
gpienaar
newbie
Topic Author
Posts: 33
Joined: Sun Dec 10, 2006 2:05 pm
Location: South Africa

Sat Jan 06, 2007 11:28 am

Walla! It is working! :D

Thank's Tom! This is exactly how my network is working! Please update the wiki site as an example. I am sure their is a lot of people out their that would like to run their network like this!

Mikrotik, please update your manuals with examples like this!

Regards

Mr G

P.S Many thanks to McGaiver! 8)
 
odie
Member Candidate
Member Candidate
Posts: 216
Joined: Wed Mar 23, 2005 8:31 am
Location: Austria
Contact:

Sat Jan 06, 2007 12:15 pm

i think this is not a matter of the manual but of basic ospf understandings
you can find some info here: http://www.inetdaemon.com/tutorials/int ... ndex.shtml
or even more info under:
http://www.cisco.com/univercd/cc/td/doc ... c/ospf.htm
and
http://www.cisco.com/univercd/cc/td/doc ... cfospf.htm
as longs as you dont know the way it works you will not be able to set up ospf properly
 
User avatar
gpienaar
newbie
Topic Author
Posts: 33
Joined: Sun Dec 10, 2006 2:05 pm
Location: South Africa

Sat Jan 06, 2007 10:26 pm

Dear savagedavid!

Please make more time on Mikrotik training sesions for OSPF!!

Regards

Mr G
 
franco
Member Candidate
Member Candidate
Posts: 142
Joined: Fri Feb 25, 2005 6:26 pm
Location: Germany

Sat Jan 27, 2007 10:25 am

hello gpienaar

how you solve the problem with the ip pool for pppoe.
I have the same net structure.
unfortunately, I have a problem with the ip addresses.
how I can solve it, that 12 AP with a pppoe server grasping on one ip pool.
we forgive the customers dynamic ip addresses.
The logon is carried out via a radius server
 
User avatar
magic
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Fri Mar 04, 2005 9:53 pm
Location: Sopron, Hungary
Contact:

Please send me example

Mon Feb 26, 2007 9:32 am

Walla! It is working! :D

Thank's Tom! This is exactly how my network is working! Please update the wiki site as an example. I am sure their is a lot of people out their that would like to run their network like this!

Mikrotik, please update your manuals with examples like this!

Regards

Mr G

P.S Many thanks to McGaiver! 8)
Hi qpienaar!

Would you be so kind and send here your settings which works for you? I tried it, but couldn't start.
If it's possible send here what you saw when use the /routing ospf export command.

Thanks
Krisz
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Mon Feb 26, 2007 10:03 am

magic if you read
First of all you must use routing-test package!

each PPPoE server must be ABR (in separate Area)

Then go to the "/routing ospf area range" and specify summary network with option "advertise=yes" then this area will distribute only summary route and get rid of all specific routes that applies under that summary route

If you would like not to advertise some specific routes you should use option "advertise=no"
and
gpienaar,

can you describe your network topology in more detail?

You can not have a chain of non-backbone areas in OSPF. Every non-backbone area must be connected to the backbone. You can not have a non-backbone area behind another non-backbone area. You should not try to use virtual links to try to get around this restriction. Virtual links are more of a last resort emergency fix to temporarily repair a multi-area OSPF network during outages that would otherwise make areas discontinous etc., but virtual links should never be part of your OSPF design as such.

You say that you're currently running "a long series chain on backbone area". Well, I don't see what's wrong with this, as long as it looks something like this

Code:
|RouterA|----(backbone)---|RouterB|---(backbone)---|RouterC|---(backbone)--->
| | |
v v v
(area 10:PPPoE) (area 20:PPPoE) (area 30:PPPoE)


A chain of routers where the backhaul links form the OSPF backbone and each router has another area that includes the PPPoE address pool so that it can be easily summarized as a range.


--Tom
and
http://www.mikrotik.com/testdocs/ros/2. ... g/ospf.php

you should be able to come up with solution without gpienars ospf export
 
User avatar
magic
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Fri Mar 04, 2005 9:53 pm
Location: Sopron, Hungary
Contact:

Mon Feb 26, 2007 10:15 am

Janisk I read it and a lot of other documentation too. And tried it and didn't work.

I use the routing-test package (which still have bugs, sent to support). I checked the documentation but it is for the normal package not for the routing test (for example no area range in the documentation :-) )

And sometimes it is lot easier to see a working config then find info about undocumented features ( I know there is lot of non mikrotik related doc about ospf). I this moment we use 333 equipment in our backbone (nearly 100 mikrotik) so I need working solutions.

And last: it would be nice if there will be more examples in the documentation. Not only for OSPF.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Mon Feb 26, 2007 10:37 am

please tell us where you have difficulties. You have to understand that people are not willing to report their current configurations due to security reasons, but you can post here your net config and configurations you have done and what you want to achieve. most probably we will be able to help you then.
 
User avatar
magic
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Fri Mar 04, 2005 9:53 pm
Location: Sopron, Hungary
Contact:

Mon Feb 26, 2007 11:06 am

please tell us where you have difficulties. You have to understand that people are not willing to report their current configurations due to security reasons, but you can post here your net config and configurations you have done and what you want to achieve. most probably we will be able to help you then.
Janisk,

You are a little funny. You write that people don't wish to send their configuration here then you asked me for my configuration. :D

I don't like to send my configuration too with the exact datas. So somebody need mine I send it without sensible datas.

What I wish to do:
I have a router which is connected to the backbone ospf are on the ether1. This works fine.
I have about 60 pppoe client on the wlan1, whose got their ip address from IP POOL. Non privat routeable ip-s. The ospf send out update when users logs in or logs out. This works fine too.

But I wish that the router send out only one route for example 86.109.75.192/26 not 64 /32 route.
So I add a new area with 0.0.0.2 area id name test. And add /routing ospf area range add area=test range=86.109.75.192/26 advertise=yes

I tried to add a network to the test area. Tried to turn on summary for that area. But there was no summary route.

My configuration now:
/ routing ospf
set router-id=0.0.0.0 distribute-default=never \
redistribute-connected=as-type-1 redistribute-static=no \
redistribute-rip=no redistribute-bgp=no metric-default=1 \
metric-connected=20 metric-static=20 metric-rip=20 metric-bgp=20
/ routing ospf area
set backbone area-id=0.0.0.0 type=default translator-role=translate-candidate \
authentication=none disabled=no
add name="test" area-id=0.0.0.2 type=default \
translator-role=translate-candidate authentication=none default-cost=1 \
disabled=no
/ routing ospf area range
add area=test range=86.109.75.192/26 cost=default advertise=yes disabled=no
/ routing ospf interface
set FIXME interface=wlan1 cost=10 priority=1 authentication-key="" \
network-type=broadcast retransmit-interval=5s transmit-delay=1s \
hello-interval=5s dead-interval=40s
/ routing ospf network
add network=86.109.x.x/29 area=backbone disabled=no

I tried to make a working configuration from cisco documentation too. But nothing happen. All my router use the routing-test package with 2.9.40

Thanks
Krisz
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Mon Feb 26, 2007 3:10 pm

in your configuration set redistribute-default as it will redistribute default route and not static

just set that ospf area range
and you do not need to set up other area if you do not want to these PPPoE can still be in your backbone area. actually there is no big difference.

and as your network is not working you do not risk very much by posting its current state as it is not working. and as you need alter your config for it to work your configuration will be changed :roll:

anyway good luck.
 
User avatar
magic
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Fri Mar 04, 2005 9:53 pm
Location: Sopron, Hungary
Contact:

Tue Feb 27, 2007 9:34 am

in your configuration set redistribute-default as it will redistribute default route and not static

just set that ospf area range
and you do not need to set up other area if you do not want to these PPPoE can still be in your backbone area. actually there is no big difference.

and as your network is not working you do not risk very much by posting its current state as it is not working. and as you need alter your config for it to work your configuration will be changed :roll:

anyway good luck.
Hi,

Maybe i'm the stupid, but did not work for me. I don't see the route which is in the area range. I made a test router which is attached to the backbone and start a pppoe server on it. But it only distribute the pppoe route not the summarized.

/ routing ospf
set router-id=0.0.0.0 distribute-default=if-installed-as-type-1 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-bgp=no metric-default=1 metric-connected=20 metric-static=20 \
metric-rip=20 metric-bgp=20
/ routing ospf area
set backbone area-id=0.0.0.0 type=default translator-role=translate-candidate \
authentication=none disabled=no
/ routing ospf area range
add area=backbone range=192.168.51.0/24 cost=default advertise=yes disabled=no
/ routing ospf interface
set FIXME interface=wlan1 cost=10 priority=1 authentication-key="" \
network-type=broadcast retransmit-interval=5s transmit-delay=1s \
hello-interval=5s dead-interval=40s
/ routing ospf network
add network=86.109.64.252/30 area=backbone disabled=no


Any idea?
 
User avatar
tneumann
Member
Member
Posts: 394
Joined: Sat Apr 16, 2005 6:38 pm
Location: Germany

Tue Feb 27, 2007 2:22 pm

magic,

from your configuration I see that you did not define an OSPF area for the PPPoE range - all you have is the backbone area.

You need to define an additional (non-backbone) area to be summarized and put your PPPoE addresses into that area.

--Tom
 
User avatar
magic
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Fri Mar 04, 2005 9:53 pm
Location: Sopron, Hungary
Contact:

Wed Feb 28, 2007 1:43 pm

magic,

from your configuration I see that you did not define an OSPF area for the PPPoE range - all you have is the backbone area.

You need to define an additional (non-backbone) area to be summarized and put your PPPoE addresses into that area.

--Tom
Tom,

Janisk wrote this: you do not need to set up other area if you do not want to these PPPoE can still be in your backbone area.

But I tried it with different area and did not work :-(

Krisz
 
User avatar
tneumann
Member
Member
Posts: 394
Joined: Sat Apr 16, 2005 6:38 pm
Location: Germany

Wed Feb 28, 2007 3:34 pm

magic,

area ranges defined under /routing ospf area range are only relevant with inter-area routing; the range is used for summarization when routing information passes from one area into another, usually from non-backbone to backbone.

OSPF also supports summarization of external routing information that is redistributed into OSPF, where 'external' means any routing information that is not learned from OSPF itself, for example static routes, connected routes, routes learned via RIP etc. A router that gateways such external routing information into OSPF is called an ASBR (Autonomous System Boundary Router) and per the OSPF standard an ASBR can summarize such external routing information and flood it into OSPF as summary LSAs. However, I think that this functionality is currently not implemented by MikroTik, not even in 2.9 routing-test, therefore I believe that to summarize you need to configure inter-area (range) summarization as a work around with MT for now. I'd be glad to learn otherwise.

--Tom
 
User avatar
magic
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Fri Mar 04, 2005 9:53 pm
Location: Sopron, Hungary
Contact:

Wed Feb 28, 2007 4:03 pm

Tneuman,

You are absolutely right. I know this, read this and tried this. But not works. So I need a working solution for mikrotik 2.9 routing test. This is why I wrote here.

Maybe somebody did this and have solutions.

Krisz
 
User avatar
tneumann
Member
Member
Posts: 394
Joined: Sat Apr 16, 2005 6:38 pm
Location: Germany

Wed Feb 28, 2007 10:57 pm

I know this, read this and tried this.
From the config export you posted in an earlier message I'd say that you did not, at least the config you posted does not include a non-backbone area. If you did in fact try a multi-area setup then could you please post that configuration export as well?

--Tom
 
User avatar
HarvSki
Member
Member
Posts: 388
Joined: Fri May 28, 2004 3:37 pm
Location: London, UK

Tue Mar 13, 2007 12:19 pm

I've started a wiki page on this, if anyone cares to update / correct I'm sure us OSPF newbies would be greatful

http://wiki.mikrotik.com/wiki/OSPF_and_Area_summaries
 
User avatar
Antixx
Member Candidate
Member Candidate
Posts: 100
Joined: Mon Jun 26, 2006 9:46 am

Re:

Thu Nov 29, 2007 9:15 pm

I've started a wiki page on this, if anyone cares to update / correct I'm sure us OSPF newbies would be greatful

http://wiki.mikrotik.com/wiki/OSPF_and_Area_summaries
Excuseme could you please tellme in which situatuin we use OSPF i confiuse about OSPF i read the duc but didnt get the target,
 
Inssomniak
Member
Member
Posts: 326
Joined: Fri Apr 13, 2007 11:21 pm

Re: OSPF and PPPOE nightmare!

Fri Nov 30, 2007 3:01 am

Im still trying to understand this OSPF too.. I have one MT router with many public subnets/DSL interfaces.

so--
                                    ===============================
     -----> DSL 1 x.x.x.32/27   --> |  Router IP x.x.x.34         |       IP range .35-62  is used for PPPoE clients
                                    |  GW1: x.x.x.x33             |       .160/28  and .176/28 and .192/28 are used for PPPoE clients
     -----> DSL 2 x.x.x.160/28  --> |                             |   --> WLAN Interface
                  x.x.x.176/28  --> |  GW2:interface routing      |
                                    |  GW3:interface routing      |
     -----> DSL 3 x.x.x.192/28  --> |                             |  ---->  Future Router, want to use above subnets on this router too
                                    |                             |
                                    |                             |
                                    |  WLAN1 10.2.23.0/27         | (backbone?)
                                    ===============================

I get confused because Im adding another tower with mikrotik and I want to use the subnets I have to serve additional PPPoE clients (basically share the subnet for PPPoE users)

Im not sure how to set up the OSPF to accomplish this.

the first range x.x.x.32/27 one of the IPs is used for the router, and the other is used for the ISP gateway.. do I still put x.x.x.32/27 as an area range even though my router has an IP in the range?

The others ranges are entirely used for PPPoE Clients.

in a nutshell, I want PPPoE clients on router1 and router2 to be in the same subnets and have it find a route back to my first router to get onto the net! I have backbone as 10.2.23.0/27 just to have access to the AP's and such)
 
User avatar
GWISA
Member
Member
Posts: 394
Joined: Tue Jan 31, 2006 2:37 pm
Location: Johannesburg, South Africa

Re: OSPF and PPPOE nightmare!

Fri Nov 30, 2007 11:02 am

OSPF on a PPPoE network is pretty simple to set up.

Primary principles employed will be:

All the backbone IP's will be in one 'area' - the backbone area and network.

Every PPPoE server IP range will be in their own area, subnet and network and also connected to the backbone area.

The ideal way to accomplish this would be to use a separate device for the backbone and PPPoE server, but it isn't required - as long as the PPPoE IP range is defined as its own area and network and does not overlap any others.

You can have the PPPoE clients and backbone on the same subnet, but don't expect this to be as stable as you'd like.

By separating the PPPoE areas and networks from the backbone, you can then use the summary route function and only distribute that into your backbone. If you don't use the summary route option, then there is a constant flapping on the routing table as PPPoE clients connect & disconnect.

Check this doc out for a different perspective on OSPF:
http://www.cisco.com/warp/public/104/1.html
 
User avatar
promind
Member Candidate
Member Candidate
Posts: 153
Joined: Thu Feb 23, 2006 11:26 am
Location: Rousse, Bulgaria
Contact:

Re: OSPF and PPPOE nightmare!

Fri Nov 30, 2007 11:43 am

OSPF on a PPPoE network is pretty simple to set up.

Primary principles employed will be:

All the backbone IP's will be in one 'area' - the backbone area and network.

Every PPPoE server IP range will be in their own area, subnet and network and also connected to the backbone area.

The ideal way to accomplish this would be to use a separate device for the backbone and PPPoE server, but it isn't required - as long as the PPPoE IP range is defined as its own area and network and does not overlap any others.

You can have the PPPoE clients and backbone on the same subnet, but don't expect this to be as stable as you'd like.

By separating the PPPoE areas and networks from the backbone, you can then use the summary route function and only distribute that into your backbone. If you don't use the summary route option, then there is a constant flapping on the routing table as PPPoE clients connect & disconnect.

Check this doc out for a different perspective on OSPF:
http://www.cisco.com/warp/public/104/1.html
I haven't used mikrotik's OSPF yet but I can post you quagga config/mikrotik uses quagga/ so you can addopt it to your mt config.
here it is:
!
! Zebra configuration saved from vty
! 2007/11/29 15:37:29
!
hostname home
password mypasswd
enable password myenablepasswd
log stdout
!
!
!
interface eth0
!
interface eth1
!
interface eth2
!
interface eth2.204
ip ospf authentication message-digest
ip ospf message-digest-key 5 md5 my-md4-key
ip ospf cost 10
ip ospf hello-interval 3
ip ospf dead-interval 10
!
interface lo
!
router ospf
ospf router-id 172.16.254.2
redistribute connected route-map home_map
redistribute static route-map home_map
network 172.16.254.0/30 area 0.0.0.15
area 0.0.0.15 authentication message-digest
area 0.0.0.15 range 172.16.254.0/30
!
ip prefix-list home seq 100 permit 10.3.0.0/16
ip prefix-list home seq 101 deny 0.0.0.0/0
!
route-map home_map permit 10
match ip address prefix-list home
!
line vty
!
P.S.
do ip route 10.3.0.0/16 Null0 2 in zebra
 
Mark74
just joined
Posts: 6
Joined: Sat May 12, 2007 1:52 pm

Re: OSPF and PPPOE nightmare!

Sun Jun 01, 2008 7:00 pm

Hello, i have one question for you ....
In my OSPF configuration every router have one subnet with two diffusion unit.
In every diffusion point work pppoe-server.
The pppoe-client route is passed by RIP to ospf router. OSPF don't redistribuite RIP.
All work fine BUT the question is .....
In the OSPF NETWORK the link from two router of the same area (192.168.1.1/30 - first router 192.168.1.2/30 second router) are backbone or area_xx? And between two router with different area? backbone too?
Every link from and to other router (with o without same area) are backbone?


thanks in advance

Mark74


PS: every routerboard is rb333 with 3.10 ppc version, router to out x86 with 3.10 version
ospf2.jpg
PS 2 : this example is wrong or not, from area 1 o area 2 to backbone link is area or backbone?
in every routers of same area, must i write subnet area-range of all router of the same areas?
You do not have the required permissions to view the files attached to this post.
 
danh@tbc.net
just joined
Posts: 10
Joined: Fri May 28, 2004 7:29 pm

Re: OSPF and PPPOE nightmare!

Thu Nov 13, 2008 11:04 pm

I'm chasing an issue similar to this. I've implemented summaries on our Cisco PPPoE servers, and now they simply put out one supernet address for the complete PPPoE Pool. However when I try to do it on the Mikrotik server, I get the summaries propagated back into the routing tables, BUT every PPPoE Customer starts receiving OPSF Hello packets on their PPPoE sessions. On the Cisco, all I had to do was define an area and define a summary-address. On the Mikrotik implementation, I didn't see any way to have the area go active without putting the subnet in the network tab.

Any ideas what I'm missing?

On another note: (and why I'm working on OSPF at the moment)

I am seeing intermittent errors in the logs: The errors go:

14:38:34 route,ospf,info Invalid cryptographic sequence number
14:38:34 route,ospf,info mine=6024
14:38:34 route,ospf,info received=6023
14:38:34 route,ospf,info Discarding packet: MD5 authentication failed
14:38:34 route,ospf,info source=xx.xx.xx.xx


The sequence numbers are always 1-3 apart. There are 4 OSPF routers in area 0, two Mikrotik, two Cisco. The Mikrotiks are HP 1U servers, and have a single Gig-E running VLANs into a Cisco switch. We've seen these errors for a while, but last week we moved the routers from 100Mb/s to Gig-E, and upgraded to 3.15 from 3.13.

This morning we had a routing issue. When I logged in, the general error was "peer is in wrong state" and the OSPF sessions were resetting themselves several times a second. The fastest way to resolve the problem was to reboot each one, but I'm trying to get to the bottom of why they were having an issue.

Anyone ever seen either of these problems, and any ideas why it might be happening? We're going to upgrade one to 3.16 and downgrade the other to 3.13 tonight to see if it's a version issue. Traffic wise, each Mikrotik router usually runs about 25Mb/s-35Mb/s providing routing and PPPoE services.

Thanks for any help

Dan
 
User avatar
acim
Member
Member
Posts: 424
Joined: Mon Sep 12, 2005 12:26 am
Location: Serbia
Contact:

Re:

Thu Apr 05, 2012 1:51 am

I've started a wiki page on this, if anyone cares to update / correct I'm sure us OSPF newbies would be greatful

http://wiki.mikrotik.com/wiki/OSPF_and_Area_summaries
Is it possible to use the same area-id and area-name on each ABR for PPPoE summarization purposes?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5940
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: OSPF and PPPOE nightmare!

Thu Apr 05, 2012 10:45 am

I'm chasing an issue similar to this. I've implemented summaries on our Cisco PPPoE servers, and now they simply put out one supernet address for the complete PPPoE Pool. However when I try to do it on the Mikrotik server, I get the summaries propagated back into the routing tables, BUT every PPPoE Customer starts receiving OPSF Hello packets on their PPPoE sessions. On the Cisco, all I had to do was define an area and define a summary-address. On the Mikrotik implementation, I didn't see any way to have the area go active without putting the subnet in the network tab.

Any ideas what I'm missing?
add in ospf interfaces all interfaces to be passive, for example I need to run OSPF on ether1 other pppoe should be passive (no hellos).
/routing ospf interface
add interface=ether1 network-type=broadcast
add interface=all passive=yes

then add area range to summarize all pppoe, for example pppoe addresses are in network 192.168.0.0/24
/routing ospf network
add network=192.168.0.0/24 area=pppoe-area

/routing ospf area range
add area=pppoe-area range=192.168.0.0/24 advertise=yes

Now backbone will receive only /24 route.
 
User avatar
acim
Member
Member
Posts: 424
Joined: Mon Sep 12, 2005 12:26 am
Location: Serbia
Contact:

Re: OSPF and PPPOE nightmare!

Sun Apr 08, 2012 4:21 pm

This is working OK for the routers in backbone area, but on routers which are not in backbone area, there is no connection between pppoe area and backbone area, so this is not working (PPPoE routes are not advertised at all). Virtual links are not working properly in Mikrotik implementation, so the only solution seems to be using tunnels (I like EoIP), but this is not elegant. Is there some better solution for PPPoE server in non-backbone areas?
 
User avatar
omidkosari
Trainer
Trainer
Posts: 616
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re:

Fri Apr 20, 2012 11:02 am

hello gpienaar

how you solve the problem with the ip pool for pppoe.
I have the same net structure.
unfortunately, I have a problem with the ip addresses.
how I can solve it, that 12 AP with a pppoe server grasping on one ip pool.
we forgive the customers dynamic ip addresses.
The logon is carried out via a radius server
Im still trying to understand this OSPF too.. I have one MT router with many public subnets/DSL interfaces.

so--
                                    ===============================
     -----> DSL 1 x.x.x.32/27   --> |  Router IP x.x.x.34         |       IP range .35-62  is used for PPPoE clients
                                    |  GW1: x.x.x.x33             |       .160/28  and .176/28 and .192/28 are used for PPPoE clients
     -----> DSL 2 x.x.x.160/28  --> |                             |   --> WLAN Interface
                  x.x.x.176/28  --> |  GW2:interface routing      |
                                    |  GW3:interface routing      |
     -----> DSL 3 x.x.x.192/28  --> |                             |  ---->  Future Router, want to use above subnets on this router too
                                    |                             |
                                    |                             |
                                    |  WLAN1 10.2.23.0/27         | (backbone?)
                                    ===============================

I get confused because Im adding another tower with mikrotik and I want to use the subnets I have to serve additional PPPoE clients (basically share the subnet for PPPoE users)

Im not sure how to set up the OSPF to accomplish this.

the first range x.x.x.32/27 one of the IPs is used for the router, and the other is used for the ISP gateway.. do I still put x.x.x.32/27 as an area range even though my router has an IP in the range?

The others ranges are entirely used for PPPoE Clients.

in a nutshell, I want PPPoE clients on router1 and router2 to be in the same subnets and have it find a route back to my first router to get onto the net! I have backbone as 10.2.23.0/27 just to have access to the AP's and such)
above are my question too ?

Also i see the following line in http://wiki.mikrotik.com/wiki/OSPF_and_ ... interfaces
Also remember that running OSPF on a big number of (flapping) PPP interfaces is not recommended.
What is the number of the big number ? i know it is related to hardware resources but is there a simple formula ?
MTCNA , MTCRE, MTCWE, Mikrotik Certified Trainer
 
spektrumzx
just joined
Posts: 13
Joined: Tue Nov 16, 2010 8:17 am

Re: OSPF and PPPOE nightmare!

Sun Aug 26, 2012 11:38 am

I have question probably connected with OSPF.

In my network I use one router as WAN, where are two BGP session with two ISP providers. After it I have three PPPoE servers that are connected to WAN with static routes, they use private IPs.
All off my users receive a public IP that I have manually routed between WAN and PPPoE servers, I mean I broke my public subnets in smallest so I can manage IP and also I make balance with two ISP.
I use Radius Manager as my accounting system, all of PPPoE servers as a different NAS.

The network groving up so I need more PPPoE servers, or more NAS in radius.

The idea is to make Radius as a IP managment system. I want to spend my IP addresses, one by one, no matter which NAS/PPPoE will take it.

I thing that OSPF can make it for all my PPPoE users so I will don't need manually route in my WAN router, I will don't need to broke subnets and also I will make my life much easy.

It is possible?


Thanks in advance,
 
User avatar
ploquets
Member Candidate
Member Candidate
Posts: 128
Joined: Tue Nov 17, 2015 12:49 pm
Location: Uruguaiana, RS, Brazil
Contact:

Re: OSPF and PPPOE nightmare!

Tue May 23, 2017 12:11 am

add in ospf interfaces all interfaces to be passive, for example I need to run OSPF on ether1 other pppoe should be passive (no hellos).
/routing ospf interface
add interface=ether1 network-type=broadcast
add interface=all passive=yes

then add area range to summarize all pppoe, for example pppoe addresses are in network 192.168.0.0/24
/routing ospf network
add network=192.168.0.0/24 area=pppoe-area

/routing ospf area range
add area=pppoe-area range=192.168.0.0/24 advertise=yes

Now backbone will receive only /24 route.
Would this work in NSSA areas?

I've checked on my PPPoE concentrator to Inject Summarys LSAs, but, even if I put:
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 redistribute-static=as-type-1 router-id=10.1.200.3

/routing ospf area
add area-id=200.200.200.200 default-cost=1 inject-summary-lsas=yes name=pppoe translator-role=translate-never type=nssa

/routing ospf network
add area=pppoe network=10.0.0.0/24

/routing ospf area range
add area=pppoe range=10.0.0.0/24

/routing ospf interface
add network-type=point-to-point passive=yes
I can't see at the backbone the route 10.0.0.0/24
Only /32 routes from pppoe-clients are shown at the route table.

What am I doing wrong?

NSSA is just to not pass any other router from backbone border router inside other areas.
 
User avatar
amt
Long time Member
Long time Member
Posts: 526
Joined: Fri Jan 16, 2015 2:05 pm

Re: OSPF and PPPOE nightmare!

Sun Sep 10, 2017 4:15 pm

add in ospf interfaces all interfaces to be passive, for example I need to run OSPF on ether1 other pppoe should be passive (no hellos).
/routing ospf interface
add interface=ether1 network-type=broadcast
add interface=all passive=yes

then add area range to summarize all pppoe, for example pppoe addresses are in network 192.168.0.0/24
/routing ospf network
add network=192.168.0.0/24 area=pppoe-area

/routing ospf area range
add area=pppoe-area range=192.168.0.0/24 advertise=yes

Now backbone will receive only /24 route.

Hi,
i would like to ask if possible to use this settings under this situation;
you have /20 ip range and more than 5 pppoe_server for all network, and radius assign ip's to customers. so you dont now which ip on which pppoe server. can you use this settings also ?

Who is online

Users browsing this forum: No registered users and 92 guests