Community discussions

 
aristosv
just joined
Topic Author
Posts: 2
Joined: Thu Feb 15, 2018 10:50 pm

IPSec VPN for iPhone

Fri Feb 16, 2018 12:20 am

I am trying to configure a MikroTik RB750GR3 to accept VPN connections from my iPhone. I've been through plenty of forum posts, and tried various methods of configuring it, but I've had no luck so far. One of the better configuration methods I found is the one below. But still my phone says it can't communicate with the L2TP-VPN server. Any suggestions?
/ip pool
add name=IPSECVPN ranges=192.168.1.10-192.168.1.15

/ppp profile
add change-tcp-mss=yes local-address=192.168.1.1 name=ipsec remote-address=IPSECVPN use-encryption=yes

/ppp secret
add name=user password=pass profile=ipsec

/interface l2tp-server server
set default-profile=ipsec enabled=yes ipsec-secret=secret-pass use-ipsec=yes

/ip ipsec proposal
set [ find default=yes ] enc-algorithms=3des

/ip ipsec peer
add address=0.0.0.0/0 dpd-interval=2s enc-algorithm=3des exchange-mode=main-l2tp generate-policy=port-override secret=secret-pass
 
User avatar
donsergio
newbie
Posts: 48
Joined: Wed Jan 31, 2018 8:35 pm
Location: Spain

Re: IPSec VPN for iPhone

Fri Feb 16, 2018 3:58 pm

Hi, have you opened ports on RB750 ??

Regards!!
 
aristosv
just joined
Topic Author
Posts: 2
Joined: Thu Feb 15, 2018 10:50 pm

Re: IPSec VPN for iPhone

Fri Feb 16, 2018 4:58 pm

that's a good question.
I'm not really familiar with Mikrotik routeros (I bought it yesterday) so I'm just figuring out how these commands work.

Do you know which commands I must run to open the ports for VPN?

Who is online

Users browsing this forum: No registered users and 63 guests