Community discussions

 
nemoforum
newbie
Topic Author
Posts: 27
Joined: Thu Jan 05, 2017 11:08 pm

hAP ac² LAN->WiFi 5GHz performance issue.

Fri Mar 30, 2018 2:24 pm

I've bought hAP ac^2, configured it and got an issue: transferring speed from LAN device (micro server with 1 Gbps eth) to Wi-Fi 5GHz device is VERY low and unstable: 0.5..2..5..20..50 Mbps, tested with two 5GHz devices with iperf3.
At the same time transferring speed from LAN device to Wi-Fi 2.4GHz device is OK: around 40..50 Mbps.
In addition:
WAN -> LAN (server) = 800..900 Mbps
LAN (server) -> WAN = 200..300 Mbps
WAN -> Wi-Fi 5GHz (device 1) ~ 200 Mbps
Wi-Fi 5GHz (device 1) -> WAN ~ 220 Mbps
WAN -> Wi-Fi 5GHz (device 2) ~ 150 Mbps
Wi-Fi 5GHz (device 2) -> WAN ~ 170 Mbps

For testing purposes, I've completely reset router's configuration, applied default one.
I didn't make ANY changes to the default config.
I got the same result: awful LAN->Wi-Fi-5GHz performance.
Laptop performance (via hAP ac2 Wi-Fi 5GHz <-> WAN):
http://www.speedtest.net/result/7182653292
20180329202204U5c7.png
-------------------------
Server performance (via hAP ac2: LAN <-> WAN):
root@server:~# speedtest-cli
Retrieving speedtest.net configuration...
Testing from Lanet Network Ltd (176.38.50.85)...
Retrieving speedtest.net server list...
Selecting best server based on ping...
Hosted by Adamant Ltd. (Kiev) [0.52 km]: 9.235 ms
Testing download speed................................................................................
Download: 783.33 Mbit/s
Testing upload speed................................................................................................
Upload: 815.18 Mbit/s
---------------------------
And LAN->Wi-Fi-5GHz (laptop) performance:
root@server:~# iperf3 -c 192.168.88.253
Connecting to host 192.168.88.253, port 5201
[ 4] local 192.168.88.252 port 44302 connected to 192.168.88.253 port 5201
[ ID] Interval Transfer Bandwidth Retr Cwnd
[ 4] 0.00-1.00 sec 1.21 MBytes 10.1 Mbits/sec 11 1.43 KBytes
[ 4] 1.00-2.00 sec 4.54 MBytes 38.1 Mbits/sec 21 85.5 KBytes
[ 4] 2.00-3.00 sec 1.64 MBytes 13.8 Mbits/sec 0 108 KBytes
[ 4] 3.00-4.00 sec 3.12 MBytes 26.2 Mbits/sec 37 237 KBytes
[ 4] 4.00-5.00 sec 2.82 MBytes 23.6 Mbits/sec 41 24.2 KBytes
[ 4] 5.00-6.00 sec 4.24 MBytes 35.6 Mbits/sec 28 1.43 KBytes
[ 4] 6.00-7.00 sec 6.98 MBytes 58.6 Mbits/sec 54 1.43 KBytes
[ 4] 7.00-8.00 sec 13.1 MBytes 110 Mbits/sec 64 68.4 KBytes
[ 4] 8.00-9.00 sec 980 KBytes 8.03 Mbits/sec 36 69.9 KBytes
[ 4] 9.00-10.00 sec 5.09 MBytes 42.7 Mbits/sec 13 1.43 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 43.7 MBytes 36.7 Mbits/sec 305 sender
[ 4] 0.00-10.00 sec 43.2 MBytes 36.3 Mbits/sec receiver

iperf Done.
-----------------------

What's wrong with LAN (server) -> Wi-Fi 5GHz (device *) ?!
When will this be fixed?
You do not have the required permissions to view the files attached to this post.
Last edited by nemoforum on Fri Mar 30, 2018 11:11 pm, edited 1 time in total.
 
AlexT
just joined
Posts: 22
Joined: Thu Mar 29, 2018 9:51 am

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Fri Mar 30, 2018 10:48 pm

I have the same problem with hap ac2. 2.4 GHz and 5.2 GHz work poorly, speed is unstable.
 
nemoforum
newbie
Topic Author
Posts: 27
Joined: Thu Jan 05, 2017 11:08 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Sat Mar 31, 2018 1:41 pm

@normis,
Any solution?
Should I return the router?
 
poizzon
Member Candidate
Member Candidate
Posts: 113
Joined: Fri Jun 21, 2013 12:53 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Sun Apr 01, 2018 6:07 pm

Can you provide more detail statitic ?

1. registration table statistic : viewtopic.php?f=7&t=131937&p=649062#p648953
2. registration table signal : viewtopic.php?t=69228#p370647
3. chanel overlap viewtopic.php?t=69228#p424730
4. speed test results
5. which equipment you are using
6. which ROS version

I'm trying test 3cAP ac, via CapsMan, and see same performance issues...

There is tests, with no changes :
Download 95.72Mbps Upload 20.40Mbps
Download 180.74Mbps Upload 152.15Mbps
Download 185.61Mbps Upload 218.71Mbps
Download 257.16Mbps Upload 262.10Mbps

Ceee5180
Download 253.68Mbps Upload 270.94Mbps
eCee5200
Download 112.55Mbps Upload 64.57Mbps
eeCe5220
Download 157.95Mbps Upload 273.95Mbps
eeeC5240
Download 123.96Mbps Upload 62.53Mbps



But some times i got :
Download 373.18Mbps Upload 531.18Mbps
--
poi
 
nemoforum
newbie
Topic Author
Posts: 27
Joined: Thu Jan 05, 2017 11:08 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Sun Apr 01, 2018 11:15 pm

1.
2018040123023924E9.png
2.
20180401230345e6d5.png
3.
20180401230657q4A0.png
4. http://www.speedtest.net/result/7182653292 and http://www.speedtest.net/result/a/3792054297 , see 1st post
5. Intel AC-7260, Xiaomi Redmi Note 3 Pro ( http://www.speedtest.net/result/a/3792054297 )
6. 6.42rc52

It's not Wi-Fi link issue.
It's LAN-WiFi 5GHz issue, because bought Laptop and Phone shows the same problem with LAN-WiFi 5GHz connection.
And there was NO the issue like described with hAP ac.
You do not have the required permissions to view the files attached to this post.
 
nemoforum
newbie
Topic Author
Posts: 27
Joined: Thu Jan 05, 2017 11:08 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Sun Apr 01, 2018 11:45 pm

The same tests with my phone and server.
Screenshot_Magic_iPerf_20180401-234131.png
Screenshot_Speedtest_20180401-234200.png
Screenshot_JuiceSSH_20180401-234245.png
Upload speed from server is lower, because vlan is configured for internet connection, BTW why so slow?
With default ROS config speed is around 800..900 Mbps up and down (from server to internet and backward).
You do not have the required permissions to view the files attached to this post.
 
nemoforum
newbie
Topic Author
Posts: 27
Joined: Thu Jan 05, 2017 11:08 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Tue Apr 03, 2018 10:20 am

Hey Mikrotik! Any answer?
 
poizzon
Member Candidate
Member Candidate
Posts: 113
Joined: Fri Jun 21, 2013 12:53 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Tue Apr 03, 2018 11:11 am

Hey Mikrotik! Any answer?
Can you perform test with changed chanel width?

Ceee5180
eCee5200
eeCe5220
eeeC5240
?

Also Intel 7260 slow performance :

http://www.troublefixers.org/laptops/fi ... ws-10/679/

https://communities.intel.com/thread/59726
--
poi
 
nemoforum
newbie
Topic Author
Posts: 27
Joined: Thu Jan 05, 2017 11:08 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Tue Apr 03, 2018 7:15 pm

Intel 7260 slow - ha-ha!
It works perfectly with hAP ac (I got stable 200..220 Mbps with it) and many other routers. As well as Xiaomi Redmi Note 3 works perfectly with hAP ac (on 5GHz).

The test results you asked for are below, as expected nothing changed.
Also, please check this link viewtopic.php?f=7&t=132648&p=651986#p651751


C:\Users\nemof\Desktop\iperf-3.1.3-win64>iperf3.exe -c 10.10.10.253 -R
Connecting to host 10.10.10.253, port 5201
Reverse mode, remote host 10.10.10.253 is sending
[ 4] local 10.10.10.95 port 53670 connected to 10.10.10.253 port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 4.97 MBytes 41.6 Mbits/sec
[ 4] 1.00-2.00 sec 3.87 MBytes 32.5 Mbits/sec
[ 4] 2.00-3.00 sec 4.38 MBytes 36.8 Mbits/sec
[ 4] 3.00-4.00 sec 2.87 MBytes 24.1 Mbits/sec
[ 4] 4.00-5.00 sec 3.67 MBytes 30.7 Mbits/sec
[ 4] 5.00-6.00 sec 2.29 MBytes 19.2 Mbits/sec
[ 4] 6.00-7.00 sec 2.65 MBytes 22.2 Mbits/sec
[ 4] 7.00-8.00 sec 2.31 MBytes 19.4 Mbits/sec
[ 4] 8.00-9.00 sec 3.33 MBytes 27.9 Mbits/sec
[ 4] 9.00-10.00 sec 3.19 MBytes 26.8 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 34.3 MBytes 28.7 Mbits/sec 70 sender
[ 4] 0.00-10.00 sec 33.7 MBytes 28.2 Mbits/sec receiver

iperf Done.

C:\Users\nemof\Desktop\iperf-3.1.3-win64>iperf3.exe -c 10.10.10.253 -R
Connecting to host 10.10.10.253, port 5201
Reverse mode, remote host 10.10.10.253 is sending
[ 4] local 10.10.10.95 port 53678 connected to 10.10.10.253 port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 643 KBytes 5.26 Mbits/sec
[ 4] 1.00-2.00 sec 436 KBytes 3.57 Mbits/sec
[ 4] 2.00-3.00 sec 2.34 MBytes 19.6 Mbits/sec
[ 4] 3.00-4.00 sec 1.51 MBytes 12.7 Mbits/sec
[ 4] 4.00-5.00 sec 4.38 MBytes 36.7 Mbits/sec
[ 4] 5.00-6.00 sec 5.36 MBytes 45.0 Mbits/sec
[ 4] 6.00-7.00 sec 2.39 MBytes 20.1 Mbits/sec
[ 4] 7.00-8.00 sec 5.41 MBytes 45.2 Mbits/sec
[ 4] 8.00-9.00 sec 8.07 MBytes 67.8 Mbits/sec
[ 4] 9.00-10.00 sec 16.6 MBytes 139 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 47.6 MBytes 39.9 Mbits/sec 233 sender
[ 4] 0.00-10.00 sec 47.1 MBytes 39.5 Mbits/sec receiver

iperf Done.

C:\Users\nemof\Desktop\iperf-3.1.3-win64>iperf3.exe -c 10.10.10.253 -R
Connecting to host 10.10.10.253, port 5201
Reverse mode, remote host 10.10.10.253 is sending
[ 4] local 10.10.10.95 port 53678 connected to 10.10.10.253 port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 643 KBytes 5.26 Mbits/sec
[ 4] 1.00-2.00 sec 436 KBytes 3.57 Mbits/sec
[ 4] 2.00-3.00 sec 2.34 MBytes 19.6 Mbits/sec
[ 4] 3.00-4.00 sec 1.51 MBytes 12.7 Mbits/sec
[ 4] 4.00-5.00 sec 4.38 MBytes 36.7 Mbits/sec
[ 4] 5.00-6.00 sec 5.36 MBytes 45.0 Mbits/sec
[ 4] 6.00-7.00 sec 2.39 MBytes 20.1 Mbits/sec
[ 4] 7.00-8.00 sec 5.41 MBytes 45.2 Mbits/sec
[ 4] 8.00-9.00 sec 8.07 MBytes 67.8 Mbits/sec
[ 4] 9.00-10.00 sec 16.6 MBytes 139 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 47.6 MBytes 39.9 Mbits/sec 233 sender
[ 4] 0.00-10.00 sec 47.1 MBytes 39.5 Mbits/sec receiver

iperf Done.

C:\Users\nemof\Desktop\iperf-3.1.3-win64>iperf3.exe -c 10.10.10.253 -R
Connecting to host 10.10.10.253, port 5201
Reverse mode, remote host 10.10.10.253 is sending
[ 4] local 10.10.10.95 port 53678 connected to 10.10.10.253 port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 643 KBytes 5.26 Mbits/sec
[ 4] 1.00-2.00 sec 436 KBytes 3.57 Mbits/sec
[ 4] 2.00-3.00 sec 2.34 MBytes 19.6 Mbits/sec
[ 4] 3.00-4.00 sec 1.51 MBytes 12.7 Mbits/sec
[ 4] 4.00-5.00 sec 4.38 MBytes 36.7 Mbits/sec
[ 4] 5.00-6.00 sec 5.36 MBytes 45.0 Mbits/sec
[ 4] 6.00-7.00 sec 2.39 MBytes 20.1 Mbits/sec
[ 4] 7.00-8.00 sec 5.41 MBytes 45.2 Mbits/sec
[ 4] 8.00-9.00 sec 8.07 MBytes 67.8 Mbits/sec
[ 4] 9.00-10.00 sec 16.6 MBytes 139 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 47.6 MBytes 39.9 Mbits/sec 233 sender
[ 4] 0.00-10.00 sec 47.1 MBytes 39.5 Mbits/sec receiver

iperf Done.
 
poizzon
Member Candidate
Member Candidate
Posts: 113
Joined: Fri Jun 21, 2013 12:53 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Tue Apr 03, 2018 7:30 pm

We are making a decision - not to buy MikroTik, as always AP to buy Ubiquiti

It's interesting to get feedback about FT and Unifi series..

https://help.ubnt.com/hc/en-us/articles ... st-Roaming
--
poi
 
nemoforum
newbie
Topic Author
Posts: 27
Joined: Thu Jan 05, 2017 11:08 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Sat Apr 07, 2018 8:03 pm

Mikrotik,

Any official answer?
 
nemoforum
newbie
Topic Author
Posts: 27
Joined: Thu Jan 05, 2017 11:08 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Mon Apr 09, 2018 7:35 pm

Intel ac 8260 - the same issue.

Mikrotik?
 
poizzon
Member Candidate
Member Candidate
Posts: 113
Joined: Fri Jun 21, 2013 12:53 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Mon Apr 09, 2018 7:57 pm

Intel ac 8260 - the same issue.

Mikrotik?
Intel ac 8260 - 2018-02-06, 20.40.0.4
You do not have the required permissions to view the files attached to this post.
--
poi
 
User avatar
juliokato
Member Candidate
Member Candidate
Posts: 229
Joined: Mon Oct 26, 2015 4:27 pm
Location: Brazil

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Mon Apr 09, 2018 8:52 pm

equipment mounted pointing up !!!with very good speed...
I apologize my grammatical errors, my english not so good, I am not a native speaker.
Wiki is maintained in English. I use Google translator. 8)
 
poizzon
Member Candidate
Member Candidate
Posts: 113
Joined: Fri Jun 21, 2013 12:53 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Thu Apr 12, 2018 12:51 am

so there is two tests, one test and after few seconds - second test.

no change, no move just chrome open new tab and repteat test

so wehere is comment from MT ? :D
You do not have the required permissions to view the files attached to this post.
--
poi
 
andriys
Forum Guru
Forum Guru
Posts: 1179
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Thu Apr 12, 2018 3:02 pm

Any official answer?
I'm a bit tired repeating this again and again, but...

This is a user forum. Period. Mikrotik staff may occasionally answer some questions here, but they do not have to. If you need an "official answer" you should write you question to support@. I'm afraid that's the only "official way" to ask you questions.
 
yhfung
Member Candidate
Member Candidate
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Thu Apr 12, 2018 3:39 pm

I've bought hAP ac^2, configured it and got an issue: transferring speed from LAN device (micro server with 1 Gbps eth) to Wi-Fi 5GHz device is VERY low and unstable: 0.5..2..5..20..50 Mbps, tested with two 5GHz devices with iperf3.

What's wrong with LAN (server) -> Wi-Fi 5GHz (device *) ?!
When will this be fixed?
Have you got any reply from MikroTik Support?

YH
 
nemoforum
newbie
Topic Author
Posts: 27
Joined: Thu Jan 05, 2017 11:08 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Thu Apr 12, 2018 6:41 pm

Have you got any reply from MikroTik Support?
The first valued answer since 29 March.
You do not have the required permissions to view the files attached to this post.
 
mlenhart
Frequent Visitor
Frequent Visitor
Posts: 83
Joined: Mon Oct 30, 2017 11:30 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Thu Apr 19, 2018 10:20 am

Any official answer?
I'm a bit tired repeating this again and again, but...

This is a user forum. Period. Mikrotik staff may occasionally answer some questions here, but they do not have to. If you need an "official answer" you should write you question to support@. I'm afraid that's the only "official way" to ask you questions.
andriys: as you are an official MikroTik employee, could you please raise up an idea of creation an official communication channel MikroTik -> users? IMHO if everyone who has any question should write to support@ then you would not do anything else just responding to e-mails.
I (and definitely I am not the only one) think that this could be beneficial to both - MikroTik and also its users.
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Thu Apr 19, 2018 3:13 pm

It seams the email to support is the only way, because they have a ticketing system there and maybe some people that do the filtering above that to ensure nothing will be lost and everything will be replied at least somehow. I think that such way is quite secure but not fast enough. Other ways could loose tracking. And as you see, mikrotik is able to react officially here on the forum if they wish. Unfortunately they do not wish at given time or do not know how to react many times.
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Fri Apr 20, 2018 12:23 am

You can always hire a mikrotik consulant to try solve your problem, and you have a big issue here. 12dbm different signal in chain 0 and 1. this is BIG difference. you also have CCQ at 88. This mean that there is wifi issue here. Your client have -46 in signal. This is to "loud" to have perfect signal. Think about a sound system with 2 speakers. In your setup you have 12db more power at one, and will only hear this speaker, as is to loud for the other. You are also having to much power- and to much sound out of speaker, and its to loud to hear something clear. Like standing next to the biggest speaker in a rock concert. I think your solution is to reduce power at AP - and check power setting at client. But dont reduce to much - if you are to far away from the speaker - you will also not hear annything. If all signals are the same check if your rates are flapping. a lot of broadcast can make wifi speed flapping, If you check your 24:73 device, it have a link at 6 mb/s. When there are broadcast packet here- 802.11 will say - hey. i have a broadcast packet to all of us. What is the higest speed that we can use for communication. And the answer, sendt to all clients - is 6mb/s. and link goes down to 6mb/s for all clients for broadcast packet.

There might also be a problem in ROS, but its unlikly, a lot of thousens of other users would experience the same as you.
 
squeeze
Member Candidate
Member Candidate
Posts: 146
Joined: Thu Mar 22, 2018 7:53 pm

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Fri Apr 20, 2018 12:22 pm

There might also be a problem in ROS, but its unlikly, a lot of thousens of other users would experience the same as you.

Except they do. The problems with hap ac2 WiFi are already widely reported, acknowledged by Mikrotik themselves (who have been struggling to fix them with rapid successive firmware release candidates) and the hap ac2 has only just been released and available to public. Just wait a month if you think bad reports have not rolled in yet...

Even testing two wireless bridged hap ac2 WiFi under non-interference conditions, right next to each other, will result in flapping, CCQs of 50%, enormous retries, and both peak and average performance that is a fraction of the capability of their radios or link rates.
 
User avatar
Davis
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Mon Aug 01, 2011 12:27 pm
Location: Latvia, Riga
Contact:

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Tue May 01, 2018 2:35 am

I have noticed that (at least in my specific setup) hAP ac² together with Intel 7260 wifi card has issues with action=set-priority mangle rules.
I had used this mangle rule (rule comes from this MUM presentation) and disabling it in some cases drastically improved performance (e.g. SFTP file download improved from 1-2 MB/s to 9-10 MB/s limited by internet speed):
/ip firewall mangle
add action=set-priority chain=postrouting comment="DSCP to 802.11 WMM" \
    new-priority=from-dscp out-interface=bridge passthrough=yes
Also I have noticed that different versions of Intel drivers behave differently (e.g. 16.5.3.6 seem to offer better and more stable speeds than 18.33.12.2).
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1738
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: hAP ac² LAN->WiFi 5GHz performance issue.

Tue May 01, 2018 3:31 am

I have noticed that (at least in my specific setup) hAP ac² together with Intel 7260 wifi card has issues with action=set-priority mangle rules.
I had used this mangle rule (rule comes from this MUM presentation) and disabling it in some cases drastically improved performance (e.g. SFTP file download improved from 1-2 MB/s to 9-10 MB/s limited by internet speed):
/ip firewall mangle
add action=set-priority chain=postrouting comment="DSCP to 802.11 WMM" \
    new-priority=from-dscp out-interface=bridge passthrough=yes
Also I have noticed that different versions of Intel drivers behave differently (e.g. 16.5.3.6 seem to offer better and more stable speeds than 18.33.12.2).
inconsistent performance of intel wifi drivers is well known on wifi community

Who is online

Users browsing this forum: MSN [Bot] and 80 guests