Community discussions

MikroTik App
 
wilburt
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 84
Joined: Tue Aug 24, 2010 3:07 am

Multi-VLAN on ports

Sun Apr 22, 2018 3:42 am

I am looking to configure on the eth ports of a RBcAPGi 3 vlans and 1 non-vlan

this is the current setup

PC -> RB1100 -> RBcAPGi -> RB411

all RB devices have the following bridges configured

defaultbridge (no vlans) - this is used to bridge the eth ports together
managementbridge (vlan8) to bridge vlan8 ports
vlan15bridge (vlan15) to bridge vlan15 ports
vlan22bridge (vlan22)to bridge vlan22 ports

i can connect to the RBcAPGi from my PC and RB1100. However, i can't connect to the RB411

this is the RBcAPGI config

/interface bridge
add mtu=1500 name=ManagementBridge protocol-mode=none
add mtu=1500 name=defaultbridge protocol-mode=none
add mtu=1500 name=vlan15bridge protocol-mode=none
add mtu=1500 name=vlan22bridge protocol-mode=none
/interface wireless
set [ find default-name=wlan2 ] name=wlan5 ssid=MikroTik
/interface vlan
add interface=ether1 name=vlan8_e1 vlan-id=8
add interface=ether2 name=vlan8_e2 vlan-id=8
add interface=ether1 name=vlan15_e1 vlan-id=15
add interface=ether2 name=vlan15_e2 vlan-id=15
add interface=ether1 name=vlan22_e1 vlan-id=22
add interface=ether2 name=vlan22_e2 vlan-id=22
/interface bridge port
add bridge=ManagementBridge interface=vlan8_e1
add bridge=ManagementBridge interface=vlan8_e2
add bridge=vlan15bridge interface=vlan15_e1
add bridge=vlan15bridge interface=vlan15_e2
add bridge=vlan15bridge interface=wlan2
add bridge=vlan22bridge interface=vlan22_e1
add bridge=vlan22bridge interface=vlan22_e2
add bridge=vlan22bridge interface=wlan1
add bridge=defaultbridge interface=ether1
add bridge=defaultbridge interface=ether2
/ip address
add address=192.168.88.222/24 interface=ManagementBridge network=192.168.88.0
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns static
add address=192.168.88.1 name=router
/ip route
add distance=1 gateway=192.168.88.1

have i configured something wrong? i can't connect to the device on the 192.168.88.0/24 network. If i disable the defaultbridge eth ports on the RBcAPGi device i am able to connect to the RB411
 
Sob
Forum Guru
Forum Guru
Posts: 5470
Joined: Mon Apr 20, 2009 9:11 pm

Re: Multi-VLAN on ports

Wed Apr 25, 2018 5:07 am

Your config looks very similar to this:

https://wiki.mikrotik.com/wiki/Manual:L ... interfaces
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply. Not intended as incentive for masochists.

Who is online

Users browsing this forum: cezars, Google [Bot], hel, jatoledano and 50 guests