Community discussions

MikroTik App
 
tuxtlequino
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 68
Joined: Tue Feb 16, 2016 12:46 am

Over half of my packets are being dropped

Tue Apr 24, 2018 8:14 am

I just configure several routers using the new bridge in 6.42 according to the instructions. I am not sure if there is something here that I missed or I miss-configured, but for the life of I have been trying to figure this out for the last four days without any clue. Here are the routers I am using. Any ideas or help is appreciated.

Main Router ->Office
Main Router ->Gym->Boss
Main Router ->Houses->House1
Main Router ->Peck

Main Router
/system identity
set name=MainRouter

/interface bridge
add comment="Switched ports" name=Switch vlan-filtering=yes protocol-mode=rstp

/interface ethernet
set [ find default-name=ether1 ] comment=WAN name=WAN
set [ find default-name=ether2 ] comment=\
    "Office Trunk - VLAN10, VLAN30, VLAN40, VLAN99"
set [ find default-name=ether3 ] comment="Gym Trunk - VLAN10, VLAN30, VLAN99"
set [ find default-name=ether4 ] comment="Houses Trunk - VLAN20, VLAN99"
set [ find default-name=ether5 ] comment="Peck Trunk - VLAN20, VLAN99"
set [ find default-name=ether6 ] comment="Sign - VLAN40"
set [ find default-name=ether7 ] comment=VLAN20 disabled=yes
set [ find default-name=ether8 ] comment=VLAN99

/interface vlan
add comment=Work interface=Switch name=VLAN10 vlan-id=10
add comment=Houses interface=Switch name=VLAN20 vlan-id=20
add comment=Guests interface=Switch name=VLAN30 vlan-id=30
add comment=Sign interface=Switch name=VLAN40 vlan-id=40
add comment=Management interface=Switch name=VLAN99 vlan-id=99

/ip pool
add name=WorkPool ranges=192.168.1.100-192.168.1.200
add name=HousingPool ranges=192.168.20.100-192.168.20.200
add name=GuestsPool ranges=192.168.30.100-192.168.30.200
add name=SignPool ranges=172.16.192.20-172.16.192.200
add name=MgmtPool ranges=192.168.99.2-192.168.99.20

/ip dhcp-server
add address-pool=WorkPool disabled=no interface=VLAN10 lease-time=3h name=\
    dchpWork
add address-pool=HousingPool disabled=no interface=VLAN20 lease-time=3h name=\
    dhcpHousing
add address-pool=GuestsPool disabled=no interface=VLAN30 lease-time=2h name=\
    dhcpGuests
add address-pool=SignPool disabled=no interface=VLAN40 lease-time=3d name=\
    dhcpSign
add address-pool=MgmtPool disabled=no interface=VLAN99 lease-time=3h name=\
    dhcpMgmt

/interface bridge port
add bridge=Switch interface=ether2
add bridge=Switch interface=ether3
add bridge=Switch interface=ether4
add bridge=Switch interface=ether5
add bridge=Switch interface=ether6 pvid=40
add bridge=Switch interface=ether7 pvid=20
add bridge=Switch interface=ether8 pvid=99

/interface bridge vlan
add bridge=Switch tagged=Switch,ether2,ether3 vlan-ids=10
add bridge=Switch tagged=Switch,ether4,ether5 untagged=ether7 vlan-ids=20
add bridge=Switch tagged=Switch,ether2,ether3 vlan-ids=30
add bridge=Switch tagged=Switch,ether2 untagged=ether6 vlan-ids=40
add bridge=Switch tagged=Switch,ether2,ether3,ether4,ether5 untagged=ether8 \
    vlan-ids=99

/ip address
add address=192.168.1.1/24 interface=VLAN10 network=192.168.1.0
add address=192.168.20.1/24 interface=VLAN20 network=192.168.20.0
add address=192.168.30.1/24 interface=VLAN30 network=192.168.30.0
add address=172.16.192.1/24 interface=VLAN40 network=172.16.192.0
add address=192.168.99.1/24 interface=VLAN99 network=192.168.99.0

/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=WAN

/ip firewall nat
add action=masquerade chain=srcnat
Office
/system identity
set name=Office

/interface bridge
add comment="Switched ports" name=Switch vlan-filtering=yes protocol-mode=rstp
add name=br-vlan10
add name=br-vlan30

/interface ethernet
set [ find default-name=ether1 ] name=ether1 comment="MainRouter Trunk - VLAN10, 30, 40, 99"
set [ find default-name=ether2 ] name=ether2 comment="Old Computer - VLAN10"
set [ find default-name=ether3 ] name=ether3 comment="Printer -VLAN10"
set [ find default-name=ether4 ] name=ether4 comment="Spare - VLAN10"
set [ find default-name=ether5 ] name=ether5 comment="Sign Router - VLAN40"

/interface wireless
set [ find default-name=wlan1 ] disabled=no frequency=auto mode=ap-bridge \
    name=wlan1-Work security-profile=Staff ssid=Office-Work wireless-protocol=802.11
set [ find default-name=wlan2 ] disabled=no frequency=auto mode=ap-bridge \
    name=wlan2-Guest security-profile=Guest ssid=Office-Guest wireless-protocol=802.11

/interface vlan
add interface=Switch name=VLAN10 comment=Work vlan-id=10
add interface=Switch name=VLAN30 comment=Guests vlan-id=30
add interface=Switch name=VLAN40 comment=Sign vlan-id=40
add interface=Switch name=VLAN99 comment=Management vlan-id=99

/interface bridge port
add bridge=Switch interface=ether1
add bridge=Switch interface=ether2 pvid=10
add bridge=Switch interface=ether3 pvid=10
add bridge=Switch interface=ether4 pvid=10
add bridge=Switch interface=ether5 pvid=40
add bridge=br-vlan10 interface=VLAN10-Work
add bridge=br-vlan30 interface=VLAN30-Guests
add bridge=br-vlan10 interface=wlan1
add bridge=br-vlan30 interface=wlan2

/interface bridge vlan
add bridge=Switch tagged=ether1 untagged=ether2,ether3,ether4 vlan-ids=10
add bridge=Switch tagged=ether1 vlan-ids=30
add bridge=Switch tagged=ether1 untagged=ether5 vlan-ids=40
add bridge=Switch tagged=Switch,ether1 vlan-ids=99

/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=VLAN99

Gym
/system identity
set name=GymRouter

/interface bridge
add name=br-vlan10
add name=Switch vlan-filtering=yes protocol-mode=rstp

/interface ethernet
set [ find default-name=ether1 ] comment="MainRouter Trunk - VLAN 10,30,99"
set [ find default-name=ether2 ] comment="Boss Trunk - VLAN10"
set [ find default-name=ether3 ] comment="To PC - VLAN10"
set [ find default-name=ether4 ] comment="Laser Printer- VLAN10"
set [ find default-name=ether5 ] comment="NAS - VLAN10"
set [ find default-name=ether6 ] comment="Direct - VLAN30" disabled=yes
set [ find default-name=ether7 ] comment="Direct - VLAN99" disabled=no
set [ find default-name=ether8 ] comment="Direct - VLAN99" disabled=yes
set [ find default-name=sfp1 ] disabled=yes

/interface vlan
add comment=Work interface=Switch name=VLAN10 vlan-id=10
add comment=Guests interface=Switch name=VLAN30 vlan-id=30
add comment=Management interface=Switch name=VLAN99 vlan-id=99

/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no frequency=auto \
    mode=ap-bridge security-profile=staff ssid=Belkin80 wps-mode=disabled

/interface bridge port
add bridge=Switch interface=ether1
add bridge=Switch interface=ether2
add bridge=Switch interface=ether3 pvid=10
add bridge=Switch interface=ether4 pvid=10
add bridge=Switch interface=ether5 pvid=10
add bridge=Switch interface=ether6 pvid=30
add bridge=Switch interface=ether7 pvid=99
add bridge=br-vlan10 interface=wlan1
add bridge=br-vlan10 interface=VLAN10

/interface bridge vlan
add bridge=Switch tagged=ether1,ether2 untagged=ether3,ether4,ether5 vlan-ids=10
add bridge=Switch tagged=ether1 untagged=ether6 vlan-ids=30
add bridge=Switch tagged=Switch,ether1,ether2 untagged=ether7 vlan-ids=99

/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=VLAN99
Boss
/system identity
set name=Boss

/interface bridge
add comment="Switched ports" name=Switch vlan-filtering=yes protocol-mode=rstp
add name=br-vlan10

/interface ethernet
set [ find default-name=ether1 ] comment="Gym Trunk - VLAN10, 99"
set [ find default-name=ether2 ] comment="Spare - VLAN10"
set [ find default-name=ether3 ] comment="Spare - VLAN10"
set [ find default-name=ether4 ] comment="Spare - VLAN10"
set [ find default-name=ether5 ] comment="Spare - VLAN99"

/interface wireless
set [ find default-name=wlan1 ] disabled=yes ssid=Pastor1
set [ find default-name=wlan2 ] disabled=yes ssid=Pastor2

/interface vlan
add interface=Switch name=VLAN10 comment=Work vlan-id=10
add interface=Switch name=VLAN99 comment=Management vlan-id=99

/interface bridge port
add bridge=br-vlan10 interface=wlan1
add bridge=br-vlan10 interface=wlan2
add bridge=br-vlan10 interface=VLAN10
add bridge=Switch interface=ether1
add bridge=Switch interface=ether2 pvid=10
add bridge=Switch interface=ether3 pvid=10
add bridge=Switch interface=ether4 pvid=10
add bridge=Switch interface=ether5 pvid=99

/interface bridge vlan
add bridge=Switch tagged=ether1 untagged=ether2,ether3,ether4 vlan-ids=10
add bridge=Switch tagged=Switch,ether1 untagged=ether5 vlan-ids=99

/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=VLAN99

 
tuxtlequino
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 68
Joined: Tue Feb 16, 2016 12:46 am

Re: Over half of my packets are being dropped  [SOLVED]

Tue Apr 24, 2018 7:52 pm

Okay. I found the culprit. One of my routers is part of the CRS routers. Although there is a new bridge configuration available for hardware acceleration, this doesn't apply when we are talking about CRS routers (it is kind of a mix and match).

I couldn't find that in the documentation, and it was just by pure desperation that I got the answer. I hope that this helps someone. It would be good to make a note in the wiki about bridges and VLANS that the CRS routers still need to use the old switch chip configuration in addition to some of the new changes. If you need my config for that particular router, just ask and I can post it here.

EDIT: I accidentally said CCR instead of CRS. Now this may make more sense to some.

Who is online

Users browsing this forum: cienki, Google [Bot], Irish9, kinjakinja, mtkvvv and 116 guests