Community discussions

MikroTik App
 
mworsnop
newbie
Topic Author
Posts: 28
Joined: Mon Apr 18, 2016 8:34 am

port speed

Wed May 09, 2018 1:38 am

I just dropped off my business line with Spectrum Internet and got a residence line 400 Mbs down and 20 up. BUT I guess my old routerboard doesnt handle the 400 Mb speeds. Is there a setting on this or how do I find out if I need a new routerboard?

If I need a new version what is recommended? Simple office network.

Thank you in advance
 
User avatar
MangleRule
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Mon May 07, 2018 1:05 am

Re: port speed

Wed May 09, 2018 4:06 am

It would help to know your configuration as well as the current hardware you have. What speeds can you get through the router currently and what does your CPU look like while you push traffic.
MTCNAMTCREMTCINE | MTCTCE | MTCUME | UBWA
 
mworsnop
newbie
Topic Author
Posts: 28
Joined: Mon Apr 18, 2016 8:34 am

Re: port speed

Wed May 09, 2018 4:43 am

That's my question. There must be something to tell me what the hardware is. If the hardware can't support 1 Gb I need to change to new hardware. So how do I see the current hardware?
 
yottabit
Member Candidate
Member Candidate
Posts: 174
Joined: Thu Feb 21, 2013 5:56 am

Re: port speed

Wed May 09, 2018 5:00 am

What? The model number is on the label, in Webfig, in Winbox, and in the CLI.

Post the output of "/export hide-sensitive" and we can also check to see if you have fastpath enabled, and expensive QoS rules, etc.

Also let us know how you're testing the speed, e.g., to which sites, using Wi-Fi on which model of station hardware, or by Ethernet.

Sent from my Pixel XL using Tapatalk

 
mworsnop
newbie
Topic Author
Posts: 28
Joined: Mon Apr 18, 2016 8:34 am

Re: port speed

Wed May 09, 2018 5:09 am

Model is a 450G Sorry it took time to find that in the webconfig.


# may/08/2018 19:06:49 by RouterOS 6.40.5
# software id = 3J8U-1DQT
#
# model = 450G
# serial number = 1DFC01E27314
/interface ethernet
set [ find default-name=ether4 ] arp=proxy-arp comment="port 4 - Existing Mark Systems internal LAN" name=81LAN
set [ find default-name=ether3 ] comment="port 3" name=ISP
set [ find default-name=ether1 ] comment="port 1 - NOT USED" disabled=yes name="X Not Used"
set [ find default-name=ether2 ] comment="port 2 NOT USED" disabled=yes name=XX
set [ find default-name=ether5 ] comment="port 5 - AT-T UVERSE 24x3" disabled=yes name=xxxNA
/interface l2tp-server
add disabled=yes name=mworsnop user=mworsnop
/interface pptp-server
add name=pptp-in1 user=mworsnop
/ip neighbor discovery
set ISP discover=no
set "X Not Used" discover=no
set XX discover=no
set xxxNA discover=no
set mworsnop discover=no
set pptp-in1 discover=no
/interface wireless security-profiles
set [ find default=yes ] group-ciphers="" supplicant-identity=MikroTik unicast-ciphers=""
/ip ipsec proposal
set [ find default=yes ] disabled=yes enc-algorithms=aes-128-cbc
add enc-algorithms=3des name="no group forward sec" pfs-group=none
add auth-algorithms=md5 enc-algorithms=3des name=proposal1 pfs-group=none
add enc-algorithms=3des name=default2
/ip pool
add name=dhcp_pool1 ranges=10.215.81.90-10.215.81.159
add name=dhcp-pool-1 ranges=1.192.0.10-191.192.0.10,193.192.0.10-254.192.0.10
/ip dhcp-server
add address-pool=dhcp_pool1 authoritative=after-2sec-delay disabled=no interface=81LAN lease-time=2d name=dhcp1
/queue simple
add max-limit=2M/2M name=laptop105 target=10.215.81.105/32
add name=jesse target=10.215.81.137/32
/queue type
add kind=pcq name=PCQ_download pcq-classifier=dst-address pcq-limit=90000000KiB pcq-rate=65M
add kind=pcq name=PCQ_upload pcq-classifier=src-address pcq-limit=50000KiB pcq-rate=64M pcq-total-limit=20000KiB
/queue interface
set "81LAN" queue=ethernet-default
set ISP queue=ethernet-default
set "X Not Used" queue=ethernet-default
set XX queue=ethernet-default
set xxxNA queue=ethernet-default
/queue tree
add name=queue1x packet-mark=client_download parent=81LAN queue=PCQ_download
add name=queue2x packet-mark=client_upload parent=ISP queue=PCQ_upload
/snmp community
set [ find default=yes ] addresses=10.215.81.0/24 name=mark
/system logging action
set 0 memory-lines=300
set 1 disk-file-name=l2tp disk-lines-per-file=500
set 3 remote=10.215.81.15
add email-to=mworsnop@mark-systems.com name=email target=email
add disk-lines-per-file=500 name=disk2 target=disk
/interface l2tp-server server
set default-profile=default enabled=yes max-mru=1460 max-mtu=1460
/interface pptp-server server
set enabled=yes max-mru=1460 max-mtu=1460
/ip address
add address=10.215.81.21/16 interface=81LAN network=10.215.0.0
add address=66.215.137.90/29 interface=ISP network=66.215.137.88
add address=10.215.84.18/24 interface=xxxNA network=10.215.84.0
add address=99.26.250.37/29 disabled=yes interface=xxxNA network=99.26.250.32
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ISP
/ip dhcp-server lease
add address=10.215.81.97 mac-address=00:11:D9:3D:0C:BF server=dhcp1
add address=10.215.81.127 client-id=1:5c:aa:fd:a4:58:eb mac-address=5C:AA:FD:A4:58:EB server=dhcp1
add address=10.215.81.124 client-id=1:d0:3:4b:39:25:27 comment="Apple TV\
\n" mac-address=D0:03:4B:39:25:27 server=dhcp1
add address=10.215.81.135 client-id=1:5c:aa:fd:c0:5c:5c mac-address=5C:AA:FD:C0:5C:5C server=dhcp1
add address=10.215.81.139 mac-address=00:17:88:2A:D6:AB server=dhcp1
add address=10.215.81.114 client-id=1:5c:aa:fd:c0:5c:40 mac-address=5C:AA:FD:C0:5C:40 server=dhcp1
add address=10.215.81.112 comment="Insteon Hub" mac-address=00:0E:F3:3C:BF:62 server=dhcp1
add address=10.215.81.104 client-id=1:ac:18:26:56:4e:af mac-address=AC:18:26:56:4E:AF server=dhcp1
add address=10.215.81.133 always-broadcast=yes client-id=1:0:50:b6:cd:e8:ba mac-address=00:50:B6:CD:E8:BA server=dhcp1
add address=10.215.81.131 client-id=1:c8:8:e9:d6:e1:33 comment="LG TV Master Wired" mac-address=C8:08:E9:D6:E1:33 server=dhcp1
add address=10.215.81.92 always-broadcast=yes client-id="Cody Nintendo" mac-address=7C:BB:8A:B3:A0:4E server=dhcp1
add address=10.215.81.144 always-broadcast=yes mac-address=6C:56:97:B8:FC:D9 server=dhcp1
add address=10.215.81.142 mac-address=FC:A1:83:30:83:D9 server=dhcp1
add address=10.215.81.140 mac-address=38:F7:3D:4B:FC:39 server=dhcp1
add address=10.215.81.146 client-id=1:0:e:58:51:13:a0 mac-address=00:0E:58:51:13:A0 server=dhcp1
add address=10.215.81.134 always-broadcast=yes comment="Alexa Den Office" mac-address=88:71:E5:D7:3F:4D server=dhcp1
add address=10.215.81.93 always-broadcast=yes client-id=1:4c:66:41:14:f7:3d comment="Cody G Phone" mac-address=4C:66:41:14:F7:3D server=dhcp1
add address=10.215.81.141 client-id=1:6c:56:97:c8:d3:6d comment="Master room echo show\
\n" mac-address=6C:56:97:C8:D3:6D server=dhcp1
add address=10.215.81.118 always-broadcast=yes comment="Alexa Master Bathroom" mac-address=50:F5:DA:E8:C0:7C server=dhcp1
add address=10.215.81.121 always-broadcast=yes comment="Alexa Kitchen" mac-address=44:65:0D:60:AD:2E server=dhcp1
add address=10.215.81.157 client-id="Elk M1XP" mac-address=00:40:9D:43:35:97 server=dhcp1
add address=10.215.81.145 client-id=1:88:53:95:8b:3a:69 mac-address=88:53:95:8B:3A:69 server=dhcp1
add address=10.215.81.155 mac-address=FC:A1:83:B5:0B:BF server=dhcp1
add address=10.215.81.152 client-id=1:b8:c1:11:13:d6:d8 mac-address=B8:C1:11:13:D6:D8 server=dhcp1
add address=10.215.81.119 client-id=1:38:8c:50:ed:70:68 comment="LG TV Living Room" mac-address=38:8C:50:ED:70:68 server=dhcp1
add address=10.215.81.137 client-id=1:30:85:a9:10:97:b2 mac-address=30:85:A9:10:97:B2 server=dhcp1
add address=10.215.81.91 client-id=1:18:60:24:a:9a:1d comment="HP Printer 8720" mac-address=18:60:24:0A:9A:1D server=dhcp1
/ip dhcp-server network
add address=10.215.81.0/24 dns-server=10.215.81.21 domain=snop.com gateway=10.215.81.21 netmask=24
/ip dns
set allow-remote-requests=yes max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4
/ip dns static
add address=10.215.81.100 name=codylaptop.snop.com
add address=10.215.81.144 name=alexa1.snop.com
add address=10.215.81.142 name=alexa2.snop.com
add address=10.215.81.140 name=alexa3.snop.com
add address=10.215.81.138 name=alex.snop.com
add address=10.215.81.93 name=codygphone.snop.com
add address=10.215.81.141 name=alexashow.snop.com
add address=10.215.81.91 name=hpprinter.snop.com
add address=10.215.81.137 name=jesse.snop.com
add address=10.215.81.152 name=codyiPhoneX.snop.com
add address=10.215.81.124 name=appletvmark.snop.com
/ip firewall address-list
add address=192.229.210.181 list=blacklist
add address=62.210.176.62 list=blacklist
add address=62.210.176.89 list=blacklist
add address=10.215.81.137 list=es
/ip firewall filter
add action=accept chain=forward disabled=yes src-address-list=10.215.81.130 time=0s-23h59m,sun,mon,tue,wed,thu,fri,sat
add action=drop chain=forward comment=Blacklist src-address-list=blacklist
add action=drop chain=input connection-state=!established,related in-interface=ISP
add action=drop chain=forward disabled=yes src-address=10.215.81.105
add action=drop chain=forward disabled=yes src-address-list=es time=22h55m-1d,sun,mon,tue,wed,thu,fri,sat
# inactive time
add action=drop chain=forward src-address-list=es time=1h33m-7h,sun,mon,tue,wed,thu,fri,sat
/ip firewall mangle
add action=mark-routing chain=prerouting comment=PHONE new-routing-mark=PHONE passthrough=yes src-address=10.215.81.1
add action=mark-routing chain=prerouting connection-mark=Chart3x1-In in-interface=81LAN new-routing-mark=Chart3x1-In passthrough=no
add action=mark-routing chain=prerouting comment=POSEIDON new-routing-mark=POSEIDON passthrough=no src-address=10.215.81.12
add action=mark-connection chain=prerouting comment="chart 3x1 in new" connection-state=new in-interface=ISP new-connection-mark=Chart3x1-In passthrough=yes
add action=mark-routing chain=prerouting comment=DOC disabled=yes dst-address=0.0.0.0 dst-port=!80,3001,443 new-routing-mark=DOC passthrough=no protocol=tcp src-address=10.215.81.22
add action=mark-routing chain=prerouting comment=ROB disabled=yes new-routing-mark=ROBMAC passthrough=no src-address=10.215.81.43
add action=mark-routing chain=prerouting comment=WEB dst-address-list="" dst-port=80,5223,3001,3002,3003,443,3389 new-routing-mark=web passthrough=no protocol=tcp src-address=10.215.81.0/24
add action=mark-routing chain=prerouting comment=FTP connection-type=ftp new-routing-mark=FTP passthrough=no protocol=tcp routing-mark=""
add action=mark-routing chain=prerouting connection-mark=ATT-In in-interface=81LAN new-routing-mark=ATT-In passthrough=no
add action=mark-packet chain=prerouting connection-type=!sip new-packet-mark="ALL not VOIP" passthrough=yes
add action=mark-packet chain=prerouting comment=VOIP connection-type=sip new-packet-mark=VOIP passthrough=yes
add action=mark-routing chain=prerouting dst-address=0.0.0.0/0 new-routing-mark=VOIP packet-mark=VOIP passthrough=yes src-address=0.0.0.0/0
add action=accept chain=prerouting disabled=yes protocol=udp src-address=10.215.81.0/24 src-port=5223,3478,3479,3658
add action=mark-packet chain=prerouting in-interface=81LAN new-packet-mark=client_upload passthrough=yes
add action=mark-packet chain=prerouting in-interface=ISP new-packet-mark=client_download passthrough=yes
/ip firewall nat
add action=src-nat chain=srcnat disabled=yes src-address=10.215.81.1 to-addresses=66.215.137.90
add action=netmap chain=dstnat comment="PLEX Remote Access to MarkMac Server\
\n" dst-address=0.0.0.0/0 dst-port=32400 protocol=tcp src-address=0.0.0.0/0 to-addresses=10.215.81.133 to-ports=32400
add action=masquerade chain=srcnat dst-address=0.0.0.0/0 src-address=10.215.81.0/24
add action=dst-nat chain=dstnat disabled=yes dst-port=3074,88 protocol=udp src-address=0.0.0.0/0 to-addresses=10.215.81.0/24
/ip firewall service-port
set ftp ports=20,21,1024,1023
/ip ipsec peer
add address=0.0.0.0/0 dh-group=modp1024 dpd-interval=disable-dpd enc-algorithm=3des generate-policy=port-override my-id=user-fqdn nat-traversal=no
add address=12.68.44.20/32 dh-group=modp1024 dpd-interval=15s dpd-maximum-failures=10 enc-algorithm=3des my-id=user-fqdn nat-traversal=no
/ip ipsec policy
add dst-address=172.22.2.0/24 proposal=default2 sa-dst-address=12.68.44.20 sa-src-address=66.215.137.90 src-address=10.215.81.0/24 tunnel=yes
set 1 disabled=yes
/ip proxy
set cache-path=web-proxy1 max-cache-size=none parent-proxy=0.0.0.0
/ip route rule
add routing-mark=web table=web
/ip service
set telnet address=10.215.81.0/24
set ftp disabled=yes
set ssh address=209.189.247.64/26 disabled=yes
set api disabled=yes
/ip traffic-flow
set active-flow-timeout=2m cache-entries=4k enabled=yes interfaces=81LAN
/ip traffic-flow target
add dst-address=10.215.81.4 port=1235
/ppp secret
add local-address=10.215.81.180 remote-address=10.215.81.181
/routing rip interface
add send=v1-2
/snmp
set contact="Mark" enabled=yes location="Routerboard " trap-target=0.0.0.0
/system clock
set time-zone-autodetect=no time-zone-name=America/Los_Angeles
/system clock manual
set time-zone=-08:00
/system identity
set name=Mark1
/system logging
add action=remote disabled=yes topics=!e-mail
add disabled=yes topics=watchdog
add disabled=yes topics=firewall
add disabled=yes topics=pptp
add disabled=yes topics=ipsec
add action=remote disabled=yes topics=info
add action=disk2 disabled=yes topics=ipsec
add action=remote disabled=yes topics=system
add disabled=yes topics=ppp
add topics=system
add disabled=yes topics=error
add disabled=yes topics=l2tp
add disabled=yes topics=rsvp
add disabled=yes topics=raw
add action=disk2 disabled=yes topics=l2tp
add action=disk disabled=yes topics=ipsec
/system ntp client
set enabled=yes primary-ntp=17.253.34.253 secondary-ntp=17.253.34.253
/system scheduler
add interval=1d name=schedule1 on-event="ip dhcp-server lease remove [find host-name=\"DESKTOP-FNOUQ49\"]" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=may/08/2016 start-time=21:36:00
add interval=1d name=schedule2 on-event="ip dhcp-server lease remove [find host-name=\"DESKTOP-FNOUQ49\"]" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=may/08/2016 start-time=22:30:00
/system upgrade mirror
set enabled=yes primary-server=10.215.81.12
/system watchdog
set automatic-supout=no no-ping-delay=0ms send-email-from=mworsnop@mark-systems.com send-email-to=mworsnop@mark-systems.com send-smtp-server=10.215.81.12 watchdog-timer=no
/tool bandwidth-server
set enabled=no max-sessions=10
/tool e-mail
set address=209.85.225.109 from=""
/tool graphing interface
add
/tool sniffer
set file-limit=10KiB filter-interface=ISP filter-ip-address=45.57.59.188/32 filter-stream=yes only-headers=yes
 
yottabit
Member Candidate
Member Candidate
Posts: 174
Joined: Thu Feb 21, 2013 5:56 am

Re: port speed

Wed May 09, 2018 5:40 am

You have PCQ set to 64/65M.

You have a complex set of QoS rules with passthrough=yes on the rules which means the entire list is being processed for each state.

I don't think fast-path can work with your QoS rules.

You didn't answer to where you tested, using which model of station device, and whether the test was Wi-Fi or Ethernet.

I suggest you backup your config, then reset to default config and test again. You can apply your old configuration in pieces until you narrow down the bottleneck.

You can run Tools -> Profile to see CPU utilization, etc., during your test.

But I suggest you start with your PCQ setting.

Sent from my Pixel XL using Tapatalk

 
mworsnop
newbie
Topic Author
Posts: 28
Joined: Mon Apr 18, 2016 8:34 am

Re: port speed

Wed May 09, 2018 6:09 am

Does this hardware support 1 Gb?

Where is the PCQ? I'm using web config. What should the setting be?
 
yottabit
Member Candidate
Member Candidate
Posts: 174
Joined: Thu Feb 21, 2013 5:56 am

Re: port speed

Wed May 09, 2018 6:47 am

The RB450G has 5xGbE ports and should be able to route with fast-path at over 600 Mbps.

If you don't know what PCQ is, I advise you to ask the person that configured your router. If you bought it used, you need to reset to default and start over.

https://mikrotik.com/product/RB450G#fndtn-testresults

Sent from my Pixel XL using Tapatalk


 
mworsnop
newbie
Topic Author
Posts: 28
Joined: Mon Apr 18, 2016 8:34 am

Re: port speed

Wed May 09, 2018 6:50 am

I configured it years ago and it just works! I dont mess with it hardly ever. I will look up PCQ and try and figure it out.
 
mworsnop
newbie
Topic Author
Posts: 28
Joined: Mon Apr 18, 2016 8:34 am

Re: port speed

Wed May 09, 2018 6:54 am

The queue type PCQ was created so that everyone shares the internet evenly. I will look that up again and try and figure out what I need to change
 
mworsnop
newbie
Topic Author
Posts: 28
Joined: Mon Apr 18, 2016 8:34 am

Re: port speed

Wed May 09, 2018 7:09 am

I still dont see the huge list of QOS? What are you seeing that looks like lots of work?
 
mworsnop
newbie
Topic Author
Posts: 28
Joined: Mon Apr 18, 2016 8:34 am

Re: port speed

Wed May 09, 2018 7:28 am

CPU runs at 98% when running a download test from speedtest.net

Does that mean I need a different box with more of a CPU?
 
yottabit
Member Candidate
Member Candidate
Posts: 174
Joined: Thu Feb 21, 2013 5:56 am

Re: port speed

Wed May 09, 2018 2:46 pm

If you want to keep the config as-is, yes, you'll need a faster router. The hAP ac2 should work nicely for you with its quad-core ARM CPU.

Sent from my Pixel XL using Tapatalk

 
mworsnop
newbie
Topic Author
Posts: 28
Joined: Mon Apr 18, 2016 8:34 am

Re: port speed

Wed May 09, 2018 5:28 pm

I disabled several things and removed most of the obsolete firewall rules and still only get 200 Mbs on the internet. OK thank you for the advice on the new model! Appreciate all the help!!!!
 
mworsnop
newbie
Topic Author
Posts: 28
Joined: Mon Apr 18, 2016 8:34 am

Re: port speed

Thu May 10, 2018 12:45 am

Looks like the model you recommeded has WiFi in there too. I really do not need another WiFi access point. Is there one that doesnt have Wifi?

How about RB3011UiAS-RM
??
 
yottabit
Member Candidate
Member Candidate
Posts: 174
Joined: Thu Feb 21, 2013 5:56 am

Re: port speed

Thu May 10, 2018 3:37 pm

Just don't use the Wi-Fi. I have mine disabled, too, as I use the more powerful hAP ac model for Wi-Fi. The RB3011 is also ARM, but dual-core instead of quad-core, and it costs more.

I think the hAP ac2 is still the best fit. But the RB3011 would be adequate, too.

Sent from my Pixel XL using Tapatalk

 
mworsnop
newbie
Topic Author
Posts: 28
Joined: Mon Apr 18, 2016 8:34 am

Re: port speed

Thu May 10, 2018 4:24 pm

Thank you again.

Who is online

Users browsing this forum: MaRaToN, Zacharias and 242 guests