Community discussions

MUM Europe 2020
 
User avatar
Equis
Forum Veteran
Forum Veteran
Topic Author
Posts: 888
Joined: Mon Jun 06, 2005 6:48 am

Redirct IP to webpage

Sat Jan 27, 2007 6:21 am

Hello

If I had a customer that didn't pay, can I redirect port 80 for him only to a webpage saying pay please?

Thanks
 
pedja
Long time Member
Long time Member
Posts: 684
Joined: Sat Feb 26, 2005 5:37 am

Sat Jan 27, 2007 11:34 am

yes, just set dst-nat for such user to IP where web page is. Pay attention that web server you map to wil receive original http request targeted to site user wanted to use, so you have to set web server to respond to any http request with the same page.
 
User avatar
Equis
Forum Veteran
Forum Veteran
Topic Author
Posts: 888
Joined: Mon Jun 06, 2005 6:48 am

Sat Jan 27, 2007 12:24 pm

Perfect Thanks!
 
User avatar
samsoft08
Long time Member
Long time Member
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Mon Feb 05, 2007 4:46 am

i'm testing Abyss web server on my PC which has a local IP , can I redirect non paid clients to this web server ? i tried but ....failed

to-address = 192.168.1.101... to-port = 8081
my local network is 192.168.1.1/24
 
ferry
Frequent Visitor
Frequent Visitor
Posts: 77
Joined: Mon Jan 15, 2007 11:59 am

Dest NAT

Mon Feb 05, 2007 11:33 am

Maybe u wrong about the port. Check it again...

dest address:your web
dest-port :8081

action: dst-nat , ip:your_ip_local, port :let be default


Thx :lol:
 
User avatar
samsoft08
Long time Member
Long time Member
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Mon Feb 05, 2007 7:00 pm

in the Abyss web server software i put the 8081 port .
when disabled the redirect rule in MT and type http://192.168.1.101:8081 in any browser on the lan its working and it shows the server(192.168.1.101) page ..
but when i tried to make redirection it shows the page cannot displayed .. i dont know why ..
chain=dstnat src-address-list=Non-Paid action=dst-nat 
     to-addresses=192.168.1.101 to-ports=8081
Non-Paid is the address list i want to be redirected ..
 
User avatar
samsoft08
Long time Member
Long time Member
Posts: 617
Joined: Sat Nov 26, 2005 10:52 pm

Mon Feb 05, 2007 9:15 pm

anyone ????????
 
Peace
newbie
Posts: 34
Joined: Wed Dec 15, 2004 11:04 am
Location: Latvia

Tue Mar 13, 2007 10:44 am

I also have this problem
If I make redirect to port :8181 it redirect me only to 80 port
 
User avatar
docto_
newbie
Posts: 28
Joined: Sun Nov 12, 2006 7:48 pm
Location: Latvia

Tue Mar 13, 2007 12:17 pm

You must redirect protocol=tcp port=80
 
savage
Forum Guru
Forum Guru
Posts: 1220
Joined: Mon Oct 18, 2004 12:07 am
Location: Cape Town, South Africa
Contact:

Wed Mar 14, 2007 8:44 am

chain=dstnat action=dst-nat src-address-list=Non-Paid dst-port=80  
     to-addresses=192.168.1.101 to-ports=8081 protocol=tcp
Everyone in Non-Paid will redirect to 192.168.1.101:8081 IF they attempt to make a connection to port 80.
Regards,
Chris
 
maxfava
Member Candidate
Member Candidate
Posts: 221
Joined: Mon Oct 17, 2005 12:30 am

Mon Mar 19, 2007 1:34 am

I have used dst-nat and as action "same"
to address xx.xx.xx.xx port 80.
but it does not work if set src-address for mascherating for the same source address.
For me it works.

Now I wnat limit the bandwith to my non pay customer, but before I want to advice the customer with the first page only.
how to set up this?
 
Ghassan
Member Candidate
Member Candidate
Posts: 213
Joined: Mon May 29, 2006 11:08 pm
Location: Lebanon
Contact:

Thu Mar 22, 2007 1:45 am

Hello all ,

also i have this problem and i can not find its solution ..

notice that i have subnets for exmple :
i have a web server that has ip : 44.83.16.2/30
and i would like to open it from : 44.83.16.6/30

I don't have any rules at MANGLE , disabled firewall to see if it is from my firewall rules but nothing changed .. any idea !

Who is online

Users browsing this forum: MSN [Bot] and 102 guests