Community discussions

 
L1nkCZ
just joined
Topic Author
Posts: 2
Joined: Thu Jun 21, 2018 1:28 pm

Hotspot problem IOS 10.4

Thu Jun 21, 2018 2:56 pm

Hi

have problem to see login page on Apple devices with IOS 10.4 alerdy try change dns name to other one but dosent help any other ideas ?

Export here:

/interface bridge
add name=bridge1
/interface ethernet
set [ find default-name=ether1 ] name=ether1-WAN_24G rx-flow-control=on \
tx-flow-control=on
set [ find default-name=ether2 ] name="ether2-modry_bar v pravo"
set [ find default-name=ether3 ] name=ether3-modry_bar_vlevo
set [ find default-name=ether6 ] disabled=yes name=ether6-eoip_kancl
set [ find default-name=ether10 ] name="ether10-sfp switch"
/interface eoip
add !keepalive mac-address=02:98:4F:34:72:4E name=eoip-tunnel1-hladkov \
remote-address=10.16.0.5 tunnel-id=6
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] hotspot-address=10.143.32.1
add dns-name=hotspot.info hotspot-address=10.143.32.1 login-by=http-chap name=\
hsprof1
/ip pool
add name=dhcp_pool0 ranges=10.143.32.2-10.143.47.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=bridge1 lease-time=1d name=\
dhcp1
/ip hotspot
add address-pool=dhcp_pool0 disabled=no idle-timeout=10m interface=bridge1 \
keepalive-timeout=5m name=hotspot1 profile=hsprof1
/ip hotspot user profile
set [ find default=yes ] add-mac-cookie=no address-pool=dhcp_pool0 \
idle-timeout=2m5s shared-users=8000
/snmp community
set [ find default=yes ] addresses=0.0.0.0/0
add addresses=0.0.0.0/0 name=awn
/interface bridge port
add bridge=bridge1 hw=no interface=sfp1
add bridge=bridge1 hw=no interface="ether2-modry_bar v pravo"
add bridge=bridge1 hw=no interface=ether3-modry_bar_vlevo
add bridge=bridge1 hw=no interface="ether10-sfp switch"
add bridge=bridge1 interface=eoip-tunnel1-hladkov
add bridge=bridge1 hw=no interface=ether6-eoip_kancl
/ip address
add address=10.143.0.7/26 interface=ether1-WAN_24G network=10.143.0.0
add address=10.143.32.1/20 interface=bridge1 network=10.143.32.0
add address=10.143.0.10/26 disabled=yes network=10.143.0.0
/ip dhcp-server config
set store-leases-disk=never
/ip dhcp-server lease
add address=10.143.44.16 client-id=1:0:19:3b:c:ce:75 mac-address=\
00:19:3B:0C:CE:75 server=dhcp1
add address=10.143.47.254 client-id=1:0:19:3b:c:cd:4f mac-address=\
00:19:3B:0C:CD:4F server=dhcp1
add address=10.143.44.80 client-id=1:0:19:3b:13:96:ef mac-address=\
00:19:3B:13:96:EF server=dhcp1
add address=10.143.44.81 client-id=1:0:19:3b:13:96:26 mac-address=\
00:19:3B:13:96:26 server=dhcp1
add address=10.143.44.152 client-id=1:0:19:3b:13:95:6f mac-address=\
00:19:3B:13:95:6F server=dhcp1
add address=10.143.47.253 client-id=1:0:19:3b:13:a9:b3 mac-address=\
00:19:3B:13:A9:B3 server=dhcp1
add address=10.143.47.248 client-id=1:0:19:3b:13:a1:d0 mac-address=\
00:19:3B:13:A1:D0 server=dhcp1
add address=10.143.47.251 client-id=1:0:19:3b:13:a9:bf mac-address=\
00:19:3B:13:A9:BF server=dhcp1
add address=10.143.44.166 client-id=1:0:19:3b:13:96:ec mac-address=\
00:19:3B:13:96:EC server=dhcp1
add address=10.143.47.247 client-id=1:0:19:3b:13:9f:8a mac-address=\
00:19:3B:13:9F:8A server=dhcp1
add address=10.143.32.9 client-id=1:0:19:3b:13:95:b1 mac-address=\
00:19:3B:13:95:B1 server=dhcp1
add address=10.143.40.156 client-id=1:0:19:3b:13:96:d4 mac-address=\
00:19:3B:13:96:D4 server=dhcp1
add address=10.143.41.164 client-id=1:0:19:3b:11:6:2 mac-address=\
00:19:3B:11:06:02 server=dhcp1
add address=10.143.44.43 comment="meteorologicka stanice" mac-address=\
00:1D:8C:0D:EB:B1 server=dhcp1
add address=10.143.44.19 client-id=1:0:19:3b:13:96:bf mac-address=\
00:19:3B:13:96:BF server=dhcp1
add address=10.143.44.22 client-id=1:0:19:3b:13:ad:d mac-address=\
00:19:3B:13:AD:0D server=dhcp1
add address=10.143.32.5 client-id=1:0:19:3b:c:cf:e mac-address=\
00:19:3B:0C:CF:0E server=dhcp1
/ip dhcp-server network
add address=10.143.32.0/20 dns-server=1.1.1.1,8.8.8.8 gateway=10.143.32.1
/ip dns
set servers=1.1.1.1,10.143.32.1
/ip firewall address-list
add address=10.143.32.0/20 comment=ispadmin_DROP_NETWORKS list=\
ispadmin_DROP_NETWORKS
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" \
disabled=yes
add action=accept chain=hs-unauth-to comment="TEST API" disabled=yes \
dst-address=94.230.144.246 out-interface=bridge1
add action=accept chain=ispadmin_first_forward comment=ispadmin_first_1_ \
dst-port=123 protocol=udp
add action=accept chain=ispadmin_first_forward comment=ispadmin_first_2_ \
protocol=udp src-port=123
add action=accept chain=ispadmin_first_forward comment=ispadmin_first_3_ \
dst-port=8291 protocol=tcp
add action=accept chain=ispadmin_first_forward comment=ispadmin_first_4_ \
protocol=tcp src-port=8291
add action=accept chain=ispadmin_first_forward comment=ispadmin_first_5_ \
dst-port=9999 protocol=tcp
add action=accept chain=ispadmin_first_forward comment=ispadmin_first_6_ \
protocol=tcp src-port=9999
add action=accept chain=ispadmin_first_forward comment=ispadmin_first_7_ \
dst-address=94.230.144.0/28
add action=accept chain=ispadmin_first_forward comment=ispadmin_first_8_ \
src-address=94.230.144.0/28
add action=accept chain=ispadmin_first_forward comment=ispadmin_first_9_ \
dst-address=94.230.145.0/29
add action=accept chain=ispadmin_first_forward comment=ispadmin_first_10_ \
src-address=94.230.145.0/29
add action=accept chain=ispadmin_first_forward comment=ispadmin_first_11_ \
dst-address=10.0.98.175
add action=accept chain=ispadmin_first_forward comment=ispadmin_first_12_ \
src-address=10.0.98.175
add action=jump chain=forward comment=ispadmin_first_forward jump-target=\
ispadmin_first_forward
add action=jump chain=forward comment=ispadmin_service_forward jump-target=\
ispadmin_service_forward
add action=jump chain=forward comment=ispadmin_basic_forward jump-target=\
ispadmin_basic_forward
add action=drop chain=ispadmin_drop_forward comment=ispadmin_drop_forward
add action=jump chain=forward comment=ispadmin_drop_NETWORK_SRC jump-target=\
ispadmin_drop_forward src-address-list=ispadmin_DROP_NETWORKS
add action=accept chain=ispadmin_service_forward comment=\
rtr_Zlutelazne_G_RB3011_7519_ispadmin_up src-address=10.143.32.1
add action=jump chain=ispadmin_basic_forward comment=\
ispadmin_group_src_10.143.32.0/26 jump-target=\
ispadmin_group_src_10.143.32.0/26 src-address=10.143.32.0/26
add action=accept chain=ispadmin_group_src_10.143.32.0/26 comment=\
Taiko_a_s____ispadmin_52846_up src-address=10.143.32.2
add action=jump chain=ispadmin_basic_forward comment=\
ispadmin_group_net_src_10.143.32.0/20 jump-target=\
ispadmin_group_src_10.143.32.0/20 src-address=10.143.32.0/20
add action=accept chain=ispadmin_group_src_10.143.32.0/20 comment=\
Taiko_a_s____ispadmin_52846_net_1_up src-address=10.143.32.0/20
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" \
disabled=yes
add action=jump chain=dstnat comment=ispadmin_first_dstnat jump-target=\
ispadmin_first_dstnat
add action=jump chain=dstnat comment=ispadmin_service_dstnat jump-target=\
ispadmin_service_dstnat
add action=jump chain=dstnat comment=ispadmin_basic_dstnat jump-target=\
ispadmin_basic_dstnat
/ip hotspot ip-binding
add comment="odtud zacinaji NFTcka" mac-address=00:19:3B:0C:CD:4F type=bypassed
add mac-address=00:19:3B:13:A9:B3 type=bypassed
add mac-address=00:19:3B:13:95:B3 type=bypassed
add mac-address=00:19:3B:13:95:B1 type=bypassed
add mac-address=00:19:3B:13:A9:BF type=bypassed
add mac-address=00:19:3B:13:9F:8A type=bypassed
add mac-address=00:19:3B:13:A1:D0 type=bypassed
add mac-address=00:19:3B:13:96:EC type=bypassed
add mac-address=00:19:3B:13:95:6F type=bypassed
add mac-address=00:19:3B:0C:CF:0E type=bypassed
add mac-address=00:19:3B:0C:CE:75 type=bypassed
add mac-address=00:19:3B:13:96:D4 type=bypassed
add mac-address=00:19:3B:13:96:26 type=bypassed
add mac-address=00:19:3B:13:96:BF type=bypassed
add mac-address=00:19:3B:13:96:EF type=bypassed
add mac-address=00:19:3B:13:AD:0D type=bypassed
add comment="meteorologicka stanice" mac-address=00:1D:8C:0D:EB:B1 type=\
bypassed
add comment="pizza giallo nejaky pc co je tam furt" mac-address=\
00:25:56:26:EA:37 type=bypassed
add comment="odtud zacinaji CSSka" mac-address=CC:2D:E0:16:2C:E8 type=bypassed
add mac-address=CC:2D:E0:16:35:5E type=bypassed
add mac-address=CC:2D:E0:16:35:58 type=bypassed
add mac-address=CC:2D:E0:16:2C:64 type=bypassed
add mac-address=CC:2D:E0:16:2C:E2 type=bypassed
add comment=60GHz mac-address=64:D1:54:EE:11:AB type=bypassed
add comment=CRS mac-address=64:D1:54:4A:76:DD type=bypassed
add mac-address=00:19:3B:11:06:02 type=bypassed
/ip hotspot user
add address=10.143.32.1 name=admin password=vltava456
/ip hotspot walled-garden
add comment="place hotspot rules here" disabled=yes
add dst-host=www.airwaynet.cz server=hotspot1
add dst-host=captive.apple.com/hotspot-detect.html server=hotspot1
add dst-host=ajax.googleapis.com server=hotspot1
add dst-host=captive.apple.com server=hotspot1
add dst-host=clients3.google.com/generate_204 server=hotspot1
add dst-host=www.airport.us server=hotspot1
add dst-host=www.appleiphonecell.com server=hotspot1
add dst-host=www.ibook.info server=hotspot1
add dst-host=www.itools.info server=hotspot1
add dst-host=www.thinkdifferent.us server=hotspot1
/ip hotspot walled-garden ip
add action=accept disabled=no dst-address=31.31.75.249 !dst-port !protocol \
server=hotspot1 !src-address
add action=accept disabled=no dst-address=66.102.1.95 !dst-port !protocol \
server=hotspot1 !src-address
add action=accept disabled=no dst-address=94.230.148.213 dst-port=7443 \
!protocol server=hotspot1 src-address=10.143.47.254
add action=accept disabled=no dst-address=17.253.55.204 !dst-address-list \
!dst-port protocol=tcp server=hotspot1 !src-address !src-address-list
/ip route
add distance=1 gateway=10.143.0.1
/ip service
set telnet disabled=yes
set www port=9999
set api-ssl disabled=yes
/snmp
set contact=in@ai.cz enabled=yes location=Pr
/system clock
set time-zone-name=Europe/Prague
/system identity
set name=zlute_lazne_router_sarel
/system routerboard settings
set silent-boot=no
/system script
add name=ispadmin_info_pages owner=hermes policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive source=":local sr\
caddr\r\
\n:local srcport\r\
\n:local srcaddrs\r\
\n:global listinfo\r\
\n:global server\r\
\n:set server 94.230.144.243\r\
\n:foreach j in=[/ip firewall address-list find list=\"ispadmin_info_pages_r\
un\"] do={\r\
\n /ip firewall address-list\r\
\n :set listinfo [get \$j address]\r\
\n :local infook [/ip firewall address-list find (list=\"ispadmin_inf\
o_pages_ok\" && address=\"\$listinfo\")]\r\
\n :if (\$infook = \"\") do={\r\
\n /ip firewall connection\r\
\n :foreach i in=[/ip firewall connection find (src-address~\
\"\$listinfo:\" && connection-mark=\"info_pages\" && tcp-state=\"est
d\")] do={\r\
\n :set srcaddr [get \$i src-address]\r\
\n :set srcaddrs [:find \$srcaddr \":\"]\r\
\n :if ( \$srcaddrs != \"\" ) do= {\r\
\n :set srcport [:pick \$srcaddr ([:fi
caddr \":\"]+1) [:len \$srcaddr]]\r\
\n /tool fetch keep-result=no mode=htt
\"http://\$server:11500/information_messages.php\\\?userip=\$listinfo
rt=\$srcport\"\r\
\n\t\t\t\t:delay 3\r\
\n\t\t\t\t/ip firewall connection remove number=\$i\r\
\n }\r\
\n }\r\
\n }\r\
\n /ip firewall address-list remove numbers=\$j\r\
\n}"
 
2frogs
Long time Member
Long time Member
Posts: 540
Joined: Fri Dec 03, 2010 1:38 am

Re: Hotspot problem IOS 10.4

Sat Jun 23, 2018 6:12 am

Why do you have captive.apple.com in your walled-garden? iOS uses this url to see if the device is behind a captive portal. If it can access it, it will not pop up the login page.
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1740
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Hotspot problem IOS 10.4

Sat Jun 23, 2018 7:01 am

Why do you have captive.apple.com in your walled-garden? iOS uses this url to see if the device is behind a captive portal. If it can access it, it will not pop up the login page.

useful tip, thank you for the info 8)
 
L1nkCZ
just joined
Topic Author
Posts: 2
Joined: Thu Jun 21, 2018 1:28 pm

Re: Hotspot problem IOS 10.4

Tue Jun 26, 2018 4:17 pm

Problem solved thanks

Who is online

Users browsing this forum: Google [Bot] and 80 guests