Community discussions

 
Jukilo
just joined
Topic Author
Posts: 10
Joined: Thu Jun 07, 2018 4:15 pm

Mikrotik "Internet detect" problem

Mon Jun 25, 2018 5:01 pm

Try to test new future: /internet detect. I have enabled it on wan interfaces, but mkt do not change status to "internet". and i do not see connections to cloud.mikrotik.com:30000, as written on wiki. It's a bug?

All information on screenshot:
2018-06-25_165941.png
You do not have the required permissions to view the files attached to this post.
 
davidw
Frequent Visitor
Frequent Visitor
Posts: 90
Joined: Fri Apr 27, 2007 11:11 pm

Re: Mikrotik "Internet detect" problem

Thu Sep 20, 2018 2:27 pm

+1 !

It never changes to internet state
 
WarMaster
just joined
Posts: 6
Joined: Wed Oct 25, 2017 10:36 am
Location: The Netherlands

Re: Mikrotik "Internet detect" problem

Fri Nov 02, 2018 9:54 am

Yup, same here. +1

I even have a specific output rule for udp/30000 on the IPv4 & IPv6 firewall which never gets triggered.

P.S. The new Mikrotik Android app has a 'detect internet' option which it does. What it actually changes in the config is as of yet unknown to me.
I suspect only the 8.8.8.8 dns query is being used to determine the internet access at the moment, but only for the mikrotik app, not the interface lists.
 
Matthew1471
just joined
Posts: 8
Joined: Wed Feb 20, 2019 1:10 pm

Re: Mikrotik "Internet detect" problem

Thu Feb 21, 2019 11:25 am

More details seem to be listed here :)? https://wiki.mikrotik.com/wiki/Manual:Detect_internet

Reads like you need to pass WAN criteria to then ALSO evaluate for Internet criteria.
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1790
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: Mikrotik "Internet detect" problem

Thu Feb 21, 2019 12:56 pm

But what is the goal of this function and how it is used / impacts others is not clarified.

Hence, in effect for me right now: disable.
 
nixpod
just joined
Posts: 1
Joined: Sun Feb 24, 2019 3:21 pm

Re: Mikrotik "Internet detect" problem

Sun Feb 24, 2019 3:41 pm

Same issue here on a hap ac. The interface remains in wan state.
I can see udp packets going to cloud.mikrotik.com on port 30000, but never see any response coming back in.
I verified udp/30000 was not blocked by the ISP by setting up netcat on a linux box on internet and can see traffic flowing through.
Also tried sending manually sending some udp/30000 packets to cloud.mikrotik.com using netcat, but never see any response returning (probably normal).
 
Sieru
just joined
Posts: 1
Joined: Tue Mar 19, 2019 2:47 pm

Re: Mikrotik "Internet detect" problem

Tue Mar 19, 2019 2:53 pm

Same problem on 1100ahx4. Do you have any solution?
Also, in mobile app I can see "Available on ether1 (Limited access)".
 
gutekpl
newbie
Posts: 46
Joined: Wed Feb 20, 2019 6:31 pm

Re: Mikrotik "Internet detect" problem

Wed Mar 20, 2019 4:35 pm

Enabling it turned on my internet speed graph in mobile app. However thing I cannot understand is difference in speeds between pppoe-out1 and ether1 - for my understanding that should be exactly the same, as my ISP cable is plugged into eth1.
You do not have the required permissions to view the files attached to this post.
 
User avatar
kmansoft
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Tue Jan 22, 2019 5:00 pm

Re: Mikrotik "Internet detect" problem

Tue Mar 26, 2019 8:08 pm

Same thing here with ac2 6.45beta20.

Limited access in android app and WAN in web ui.

Mikrotik support, any comments?

Google's DNS servers are definitely reachable (I have them as the router's DNS servers) but I have not checked UDP traffic.

It's a nice feature and I'd love to enjoy those charts and stats n the android app.

Oh the interfaces are of pptp and gre type if it matters.
 
anav
Forum Guru
Forum Guru
Posts: 3106
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: Mikrotik "Internet detect" problem

Tue Mar 26, 2019 8:51 pm

But what is the goal of this function and how it is used / impacts others is not clarified.
I sprayed coffee on my desk reading this kernel of truth Sebastia !!!

You have just described all the functionality of MT devices, so equally poorly documented LOL.
Its the outcome of the Lowest Cost Compliant Solution approach to engineering documentation - cheap and leaves a bitter taste in one's mouth!
Am I complaining, since I have my awesome low cost MT devices? - well obviously not since I am still here and still buying components. :-)
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
User avatar
kmansoft
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Tue Jan 22, 2019 5:00 pm

Re: Mikrotik "Internet detect" problem

Tue Mar 26, 2019 8:52 pm

Oh and speaking of UDP traffic - my internet connection is pptp but has a "real" (not NAT-ed) IPv4 address.

But what about those whose Internet connection is behind a NAT? Pretty common here in Russia and not only here I would think. Those should still detect as Internet isn't that right? But expecting a UDP reply would not work in this case I believe.
 
dricks
just joined
Posts: 13
Joined: Fri Jan 08, 2010 7:31 pm
Location: Embarcacion

Re: Mikrotik "Internet detect" problem

Thu Apr 04, 2019 3:58 am

solution for this:
interface detect-internet edit detect-interface-list
change to none
"crtl o" to save
and done !
 
User avatar
kmansoft
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Tue Jan 22, 2019 5:00 pm

Re: Mikrotik "Internet detect" problem

Thu Apr 04, 2019 8:22 am

solution for this:
interface detect-internet edit detect-interface-list
change to none
"crtl o" to save
and done !
No that will turn the whole feature off. Whereas what I wanted was for it to work.

At this time it's working for me - my understanding is Mikrotik fixed something server side (since it started to work without RouterOS updates).
 
gutekpl
newbie
Posts: 46
Joined: Wed Feb 20, 2019 6:31 pm

Re: Mikrotik "Internet detect" problem

Thu Apr 04, 2019 11:37 am

I think new mobile app solved that issues.
 
User avatar
kmansoft
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Tue Jan 22, 2019 5:00 pm

Re: Mikrotik "Internet detect" problem

Thu Apr 04, 2019 12:32 pm

I think new mobile app solved that issues.
Yes works in mobile app too without any updates (to the app). Works in WebFig with 6.44 as well.

It must have been the server.
Last edited by kmansoft on Fri Apr 05, 2019 1:37 pm, edited 1 time in total.
 
Reinis
MikroTik Support
MikroTik Support
Posts: 67
Joined: Wed Jan 02, 2019 12:14 pm
Location: Latvia
Contact:

Re: Mikrotik "Internet detect" problem

Thu Apr 04, 2019 12:57 pm

I think new mobile app solved that issues.
Yes works in mobile app too without any updates (to the app). Works in WebFig as well.

It must have been the server.
Correct, the issue was on our side and is now fixed. No updates on the client side are required.
 
User avatar
Joni
Frequent Visitor
Frequent Visitor
Posts: 77
Joined: Fri Mar 20, 2015 2:46 pm
Contact:

Re: Mikrotik "Internet detect" problem

Wed Apr 10, 2019 1:00 pm

Still not working on v6.43.13, WAN is never upgraded to Internet.
[admin@GW]> /interface detect-internet state print terse 
 0 name=ether1-gateway state=no-link state-change-time=apr/10/2019 12:12:22 
 1 name=ether2-master-local state=lan state-change-time=apr/10/2019 12:12:22 
 2 name=ether3-slave-local state=no-link state-change-time=apr/10/2019 12:12:22 
 3 name=ether4-slave-local state=no-link state-change-time=apr/10/2019 12:12:22 
 4 name=ether5-slave-local state=no-link state-change-time=apr/10/2019 12:12:22 
 5 name=WLAN state=no-link state-change-time=apr/10/2019 12:57:13 
 6 name=bridge-local state=lan state-change-time=apr/10/2019 12:12:22 
 7 name=4G-LTE-USB state=wan state-change-time=apr/10/2019 12:12:28 
 8 name=l2tp-out1 state=wan state-change-time=apr/10/2019 12:12:28 
 9 name=loopback state=lan state-change-time=apr/10/2019 12:12:22 
(4G-LTE-USB does NAT, ie double nat)

I wonder what is the logging topic name for Internet Detect, one of many missing wiki details https://wiki.mikrotik.com/wiki/Manual:System/Log
 
HughBurns
just joined
Posts: 1
Joined: Thu Apr 11, 2019 7:15 am

Re: Mikrotik "Internet detect" problem

Thu Apr 11, 2019 7:29 am

Just tried on two different routers, one a wAP R with a 4G LTE interface, and one a CCR1009-8G-1S-1S+ with a PPPoE interface, both running 6.44.2.

Detect internet is not working on either of them. Both interfaces stay on WAN and never transition to INTERNET. If I run a packet sniffer looking for traffic to cloud.mikrotik.com, I can see outbound requests to port 30000, but no packets coming back. On the CCR, the router is pinging 8.8.8.8 everyone second, but nothing on the 4G router.

Is this service even working currently?
 
Normie
just joined
Posts: 4
Joined: Fri Sep 27, 2019 1:47 pm

Re: Mikrotik "Internet detect" problem

Sun Oct 13, 2019 4:48 am

Hello all.

Still not work, ROS 6.45.6, RB4011, 1 WAN interface with DHCP-client ensbled, uplink to radio-bridge to ISP router, 2 LANs.

Who is online

Users browsing this forum: No registered users and 142 guests