Community discussions

 
mwittchen
just joined
Topic Author
Posts: 4
Joined: Tue Jul 10, 2018 5:47 pm

CRS3XX and 802.1ad

Tue Jul 10, 2018 6:18 pm

Hi everybody,

I'm currently a little bit in trouble to set up the VLAN configuration on the new CRS3XX switches. Usually (e.g. on a CRS212) we defined the necessary 802.1ad tags (820 as vlan-id, 80 as service-id) on an access port via
/interface ethernet switch ingress-vlan-translation
add customer-vid=0 new-customer-vid=820 new-service-vid=80 ports=ether2
/interface ethernet switch egress-vlan-translation
add customer-vid=820 new-customer-vid=0 new-service-vid=0 ports=ether2
Any untagged traffic on ether2 is tagged with the right Q-in-Q tag combination.

Now I'm wondering how to configure this tagging with the new CRS3XX devices? :( Does anyone know how to solve this problem?

Best regards,

Maik
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1736
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: CRS3XX and 802.1ad

Wed Jul 11, 2018 1:35 am

https://wiki.mikrotik.com/wiki/Manual:C ... 8Q-in-Q.29


test carefully RC versions are for testing
 
mwittchen
just joined
Topic Author
Posts: 4
Joined: Tue Jul 10, 2018 5:47 pm

Re: CRS3XX and 802.1ad

Wed Jul 11, 2018 10:52 am

Hello chechito,

thank you for your reply.

test carefully RC versions are for testing

Sure, currently I'm running 6.43rc42 and configured the device as described in your link. I've tried to use a switch rule like

/interface ethernet switch rule
add new-vlan-id=820 ports=ether1 switch=switch1 

which works, but unfortunately there is no option to set a new service-vlan-id. What I'm missing is a command line like

/interface ethernet switch rule
add new-vlan-id=820 new-service-id=80 ports=ether1 switch=switch1 

To explain my use case a bit more: We are using a lot of CRS (e.g. CRS212-1G-10S-1S+) and mark the incoming traffic with a defined vlan-id for the customer and a defined service-id for the carrier. This works like a charm. Any other things I tried (e.g. creating a vlan-interface with use-service-tag and a bridge) were working more or less, but always results in software bridging which isn't an option.
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1736
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: CRS3XX and 802.1ad

Wed Jul 11, 2018 7:12 pm

CRS 2xx and 1xx are different switches because use different chipsets

in CRS 3xx vlan dont configure by switch menu they configure by bridge menu, maybe QinQ in new CRS 3xx switches does not work yet
 
User avatar
artz
MikroTik Support
MikroTik Support
Posts: 88
Joined: Tue Oct 17, 2017 5:51 pm
Location: Riga
Contact:

Re: CRS3XX and 802.1ad

Thu Jul 12, 2018 10:20 am

As soon as you set vlan-protocol=802.1ad, then all VLAN tagging, untagging and filtering is done by checking VLAN tag with Ethertype=0x88A8 (SVID), all CVID tags are ignored and considered as untagged traffic. Selective QinQ currently is not supported on CRS3xx.

Also note that by setting vlan-protocol=802.1ad, you are enabling all VLAN related functions (including options in /interface ethernet switch) to use SVID tags globally. This means that ACL rules will only add a SVID tag or match a SVID tag.
 
mwittchen
just joined
Topic Author
Posts: 4
Joined: Tue Jul 10, 2018 5:47 pm

Re: CRS3XX and 802.1ad

Wed Jul 18, 2018 10:35 am

Hello artz

Thank you for clarifying the current q-in-q (or better q-or-q :wink:) implementation in the CRS3XX switches. I thought I misunderstood the documentation. It's a bit disappointing because the new CRS are great devices.
 
MWComms
just joined
Posts: 7
Joined: Thu Nov 30, 2017 1:35 am

Re: CRS3XX and 802.1ad

Wed Sep 12, 2018 3:35 pm

Selective QinQ currently is not supported on CRS3xx.
Can we interpret your statement as Selective QinQ will be supported in the future?

Rewriting Ingress/Egress S-VLAN and C-VLAN is absolutely essential for my use. I had planned to use the 3XX series switches in my datacentres. This may be a dealbreaker.

Are the 'new' switch rules also handled by the switch chip or offloaded to the CPU?

Who is online

Users browsing this forum: Google [Bot] and 96 guests