Community discussions

MUM Europe 2020
 
joshwebs
just joined
Topic Author
Posts: 1
Joined: Thu Jul 05, 2018 9:25 am

Hotspot Redirection - Multiple Subnets Issue

Wed Jul 11, 2018 10:32 am

Hi All,

I currently have an issue with hotspot redirect on MikroTik RB951G-2HnD, if my hotspot / IP-pool is configured as a /24 network.
i.e 192.168.15.0/24 with my hotspot address being the MikroTik's IP address for the hotspot network (192.168.15.1), when I increase the IP-Pool to include an additional subnet (192.168.16.0/24) and devices obtain an IP address on 192.168.16.0/24 range, the hotspot redirection does not occur.

Please could you advise/provide guidance on this.
 
dcwifi
just joined
Posts: 23
Joined: Thu Jan 21, 2010 7:35 am

Re: Hotspot Redirection - Multiple Subnets Issue

Wed Jul 11, 2018 12:06 pm

Simply include an additional subnet from the pool is not enough because 192.168.16.0/24 is a different network.

Add these:
/ip address add address=192.168.16.1/24 interface=(same interface as 192.168.15.0/24)
/ip dhcp-server network add address=192.168.16.0/24 gateway=192.168.16.1
/ip firewall nat add src-address=192.168.16.0/24 action=masquerade

Otherwise you can change to a bigger subnet like /23.

Who is online

Users browsing this forum: Egert143, pe1chl and 161 guests