Page 1 of 1

How LACP affects ARP?

Posted: Sun Jul 29, 2018 6:10 pm
by lapsio
Recently I created multiple threads spinning around topic of ARP and LACP issues. I thought they're independent but after lots of testing I think I finally came to following conclusion:

LACP affects ARP in some way in my setup. Every time I create LACP link there are some issues with propagating ARP responses/requests. It results in lots of "weird" issues like problems with DHCP offer propagation or ARP-ping malfunction etc.

So my question is - how to properly configure LACP on mikrotik switch that will be terminated on MikroTik router and put into bridge (on router). Lets say I want to push VLAN 1001 and 1002 through LACP and then VLAN 1001 and 1002 are bridged on router with VLAN 1000 that comes to different port. My current configuration would look like this:

/interface bridge add name=br-test
/interface bond add mode=802.3ad slaves=ether2,ether3
/interface vlan add name vlan1000 vlan-id=1000 interface=ether1
/interface vlan add name vlan1001 vlan-id=1001 interface=bond1
/interface vlan add name vlan1002 vlan-id=1002 interface=bond2

/interface bridge port add bridge=br-test interface=vlan1000
/interface bridge port add bridge=br-test interface=vlan1001
/interface bridge port add bridge=br-test interface=vlan1002

On switch device I would do:

/interface bridge add name=br-hardware vlan-filtering=yes
/interface bond add mode=802.3ad slaves=ether2,ether3 name=bond1
/interface bridge port add bridge=br-hardware interface=ether10 frame-type=admit-only-vlan-tagged ingress-filtering=yes pvid=1001
/interface bridge port add bridge=br-hardware interface=ether11 frame-type=admit-only-vlan-tagged ingress-filtering=yes pvid=1001
/interface bridge port add bridge=br-hardware interface=ether12 frame-type=admit-only-vlan-tagged ingress-filtering=yes pvid=1002
/interface bridge port add bridge=br-hardware interface=ether13 frame-type=admit-only-vlan-tagged ingress-filtering=yes pvid=1002
/interface bridge port add bridge=br-hardware interface=ether14 frame-type=admit-only-vlan-tagged ingress-filtering=yes pvid=1002
/interface bridge port add bridge=br-hardware interface=bond1 frame-type=admit-only-vlan-tagged ingress-filtering=yes pvid=2

/interface bridge vlan add vlan-ids=1001 bridge=br-hardware untagged=ether10,ether11 tagged=bond1
/interface bridge vlan add vlan-ids=1002 bridge=br-hardware untagged=ether11,ether12,ether13 tagged=bond1

However for some reason it results in ARP issues. Am I missing something?