Community discussions

 
flynno
Member Candidate
Member Candidate
Topic Author
Posts: 241
Joined: Wed Aug 27, 2014 8:11 pm

L2TP VPN

Mon Aug 06, 2018 3:39 pm

Hey guys,

I'm having difficulty setting up a VPN between two mikrotik routers.

/ip firewall address-list
add address=192.168.88.10 list=OutVpn

/ip firewall mangle
add chain=prerouting action=mark-routing new-routing-mark=VpnRoute passthrough=yes src-address-list=OutVpn log=no log-prefix="" dst-address=0.0.0.0/0

/ip firewall filter print
;;; allow L2TP VPN (500,4500,1701,47/udp)
chain=input action=accept protocol=udp dst-port=500,1701,4500 log=no log-prefix=""
chain=input action=accept protocol=ipsec-ah log=no log-prefix=""
chain=input action=accept protocol=ipsec-esp log=no log-prefix=""
chain=input action=accept protocol=gre log=no log-prefix=""

/ip firewall nat print
chain=srcnat action=masquerade out-interface=WAN log=no log-prefix=""
chain=srcnat action=masquerade out-interface=all-ppp log=no log-prefix=""


/ip dns print
servers:
dynamic-servers: 8.8.8.8.,8.8.4.4
allow-remote-requests: yes
max-udp-packet-size: 4096
query-server-timeout: 2s
query-total-timeout: 10s
max-concurrent-queries: 100
max-concurrent-tcp-sessions: 20
cache-size: 2048KiB
cache-max-ttl: 1w
cache-used: 24KiB

/ip route print

# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
A S 0.0.0.0/0 l2tp-out1 1
ADS 0.0.0.0/0 192.168.0.1 1
ADC 172.168.5.1/32 172.168.5.252 l2tp-out1 0
ADC 192.168.88.0/24 192.168.88.1 ether3 0

L2TP will establish and I can ping remote router and ping my pc from the remote router but cannot send internet traffic from PC out behind the remote mikrotik router

Who is online

Users browsing this forum: No registered users and 121 guests