Community discussions

MikroTik App
 
TheLordOfTheShells
newbie
Topic Author
Posts: 29
Joined: Tue Oct 03, 2017 2:48 am

Hostpot not working after PCC Load balancing.

Sun Aug 26, 2018 7:08 am

Hi guys.
I'm running a hostpot in my network with 2 WANs, but after PCC load balancing my client can not access to the portal, If i turn off the PCC load balancing script everthing work well but the connection just through wan 1. I have some google searches they told me that add hotspot=auth but It seems did not work with me.
Here is my LB configuration, hope you guys will help me with this matter!
/ip firewall mangle
add action=mark-connection chain=input in-interface=pppoe-out1 new-connection-mark=WAN1_conn passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out2 new-connection-mark=WAN2_conn passthrough=yes

add action=mark-routing chain=output connection-mark=WAN1_conn new-routing-mark=to_WAN1 passthrough=yes
add action=mark-routing chain=output connection-mark=WAN2_conn new-routing-mark=to_WAN2 passthrough=yes

add action=mark-connection chain=prerouting dst-address-list=!connected-subnets dst-address-type=!local [b]hotspot=auth[/b] in-interface-list=all-lans \
    new-connection-mark=WAN1_conn passthrough=yes per-connection-classifier=both-addresses:2/0
add action=mark-connection chain=prerouting dst-address-list=!connected-subnets dst-address-type=!local [b]hotspot=auth[/b] in-interface-list=all-lans new-connection-mark=\
    WAN2_conn passthrough=yes per-connection-classifier=both-addresses:2/2

add action=mark-routing chain=prerouting connection-mark=WAN1_conn in-interface-list=all-lans new-routing-mark=to_WAN1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=WAN2_conn in-interface-list=all-lans new-routing-mark=to_WAN2 passthrough=yes

/ip route
add check-gateway=ping distance=1 gateway=pppoe-out1 routing-mark=to_WAN1
add check-gateway=ping distance=1 gateway=pppoe-out2 routing-mark=to_WAN2
add distance=1 gateway=pppoe-out1
add distance=2 gateway=pppoe-out2
 
TheLordOfTheShells
newbie
Topic Author
Posts: 29
Joined: Tue Oct 03, 2017 2:48 am

Re: Hostpot not working after PCC Load balancing.

Mon Aug 27, 2018 5:50 am

Is there anyone who have solved that issue ?
Looking forward to hear your opinion.
 
ronal01
just joined
Posts: 4
Joined: Thu Jan 31, 2019 10:40 pm

Re: Hostpot not working after PCC Load balancing.

Thu Jan 31, 2019 10:46 pm

/ip firewall nat add action=accept chain=pre-hptspot disable=no dst-address-type=!local hotspot=auth

Who is online

Users browsing this forum: korniza, MSN [Bot] and 142 guests