Community discussions

 
User avatar
Joni
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 77
Joined: Fri Mar 20, 2015 2:46 pm
Contact:

Bare metal CHR on Hetzner Dedicated

Fri Aug 31, 2018 8:20 pm

cd /root && curl -O https://download2.mikrotik.com/routeros/6.42.3/chr-6.42.3.img.zip && gunzip -S .zip chr-6.42.3.img.zip
dd if=/root/chr-6.42.3.img of=/dev/sda
Tried this on Hetzner dedicated (bare metal, EX series, I know bm isn't officially supported but I don't want the virtualization maintenance overhead) however everything except routing (public ip subnets, ie forwarding) works, at least I can't get it working with any config. Sort of sad. (neither 6.40.9 (Bugfix only) or 6.42.7 (Current) or 6.43rc66 (Release candidate))
Please open a new topic and describe what exactly does not work. It's either working completely or not. It cannot 'disable routing for some unknown reason'. Where do you get your "public subnets"? Can't Hetzner block unknown IPs by default (it should, I hope)?
Either working completely or not was my impression too, until I tried this.

The intention is to provide public IP addresses to another mikrotik router behind NAT over L2TP VPN, via EoIP (nevermind overhead). L2TP works (if assigned to can internally ping each other with the public subnet IPs), EoIP (if assigned to can internally ping each other with the public subnet IPs) works but traffic from internet to the public subnet doesn't even enter Ether1-WAN (or anywhere else for that matter, torch).

Hetzner provides public IPs / subnet upon order https://wiki.hetzner.de/index.php/Zusae ... en#Subnets and trying any combination of "every" mikrotik forum suggested way of getting them forwarded, as in routing, doesn't work. "Obviously" the server doesn't have internal physical interfaces (uncertain if nor why it should matter). Hetzner support has verified the public subnet (/29) is routed to the public WAN IP. There are no firewalls etc, just plain routing. (https://wiki.mikrotik.com/wiki/Simple_S ... es_Example etc)

@Chupaka I'm happy to provide you (reputation) with the RouterOS logins / details to the "empty" test installation if you care to test it yourself, as I surely have exhausted all theories on why it shouldn't work.
 
User avatar
Joni
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 77
Joined: Fri Mar 20, 2015 2:46 pm
Contact:

Re: Bare metal CHR on Hetzner Dedicated

Sat Sep 01, 2018 8:37 am

To be specific, even assigning a one additional IP to the ether1-WAN interface doesn't respond to ping, with Linux it works without anything more than
ip address add a.b.c.d/32 dev eth0
 
User avatar
Joni
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 77
Joined: Fri Mar 20, 2015 2:46 pm
Contact:

Re: Bare metal CHR on Hetzner Dedicated

Sat Sep 01, 2018 10:51 am

Exact same issue viewtopic.php?t=114844
and almost same, except I can't ping out... viewtopic.php?t=83196
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8318
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Bare metal CHR on Hetzner Dedicated

Mon Sep 03, 2018 12:46 pm

@Chupaka I'm happy to provide you (reputation) with the RouterOS logins / details to the "empty" test installation if you care to test it yourself, as I surely have exhausted all theories on why it shouldn't work.
Ping me at Skype
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
izumin
just joined
Posts: 3
Joined: Fri Oct 13, 2017 6:09 pm

Re: Bare metal CHR on Hetzner Dedicated

Fri Oct 25, 2019 7:05 pm

Did you anyhow solve the problem?
 
User avatar
Joni
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 77
Joined: Fri Mar 20, 2015 2:46 pm
Contact:

Re: Bare metal CHR on Hetzner Dedicated

Sat Oct 26, 2019 6:40 pm

Did you anyhow solve the problem?
Unfortunately no.
 
User avatar
izumin
just joined
Posts: 3
Joined: Fri Oct 13, 2017 6:09 pm

Re: Bare metal CHR on Hetzner Dedicated

Thu Oct 31, 2019 12:27 pm

its a pity, i have the same problem. Just move with my CHR to hetzner and there is no route(s) that can make it be online. But neighbor VM's is pinging but no hypervisor.
 
User avatar
Joni
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 77
Joined: Fri Mar 20, 2015 2:46 pm
Contact:

Re: Bare metal CHR on Hetzner Dedicated

Thu Oct 31, 2019 6:14 pm

Duh... Forgot to mention that Hetzner Cloud works for CHR...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24267
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Bare metal CHR on Hetzner Dedicated  [SOLVED]

Fri Nov 01, 2019 10:39 am

Yes, Hetzner Cloud works fine like this: https://wiki.mikrotik.com/wiki/Manual:CHR_Hetzner
No answer to your question? How to write posts

Who is online

Users browsing this forum: No registered users and 121 guests