Community discussions

MUM Europe 2020
 
believewireless
Member Candidate
Member Candidate
Topic Author
Posts: 231
Joined: Wed Jul 06, 2005 6:30 pm

OSPF and Default Route

Wed Feb 14, 2007 1:13 am

We have a ring setup with OSPF and we are adding another site that connects to two routers on the ring.
                                     A
                                   /   \
                                 B      C------
                                   \    /        E
                                     D---------
The problem we are having is that router E is getting the default route of C and D, but that route is for another interface and not active in router E.

How do we get the correct default route on router E?
 
User avatar
tneumann
Member
Member
Posts: 394
Joined: Sat Apr 16, 2005 6:38 pm
Location: Germany

Wed Feb 14, 2007 8:56 am

What do you mean by 'is for another interface'? Can you describe it in more detail and maybe post the relevant parts of your config?

--Tom
 
believewireless
Member Candidate
Member Candidate
Topic Author
Posts: 231
Joined: Wed Jul 06, 2005 6:30 pm

Wed Feb 14, 2007 10:25 pm

The router has two interfaces, public and private. The public Interface is the default gateway and the E router is connected via the private interface. The default route the E router is getting is the one connected to the public interface of the C and D routers.

So, A-B-C-D have their public interfaces connected together with /30 subnets. Each router has a /24 on the private interface. Router E is connected via an IP address from the /24 subnet of the C and D routers.

Does that help or do I need to export some configs?
 
User avatar
tneumann
Member
Member
Posts: 394
Joined: Sat Apr 16, 2005 6:38 pm
Location: Germany

Thu Feb 15, 2007 6:47 pm

Some config export would be helpful, so that we can see more about your OSPF areas and how interfaces are assigned to areas etc...

--Tom
 
believewireless
Member Candidate
Member Candidate
Topic Author
Posts: 231
Joined: Wed Jul 06, 2005 6:30 pm

Fri Feb 16, 2007 11:44 pm

Ok, here's what we have for the E router. It's not working.

/routing ospf area
add area-id=0.0.0.0 disabled=no name="backbone" type=default
add area-id=0.0.0.3 disabled=no name="LM" type=default
add area-id=0.0.1.0 disabled=no name="KH" type=default
/routing ospf
set distribute-default=never metric-bgp=0 metric-connected=0 metric-default=1 \
metric-rip=0 metric-static=0 redistribute-bgp=no \
redistribute-connected=as-type-1 redistribute-rip=no \
redistribute-static=no router-id=192.168.35.161
/routing ospf interface
add authentication=none authentication-key="" cost=10 dead-interval=40s \
disabled=no hello-interval=10s interface=wlan1 network-type=broadcast \
priority=1 retransmit-interval=5s transmit-delay=1s
add authentication=none authentication-key="" cost=20 dead-interval=40s \
disabled=no hello-interval=10s interface=ether2 network-type=broadcast \
priority=1 retransmit-interval=5s transmit-delay=1s
/routing ospf network
add area="KH" disabled=yes network=192.168.35.160/27
add area="LM" disabled=yes network=172.22.22.0/24
add area="LM" disabled=no network=192.168.33.0/24
add area=backbone disabled=yes network=0.0.0.0/0
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Mon Feb 19, 2007 9:17 am

as i understand, that your network is not that big. it is easier to get used to OSPF if you create your configuration using only one backbone area with 5 routers that should work.

to ensure that everything is working, start that way:

1) set ip addresses on interfaces
2) add networks to OSPF (enabled) that will be redistributed
3) set up redistribution type redistribute static is only set to your roderrouter


if you are creating areas, that imagine it as another AS with border router.

good luck

edit:

while configuring OSPF do not forget to monitor if everything is happening as it should (draw network diagram that you know where everything goes and where it should go. ?(dude comes in handy atm)

Who is online

Users browsing this forum: codebreaker, mbovenka, sjafka and 74 guests