Page 1 of 1

CRS112-8P-4S Invalid VLAN v6.43

Posted: Fri Sep 14, 2018 7:48 pm
by plankanater
I have set up a CRS112 with vlans using the switch menu. I am trying to then turn off "Forward Invalid VLAN" so that vlan 1 will no longer work through the bridge. I uncheck the box and hit apply and it responds with "Couldn't change Switch Settings - cpu flow control not supported (6)" This is the same setup i have used on other switches and it works perfectly. Is there a bug in the winbox?

Thanks,

Re: CRS112-8P-4S Invalid VLAN v6.43

Posted: Fri Sep 14, 2018 9:53 pm
by plankanater
This appears to be an issue with the new firmware. Exported my config and put it on a 6.42 router and it worked and let me turn off the foward invalid. I then updated to 6.43, the box was still unchecked. After trying to recheck the box it gives me the same error. "Couldn't change Switch Settings - cpu flow control not supported (6)"

Even tried terminal

[admin@Horseshoe Tower Switch] > interface ethernet switch set forward-unknown-vlan=yes
failure: cpu flow control not supported
[admin@Horseshoe Tower Switch] > interface ethernet switch set forward-unknown-vlan=no
failure: cpu flow control not supported

Re: CRS112-8P-4S Invalid VLAN v6.43

Posted: Fri Sep 14, 2018 9:59 pm
by plankanater
Ok so i defaulted the switch running 6.43 and it let me enable and disable the forward invalid vlans. so it must be something in the config.

interface ethernet
set [ find default-name=ether1 ] name="1 - N 5.2" speed=100Mbps
set [ find default-name=ether2 ] name="2 - East 5.2" speed=100Mbps
set [ find default-name=ether3 ] name="3 - S 5.2" speed=100Mbps
set [ find default-name=ether4 ] name="4 - West 5.2" speed=100Mbps
set [ find default-name=ether5 ] name="5 - North 2.4" speed=100Mbps
set [ find default-name=ether6 ] name="6 - SE 2.4" speed=100Mbps
set [ find default-name=ether7 ] name="7 - " speed=100Mbps
set [ find default-name=ether8 ] name="8 - Power Ping" speed=100Mbps
set [ find default-name=sfp9 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full name="sfp 9 - "
set [ find default-name=sfp10 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full name="sfp10 - "
set [ find default-name=sfp11 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
set [ find default-name=sfp12 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full name="sfp12 - Tower Router"
/interface bridge
add admin-mac=64:D1:54:FA:2D:4A auto-mac=no comment=defconf name=bridge
/interface vlan
add interface=bridge name=vlan655 vlan-id=655
/interface list
add name=Discovery
/interface bridge port
add bridge=bridge comment=defconf interface="1 - N 5.2"
add bridge=bridge comment=defconf interface="2 - East 5.2"
add bridge=bridge comment=defconf interface="3 - S 5.2"
add bridge=bridge comment=defconf interface="4 - West 5.2"
add bridge=bridge comment=defconf interface="5 - North 2.4"
add bridge=bridge comment=defconf interface="6 - SE 2.4"
add bridge=bridge comment=defconf interface="7 - "
add bridge=bridge comment=defconf interface="8 - Power Ping"
add bridge=bridge comment=defconf interface="sfp 9 - "
add bridge=bridge comment=defconf interface="sfp10 - "
add bridge=bridge comment=defconf interface=sfp11
add bridge=bridge comment=defconf interface="sfp12 - Tower Router"
/ip neighbor discovery-settings
set discover-interface-list=all
/interface ethernet switch egress-vlan-tag
add tagged-ports="switch1-cpu,1 - N 5.2,2 - East 5.2,3 - S 5.2,4 - West 5.2,5 - North 2.4,6 - SE 2.4,sfp12 - Tower Router" vlan-id=655
add tagged-ports="1 - N 5.2,2 - East 5.2,3 - S 5.2,4 - West 5.2,5 - North 2.4,6 - SE 2.4,sfp12 - Tower Router" vlan-id=855
add tagged-ports="1 - N 5.2,2 - East 5.2,3 - S 5.2,4 - West 5.2,5 - North 2.4,6 - SE 2.4,sfp12 - Tower Router" vlan-id=455
/interface ethernet switch egress-vlan-translation
add customer-vlan-format=untagged-or-tagged new-customer-vid=655 ports="8 - Power Ping" service-vlan-format=untagged-or-tagged
/interface ethernet switch ingress-vlan-translation
add new-customer-vid=655 ports="8 - Power Ping"
/interface ethernet switch port
set 0 isolation-leakage-profile-override=1
set 1 isolation-leakage-profile-override=1
set 2 isolation-leakage-profile-override=1
set 3 isolation-leakage-profile-override=1
set 4 isolation-leakage-profile-override=1
set 5 isolation-leakage-profile-override=1
set 6 isolation-leakage-profile-override=0
set 7 isolation-leakage-profile-override=0
set 11 isolation-leakage-profile-override=0
/interface ethernet switch port-isolation
add port-profile=1 ports="8 - Power Ping,sfp12 - Tower Router" type=dst
/interface ethernet switch vlan
add ports="switch1-cpu,1 - N 5.2,2 - East 5.2,3 - S 5.2,4 - West 5.2,5 - North 2.4,6 - SE 2.4,8 - Power Ping,sfp12 - Tower Router" vlan-id=655
add ports="1 - N 5.2,2 - East 5.2,3 - S 5.2,4 - West 5.2,5 - North 2.4,6 - SE 2.4,sfp12 - Tower Router" vlan-id=855
add ports="1 - N 5.2,2 - East 5.2,3 - S 5.2,4 - West 5.2,5 - North 2.4,6 - SE 2.4,sfp12 - Tower Router" vlan-id=455
/interface list member
add interface="sfp12 - Tower Router" list=Discovery
/ip address
add address=10.50.55.9/24 comment=defconf interface=vlan655 network=10.50.55.0
/ip route
add distance=1 gateway=10.50.55.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh address=69.58.115.252/32
set api disabled=yes
set winbox address=69.58.112.0/20
set api-ssl disabled=yes
/system clock
set time-zone-name=America/New_York
/system identity
set name="Horseshoe Tower Switch"
/system logging
set 0 action=disk
set 1 action=disk
set 2 action=disk
set 3 action=disk
/system ntp client
set enabled=yes primary-ntp=69.58.116.222
/system routerboard settings
set silent-boot=no

Re: CRS112-8P-4S Invalid VLAN v6.43  [SOLVED]

Posted: Mon Sep 17, 2018 1:25 pm
by jayd2k
Known bug. Duplicate of viewtopic.php?t=139148.

Re: CRS112-8P-4S Invalid VLAN v6.43

Posted: Thu Sep 20, 2018 6:26 pm
by plankanater
It seems to be fixed in 6.43.3