Community discussions

MikroTik App
 
ithierack
just joined
Topic Author
Posts: 9
Joined: Sat Mar 05, 2016 1:17 pm

Wrong "Last Link Down Time" in Winbox

Tue Sep 18, 2018 11:46 am

did not know exactly when this happens. But in WinBox, the "Last Link Down Time" is displayed wrong. It is correct displayed in the Web-Interface.
It display some time in the future, it looks like starttime of WinBox + 30 hours. Uptime itself is correct.

See screenshot.
screen_winbox20180918.jpg
Does anyone else see this? Would be nice to get the correct value here, so i don't need to grep the info out of the logfiles if i need this.

Router is an CCR1009-8g-1S-1S+ with latest 6.43. But i saw this also in latest 6.42.
You do not have the required permissions to view the files attached to this post.
 
DummyPLUG
Frequent Visitor
Frequent Visitor
Posts: 79
Joined: Wed Jan 03, 2018 10:17 am

Re: Wrong "Last Link Down Time" in Winbox

Sun Sep 23, 2018 2:52 pm

Happen to my CCr1009-7G too, everywhere is correct except in winbox, beside link down time the "last link up time" will sometime display the current time instead of the correct one
 
doukas
just joined
Posts: 2
Joined: Wed Sep 26, 2018 3:35 pm

Re: Wrong "Last Link Down Time" in Winbox

Wed Sep 26, 2018 4:04 pm

Happen to my CCr1009-7G too, everywhere is correct except in winbox, beside link down time the "last link up time" will sometime display the current time instead of the correct one[/u]
The same problem in my RB3011UiAS after upgrade to v6.43. Any solution??
Thanks in advance!
 
stoser
Member Candidate
Member Candidate
Posts: 120
Joined: Sun Aug 21, 2016 12:04 am

Re: Wrong "Last Link Down Time" in Winbox

Thu Sep 27, 2018 6:59 pm

I am also having this problem, on RouterBOARD 3011UiAS, running 6.40.9, Firmware 3.41 However I do not believe that this has to do with upgrade version or firmware. I believe that it is the newer versions of winbox.

Winbox 3.11 connected to the same router shows CORRECT dates in "last link up time" and "last link down time"

Winbox 3.17 shows incorrect dates, specifically about 18 hours in the future.

Winbox 3.18 shows incorrect dates as well.
 
stoser
Member Candidate
Member Candidate
Posts: 120
Joined: Sun Aug 21, 2016 12:04 am

Re: Wrong "Last Link Down Time" in Winbox

Fri Sep 28, 2018 2:45 pm

I can confirm that this occurs on the following routers using Winbox 3.17 AND Winbox 3.18.
Note: The strange date behavior is NOT occurring with winbox 3.11, on the versions that it can connect to (pre 6.43).

3011UiAS, running 6.40.9, Firmware 3.41
Power Box Pro (960PGS) running 6.42.7
750UP running 6.42.7
Power Box 750P r2 running 6.43
951-2n running 6.43
2011UiAS-2HnD running 6.43 -- This one is weird. The last link uptime of all active interfaces seems always gets set to the time that winbox connected ...

The incorrect dates appear to be random. Each time winbox connects, they may or may not change to dates ranging from a few hours to a few weeks in the future ... That it to say, one cannot simply calculate the true date.

Kind regards, --
 
stoser
Member Candidate
Member Candidate
Posts: 120
Joined: Sun Aug 21, 2016 12:04 am

Re: Wrong "Last Link Down Time" in Winbox

Tue Oct 30, 2018 4:16 am

Bump...

Yesterday I got around to upgrading all of the RBs in my previous post to 6.43.4, and a CRS 326 as well, both firmware and packages. Using both winbox 3.17 and 3.18, the "Last Link uptime" of all active interfaces always gets set to the time that winbox connected ... The last link downtime is always blank.

Six different models of RB, and a CRS, all with the same problem. Does anyone know if the next version of Winbox will address this issue? Does anyone know if there is a workaround?
 
odge
Member Candidate
Member Candidate
Posts: 103
Joined: Mon Nov 29, 2010 2:53 pm

Re: Wrong "Last Link Down Time" in Winbox

Sat Nov 10, 2018 10:35 am

Hi

On Ticket#2018110622004024 I got :
Hello,

Problem is now reported to our development team.

When it will be fixed, then detailed problem description (fix) will be mentioned in RouterOS and/or Winbox changelog.
 
stoser
Member Candidate
Member Candidate
Posts: 120
Joined: Sun Aug 21, 2016 12:04 am

Re: Wrong "Last Link Down Time" in Winbox

Sun Nov 11, 2018 4:55 pm

I reported it as well

Ticket#2018103022005561

Mikrotik support asked me for screenshots and additional details, I gave them screenshots from 3 differnt RBs, and using different versions of Winbox (when possible). Hopefully it will be corrected in the next version of Winbox.
 
Treath1
just joined
Posts: 5
Joined: Sat Mar 19, 2011 4:23 pm
Location: Cape Town South Africa
Contact:

Re: Wrong "Last Link Down Time" in Winbox

Mon Nov 12, 2018 4:54 pm

I am also having this issue with my routers.
I have a CCR1009-8G-1S-1S+ 6.43.2

So strange the dates showing in last link down and uptime are seemingly random. For instance the one I am looking at now is 1 month 5 days ahead.
I checked the system clock on both routers, both are "correct" as in the date and time are accurate, but the interface details are completely wrong.
 
User avatar
jspool
Member
Member
Posts: 423
Joined: Sun Oct 04, 2009 4:06 am
Location: Oregon

Re: Wrong "Last Link Down Time" in Winbox

Fri Nov 30, 2018 5:51 am

I also notice this on some of my VPN clients. Many show "Last Link Up Time" over a month in the future.
 
fuzzbawl
just joined
Posts: 22
Joined: Tue Dec 21, 2010 8:41 pm

Re: Wrong "Last Link Down Time" in Winbox

Wed Jan 09, 2019 9:02 pm

I was able to resolve this on our workstations, it seems to be a difference in how Winbox is writing session files. If you delete the "%userprofile%\appdata\roaming\mikrotik\winbox\sessions" directory, then it all works fine again and correct link down dates are shown. We've confirmed that on two different computers and so far, so good!
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1880
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Randburg
Contact:

Re: Wrong "Last Link Down Time" in Winbox

Sat Jan 12, 2019 9:17 pm

I was able to resolve this on our workstations, it seems to be a difference in how Winbox is writing session files. If you delete the "%userprofile%\appdata\roaming\mikrotik\winbox\sessions" directory, then it all works fine again and correct link down dates are shown. We've confirmed that on two different computers and so far, so good!
Thank you, will try this next time
MTCNA, MTCTCE, MTCRE & MTCINE
 
stoser
Member Candidate
Member Candidate
Posts: 120
Joined: Sun Aug 21, 2016 12:04 am

Re: Wrong "Last Link Down Time" in Winbox

Sun Jan 13, 2019 5:42 pm

I was able to resolve this on our workstations, it seems to be a difference in how Winbox is writing session files. If you delete the "%userprofile%\appdata\roaming\mikrotik\winbox\sessions" directory, then it all works fine again and correct link down dates are shown. We've confirmed that on two different computers and so far, so good!
I confirm that this works, but only for the first time that winbox is used after the session files are deleted. Once the session data is rewritten by winbox, the next time winbox is opened for that RB, the same problem appears. This may be useful information for the Mikrotik developers, but it's not a usefull workaraound, especially since the session data contains all of the winbox column formatting that I am sure we all painstakingly work on ... I would rather use the terminal to see one erroneous data point, that to lose all of my other winbox formatting ...
 
rzirzi
Member
Member
Posts: 393
Joined: Mon Oct 09, 2006 2:33 pm

Re: Wrong "Last Link Down Time" in Winbox

Sun Feb 17, 2019 11:35 pm

I confirm that this works, but only for the first time that winbox is used after the session files are deleted. Once the session data is rewritten by winbox, the next time winbox is opened for that RB, the same problem appears. This may be useful information for the Mikrotik developers, but it's not a usefull workaraound, especially since the session data contains all of the winbox column formatting that I am sure we all painstakingly work on ... I would rather use the terminal to see one erroneous data point, that to lose all of my other winbox formatting ...
I can confirm that too. The same problem, and deleting sessions files works ONLY for the first time. Next login with Winbox - shows the wrong "Last Link Down Time" - there is a logon date and time!
MikroTik team - please repair that problem.
 
User avatar
Cha0s
Forum Guru
Forum Guru
Posts: 1026
Joined: Tue Oct 11, 2005 4:53 pm

Re: Wrong "Last Link Down Time" in Winbox

Mon Feb 18, 2019 12:05 am

I confirm the problem.
 
mongobongo
newbie
Posts: 27
Joined: Fri Jul 28, 2017 5:13 pm

Re: Wrong "Last Link Down Time" in Winbox

Fri Mar 29, 2019 3:13 pm

Same here!
RouterOS: 6.44.1
WinBox: 3.17
 
paulct
Member
Member
Posts: 326
Joined: Fri Jul 12, 2013 5:38 pm

Re: Wrong "Last Link Down Time" in Winbox

Fri Mar 29, 2019 4:30 pm

same here, a real issue when you to need to prove something.
 
AlexAfanasyev
just joined
Posts: 1
Joined: Mon Feb 11, 2019 12:30 am

Re: Wrong "Last Link Down Time" in Winbox

Thu May 02, 2019 6:24 pm

1y passed. Problem still not resolved :(
RB3011UiAS
ROS 6.44.3 (latest "stable")
 
dbai
just joined
Posts: 15
Joined: Mon Mar 16, 2009 1:22 am
Location: Prague, Czech Republic

Re: Wrong "Last Link Down Time" in Winbox

Wed Apr 15, 2020 10:39 am

Problem persists.
CCR1036-12G-4S
ROS v6,46,5
WinBox v3.22 (64bit)
 
urnash
just joined
Posts: 1
Joined: Sun Apr 05, 2020 6:38 pm

Re: Wrong "Last Link Down Time" in Winbox

Fri Apr 17, 2020 2:20 pm

Проблема до сих пор не решена!!!
The problem is still not resolved !!!

Есть обходной путь решения проблемы, надо переименовать папку сессии, зайти в винбокс и авторизоваться на роутере, закрыть винбокс, удалить новую созданную папку сессии, старую переименовать обратно.
Теперь все работает, но не знаю на сколько долго...
Last edited by urnash on Fri Apr 17, 2020 2:25 pm, edited 1 time in total.
 
maxsaf
Frequent Visitor
Frequent Visitor
Posts: 71
Joined: Tue Mar 06, 2018 8:47 pm

Re: Wrong "Last Link Down Time" in Winbox

Tue Jun 23, 2020 7:08 pm

Присоединяюсь к вопросу, имею ту же проблему
I have the same issue
 
anishpsla
newbie
Posts: 38
Joined: Mon Aug 25, 2014 9:16 am

Re: Wrong "Last Link Down Time" in Winbox

Sat Jun 27, 2020 9:26 pm

Problem still persist. Please clear it as soon as possible.
 
stoser
Member Candidate
Member Candidate
Posts: 120
Joined: Sun Aug 21, 2016 12:04 am

Re: Wrong "Last Link Down Time" in Winbox

Wed Aug 05, 2020 2:23 pm

In the change log for Version 6.47 (2020-Jun-02 07:38) it states:

*) winbox - fixed dates and times in interface link up/down properties (WinBox v3.24 required);

So ... Supposedly this should be fixed. I have not tested yet because I only use "long term" versions in production routers, whereas 6.47.1 is still only a "stable" version.. But if anyone has time to test this out, please post if the problem was fixed. Kind regards -
 
doukas
just joined
Posts: 2
Joined: Wed Sep 26, 2018 3:35 pm

Re: Wrong "Last Link Down Time" in Winbox

Wed Nov 18, 2020 9:59 pm

upgrade winbox to v3.27 and the problem solved !!!
 
stoser
Member Candidate
Member Candidate
Posts: 120
Joined: Sun Aug 21, 2016 12:04 am

Re: Wrong "Last Link Down Time" in Winbox

Wed Nov 18, 2020 11:48 pm

@doukas, what FW version are you using?

Who is online

Users browsing this forum: No registered users and 174 guests