Community discussions

 
irghost
Member Candidate
Member Candidate
Topic Author
Posts: 281
Joined: Sun Feb 21, 2016 1:49 pm

EoIP Tunnel not running?

Thu Sep 27, 2018 6:28 pm

Hi
I have 2 CHR (one on KVM and the other on ESXi) with EoIP tunnel in between
on First CHR (KVM ) everything was OK until today, EoIP tunnel stop working

First CHR(KVM ) Version 6.43.2

Image


Sec CHR (ESXi) 6.42.7
Image
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
User avatar
Anumrak
Forum Guru
Forum Guru
Posts: 1051
Joined: Fri Jul 28, 2017 2:53 pm

Re: EoIP Tunnel not running?

Fri Sep 28, 2018 4:34 pm

Try to upgrade to same as KVM CHR ROS version and set tunnel id 1. Also check logs and sock proxy for strange stuff.
 
irghost
Member Candidate
Member Candidate
Topic Author
Posts: 281
Joined: Sun Feb 21, 2016 1:49 pm

Re: EoIP Tunnel not running?

Sat Sep 29, 2018 12:25 am

Try to upgrade to same as KVM CHR ROS version and set tunnel id 1. Also check logs and sock proxy for strange stuff.
nothing.

they are same version
still not working
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
sindy
Forum Guru
Forum Guru
Posts: 4009
Joined: Mon Dec 04, 2017 9:19 pm

Re: EoIP Tunnel not running?

Sat Sep 29, 2018 11:38 am

Stupid question - do you have only the EoIP tunnel between the two CHRs or also a GRE tunnel?
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
User avatar
ingdaka
Member Candidate
Member Candidate
Posts: 183
Joined: Thu Aug 30, 2012 3:06 pm
Location: Albania
Contact:

Re: EoIP Tunnel not running?

Sat Sep 29, 2018 9:30 pm

Please check logs and ave you tried to ping routers if they can reach each-other?
Ilir Daka
Electronic & Network Engineer
E-mail: ilirdaka@live.com
Mob: +355692982151
WhatsApp: +355692982151
Mikrotik Official Consultant
CCNA | Fortinet NSE3 | MTCRE | MTCSE
 
irghost
Member Candidate
Member Candidate
Topic Author
Posts: 281
Joined: Sun Feb 21, 2016 1:49 pm

Re: EoIP Tunnel not running?

Sun Sep 30, 2018 12:27 am

Please check logs and ave you tried to ping routers if they can reach each-other?
they can ping each other with their public IP
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
User avatar
Anumrak
Forum Guru
Forum Guru
Posts: 1051
Joined: Fri Jul 28, 2017 2:53 pm

Re: EoIP Tunnel not running?

Mon Oct 01, 2018 3:28 pm

And with 1500 mtu?

P.S.: Try to use this macs range for both sides 00:00:5E:80:00:00 - 00:00:5E:FF:FF:FF
 
misucatinas
just joined
Posts: 24
Joined: Thu Mar 01, 2018 9:11 am

Re: EoIP Tunnel not running?

Wed Sep 18, 2019 9:47 am

I have the same of problem, how to solve it?
Thank you!

L.E.: I added GRE in firewall and it`s works!
 
sindy
Forum Guru
Forum Guru
Posts: 4009
Joined: Mon Dec 04, 2017 9:19 pm

Re: EoIP Tunnel not running?

Wed Sep 18, 2019 10:22 am

I added GRE in firewall and it`s works!
The reason is that EoIP is one of possible applications using GRE as transport. The very idea of GRE is to allow tunneling different types of payload (G = generic). So what we are used to call a GRE tunnel is actually an "IP over GRE" one, whilst EoIP is an "Ethernet over GRE" one.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
ShaMAD
just joined
Posts: 2
Joined: Tue Oct 08, 2019 4:12 pm

Re: EoIP Tunnel not running?

Tue Oct 08, 2019 4:21 pm

I have the same problem, in my case GRE traffic was filtered by the first rule, which resets the "invalid" connection state input chain.
As soon as I disabled this rule, the GRE traffic flow as usual, I could not understand what was the matter.
But as soon as I turned on the PPTP service port, GRE traffic was no longer dumped as invalid.
The problem is that the PPTP service port has been disabled for more than a year and everything worked fine, but after updating 6.45.6 it stopped working and rolling back to 6.45.3 did not return this functionality
 
ShaMAD
just joined
Posts: 2
Joined: Tue Oct 08, 2019 4:12 pm

Re: EoIP Tunnel not running?

Fri Oct 11, 2019 5:04 pm

The PPTP service must be enabled, otherwise GRE traffic may be filtered input chain by an Drop invalid connection state rule.
This problem appeared after the update on one of my devices, PPTP was turned off, after disabling drop rule GRE start work, and after enabling PPTP service GRE no more dropped as invalid

Who is online

Users browsing this forum: Google [Bot] and 69 guests