Community discussions

MUM Europe 2020
 
afamnu
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Sun Sep 03, 2006 9:52 am

i guess no 1 can :)

Tue Feb 20, 2007 8:24 am

hello all freinds
i have MK 2.9.40, how to make the ICMP packets unlimited , i mean imake limit for each user and client have so much load so its normal when ping the server the ms well be high,any body knows how i can unlimited the icmp on server
 
afamnu
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Sun Sep 03, 2006 9:52 am

Tue Feb 20, 2007 8:45 am

:s no oneeeeeeeee
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24417
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Tue Feb 20, 2007 8:53 am

easy. it's called mangle. look in the manual
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Tue Feb 20, 2007 10:05 am

indeed it is easy if you look at manual, and only person here that actually reads it is you, normis :lol:
 
afamnu
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Sun Sep 03, 2006 9:52 am

Fri Feb 23, 2007 12:22 am

ok guys , i know mangle , but how i can do this , what's the rule
 
firebat
Member
Member
Posts: 390
Joined: Mon Apr 11, 2005 8:38 am

Fri Feb 23, 2007 8:05 am

Why not mangle packets and mark icmp packets with "icmp". Then add a queue with sufficient priority and use the packet mark of "icmp" for the queue.
 
afamnu
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Sun Sep 03, 2006 9:52 am

Fri Feb 23, 2007 9:58 am

i already did that , but not working ,, plz any one can put this rule ..
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6621
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Fri Feb 23, 2007 10:15 am

Queues and mangle are working fine, when correct configuration is used.
There is no other opportunity except this,
- create two mangle rules for each user, first rule to mark ICMP traffic (protocol=icmp), second rule to mark other traffic;
- create two queue rules for each user, one for ICMP traffic without limit-at and max-limit configuration, second for other traffic.
 
afamnu
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Sun Sep 03, 2006 9:52 am

Fri Feb 23, 2007 12:59 pm

i also did that but its not workss ,
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6621
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Fri Feb 23, 2007 1:06 pm

It works fine for me.
Post your mangle export and used queue export.
 
afamnu
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Sun Sep 03, 2006 9:52 am

Fri Feb 23, 2007 1:12 pm

if its works with u can u show me how plz.? and how u did that
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6621
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Fri Feb 23, 2007 1:15 pm

Could you post export from your routers ?
It would be useful to see, why mangle and queues do not work in your case.
 
afamnu
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Sun Sep 03, 2006 9:52 am

Fri Feb 23, 2007 1:20 pm

0 chain=forward src-address=217.65.150.0/24 protocol=icmp action=mark-packet
new-packet-mark=ICMP passthrough=yes

1 chain=input src-address=217.65.150.0/24 protocol=icmp action=mark-packet
new-packet-mark=ICMP passthrough=yes that's it and in queue rules i did that also
name="ICMP" target-addresses=217.65.150.0/24 dst-address=0.0.0.0
interface=End-Users parent=none packet-marks=ICMP direction=both
priority=8 queue=default-small/default-small limit-at=0/0
max-limit=256000/1024000 total-queue=default-small

So :)
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6621
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Fri Feb 23, 2007 1:32 pm

Use 'interface=all' for 'queue simple' configuration, where are the traffic limit for other traffic (not ICMP) ?
 
afamnu
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Sun Sep 03, 2006 9:52 am

Fri Feb 23, 2007 1:37 pm

i used all before , but as much as i tryed i lost my mind :s
can u show me how u did that , i also tryed that kind of rule to MSN for port 1863 to make all my customers open without any limit queue but also still not working , can u show me how u did that ,,??
 
afamnu
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Sun Sep 03, 2006 9:52 am

Sat Feb 24, 2007 7:24 am

thank u all but still it snt work,,:S
 
User avatar
mneumark
Member
Member
Posts: 375
Joined: Thu Jun 08, 2006 7:20 am
Location: Escalon, CA
Contact:

Sat Feb 24, 2007 9:55 am

MSN also uses port 80.
 
User avatar
GWISA
Member
Member
Posts: 394
Joined: Tue Jan 31, 2006 2:37 pm
Location: Johannesburg, South Africa

Sat Feb 24, 2007 10:53 am

Priority=8 is your problem - you've set ICMP for lowest priority...
 
afamnu
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Sun Sep 03, 2006 9:52 am

Sat Feb 24, 2007 1:45 pm

can any body give me the right rule to try it ...??
 
User avatar
GWISA
Member
Member
Posts: 394
Joined: Tue Jan 31, 2006 2:37 pm
Location: Johannesburg, South Africa

Sat Feb 24, 2007 6:50 pm

try this:
/ ip firewall mangle 
add chain=prerouting protocol=icmp action=mark-packet \
    new-packet-mark=icmp-flow passthrough=no comment="ICMP" disabled=no 
add chain=prerouting protocol=!icmp action=mark-packet \
    new-packet-mark=non-ICMP passthrough=no comment="Non-ICMP" disabled=no 

/ queue simple 
add name="ICMP" dst-address=0.0.0.0/0 interface=all parent=none \
    packet-marks=icmp-flow direction=both priority=1
add name="Non-ICMP" dst-address=0.0.0.0/0 interface=all parent=none \
    packet-marks=non-ICMP direction=both priority=8
You can split this up into 2 seperate up/down trees and specify your up/down interfaces.
 
afamnu
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Sun Sep 03, 2006 9:52 am

Sun Feb 25, 2007 12:10 am

GWISA
thank u mannnnnnnn (y) :)

Who is online

Users browsing this forum: Kindis, philipaps and 140 guests