Community discussions

 
andersa
just joined
Topic Author
Posts: 11
Joined: Sat Dec 19, 2015 2:29 pm

Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Thu Nov 15, 2018 6:47 pm

Hi

I am running 17 CRS328-24P-4S+ connected to 2 CRS317-1G-16S+ using this SFP S+32LC10D. The 328 boxes are running RouterOS 6.43.2 and the CRS317 boxes are running 6.43.4. I am experiencing that all the ports on the CRS317 are going up and down with anything between minutes to hours apart. It is almost no traffic on the network. I am totally in the dark here, do any of you have any idea what this could be?

Example from log:
17:02:12 interface,info sfp-sfpplus2 link down
17:04:07 interface,info sfp-sfpplus2 link up (speed 10G, full duplex)
17:09:04 interface,info sfp-sfpplus8 link down
17:09:05 interface,info sfp-sfpplus8 link up (speed 10G, full duplex)
17:18:00 interface,info sfp-sfpplus3 link down
17:18:01 interface,info sfp-sfpplus3 link up (speed 10G, full duplex)
17:24:13 interface,info sfp-sfpplus4 link down
17:24:15 interface,info sfp-sfpplus4 link up (speed 10G, full duplex)
17:25:04 interface,info sfp-sfpplus16 link down
17:25:05 interface,info sfp-sfpplus16 link up (speed 10G, full duplex)
17:34:00 interface,info sfp-sfpplus4 link down
17:34:01 interface,info sfp-sfpplus4 link up (speed 10G, full duplex)

Interface stats from one of the CRS328:
/interface ethernet print stats from=sfp-sfpplus2
name: sfp-sfpplus2
driver-rx-byte: 4 096 343 318
driver-rx-packet: 44 864 695
driver-tx-byte: 1 460 265 180
driver-tx-packet: 9 040 331
rx-bytes: 4 277 853 088
rx-too-short: 0
rx-too-long: 0
rx-unicast: 9 695 367
rx-broadcast: 31 908 257
rx-pause: 0
rx-multicast: 3 273 516
rx-error-events: 239
rx-fcs-error: 0
rx-fragment: 0
rx-overflow: 0
rx-jabber: 0
tx-bytes: 1 498 564 543
tx-unicast: 9 049 910
tx-broadcast: 231
tx-pause: 0
tx-multicast: 4 463
tx-underrun: 0
tx-collision: 0
tx-late-collision: 0
tx-rx-64: 31 287 843
tx-rx-65-127: 4 828 178
tx-rx-128-255: 17 182 394
tx-rx-256-511: 179 280
tx-rx-512-1023: 436 533
tx-rx-1024-1518: 17 622
tx-queue0-packet: 9 037 205
tx-queue1-packet: 0
tx-queue2-packet: 0
tx-queue3-packet: 0
tx-queue4-packet: 0
tx-queue5-packet: 0
tx-queue6-packet: 0
tx-queue7-packet: 0
 
keefe007
Member Candidate
Member Candidate
Posts: 119
Joined: Sun Jun 25, 2006 3:01 am

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Tue Dec 04, 2018 9:19 pm

Try 6.43.7 and make sure routerboot is also updated.
 
andersa
just joined
Topic Author
Posts: 11
Joined: Sat Dec 19, 2015 2:29 pm

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Tue Dec 04, 2018 10:38 pm

Sure, i dont see anything about the 317s in the changelog, but i'll try. Will give a new status in about 24h, will see if anything has changed.
 
andersa
just joined
Topic Author
Posts: 11
Joined: Sat Dec 19, 2015 2:29 pm

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Wed Dec 05, 2018 9:30 am

Try 6.43.7 and make sure routerboot is also updated.
Sad to say, but this made no difference.
 
keefe007
Member Candidate
Member Candidate
Posts: 119
Joined: Sun Jun 25, 2006 3:01 am

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Wed Dec 05, 2018 4:30 pm

I am also seeing some link downs on CRS328 switches but the firmware update made them significantly less for me.
 
keefe007
Member Candidate
Member Candidate
Posts: 119
Joined: Sun Jun 25, 2006 3:01 am

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Mon Dec 10, 2018 10:01 pm

Did you find a fix yet?
 
andersa
just joined
Topic Author
Posts: 11
Joined: Sat Dec 19, 2015 2:29 pm

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Tue Dec 11, 2018 9:47 am

Unfortunately not. I sendt them the support files at 22. Nov and did a follow up on 4. Des. Still no reply. Would be great if MT would have a look at this.
 
mducharme
Trainer
Trainer
Posts: 714
Joined: Tue Jul 19, 2016 6:45 pm

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Tue Dec 11, 2018 10:59 am

From the MikroTik site it looks to me like the S+32LC10D is specifically meant to have the S+23LC10D module on the other end. Are you using the same module on both ends?
 
Elliot
newbie
Posts: 43
Joined: Tue May 30, 2017 3:04 pm

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Tue Dec 11, 2018 11:21 am

I have the SAME EXACT problem. Mikrotik needs to fix this. No problem with 1Gbps SFP but with OWM SFP+ it's hell. I think this could be combination of software and hardware problem with SFP+ modules.
 
andersa
just joined
Topic Author
Posts: 11
Joined: Sat Dec 19, 2015 2:29 pm

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Tue Dec 11, 2018 11:54 am

I have the SAME EXACT problem. Mikrotik needs to fix this. No problem with 1Gbps SFP but with OWM SFP+ it's hell. I think this could be combination of software and hardware problem with SFP+ modules.
I agree with you assumtion that this is an edge case between the SFP units and the switch. But strangely it only occurs on one of our two CRS317 in the installation.
 
andersa
just joined
Topic Author
Posts: 11
Joined: Sat Dec 19, 2015 2:29 pm

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Tue Dec 11, 2018 11:55 am

From the MikroTik site it looks to me like the S+32LC10D is specifically meant to have the S+23LC10D module on the other end. Are you using the same module on both ends?
I am using the paired SFP+ from Mikrotik S+2332LC10D. So yes.
 
keefe007
Member Candidate
Member Candidate
Posts: 119
Joined: Sun Jun 25, 2006 3:01 am

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Tue Dec 11, 2018 6:51 pm

What's the fix Mikrotik?
 
cowgirl
just joined
Posts: 5
Joined: Tue Dec 18, 2018 12:10 am
Location: South-West-Germany
Contact:

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Sat Dec 22, 2018 6:42 pm

Push - she problem on CRS328 here.... waiting for a fix
 
sff
just joined
Posts: 11
Joined: Fri Aug 13, 2010 5:15 pm

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Sat Dec 22, 2018 6:49 pm

We had this same problem appear on one of our 317s. I am not 100% sure when it started, but it was observed on 6.43.4. The upgrade to 6.43.7 fixed it, but ONLY after I did a full factory reset and reloaded the configuration by hand (it wasn't complex).

We also observed it for a brief time on several of the 328s. Switching from using SFP+1 to SFP+2 for the uplink fixed it.
 
wotoni
just joined
Posts: 16
Joined: Sat Aug 04, 2012 12:13 am

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Fri Dec 28, 2018 6:37 pm

We are experiencing the same thing. Running 6.42.7 with DAC Cable from CRS317 to CRS328-4C-20S-4S+RM.

I had to go to a SFP 1G on both units for the flapping to stop. I had tried SFP+ DAC and SFP+ single mode fiber with the same issue.

We have 8 CRS212 plugged into the CRS317 via DAC Cable with no issue. Only the 328 SFP+ ports appear to have the issue.
 
AVA
just joined
Posts: 15
Joined: Mon Jun 18, 2018 6:19 pm

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Wed Feb 06, 2019 11:21 am

Exactly the same problem here. Links between CRS317 and CRS328-4C-20S-4S+ are flapping. I have 3 pairs of 317 <-> 328 and all have the same problem. I tried different SFP/DAC. The latest firmware (6.43.8) does not help. No problem with 1GbE links....... :(
 
andersa
just joined
Topic Author
Posts: 11
Joined: Sat Dec 19, 2015 2:29 pm

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Wed Feb 06, 2019 1:05 pm

I sendt MT a service dump in november - still no answer. Could i bother you guys that are experiencing the same problem with sending MT an email urging them to have a look at the issue - or at least give some feedback. I am experiencing total radio silence.
 
User avatar
jprietove
Trainer
Trainer
Posts: 51
Joined: Fri Jun 03, 2016 3:00 pm
Location: Cádiz, Spain
Contact:

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Wed Feb 06, 2019 2:52 pm

Are any of you using port ether1 or just sfp-plus ports? If you are, remember that "The new Cloud Router Switch 317-1G-16S+RM is a rack-mountable manageable switch with Layer3 features, it has 16 SFP+ ports for high performance 10GbE connectivity and a 1GbE copper port for management. "
 
andersa
just joined
Topic Author
Posts: 11
Joined: Sat Dec 19, 2015 2:29 pm

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Wed Feb 06, 2019 3:04 pm

Are any of you using port ether1 or just sfp-plus ports? If you are, remember that "The new Cloud Router Switch 317-1G-16S+RM is a rack-mountable manageable switch with Layer3 features, it has 16 SFP+ ports for high performance 10GbE connectivity and a 1GbE copper port for management. "
I can only speak for myself - and i am only using the SFP+ ports.
 
AVA
just joined
Posts: 15
Joined: Mon Jun 18, 2018 6:19 pm

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Wed Feb 06, 2019 4:35 pm

I think the problem is the CRS328. We use the CRS317 as Core with downlinks to different CA devices, some with 1GbE and some with 10GbE. The only affected links are those between CRS317 and CRS328 with 10GbE.
 
sebg
just joined
Posts: 2
Joined: Fri Nov 16, 2018 5:49 pm

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Thu Feb 07, 2019 4:29 pm

exact same issue here, same symptoms, same workaround (force 1G link), it would be great if Mikrotik took this issue seriously...
 
Redmor
Member Candidate
Member Candidate
Posts: 233
Joined: Wed May 31, 2017 7:40 pm
Location: Italy

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Thu Feb 07, 2019 8:20 pm

I ever had bad experiences with CRSs port flapping and I don't use them anymore, both ethernets and SFPs.
Sometimes on CCRs ports go totally down, disabling and enabling them solves the problem.
ImageImage
 
sebg
just joined
Posts: 2
Joined: Fri Nov 16, 2018 5:49 pm

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Fri Feb 08, 2019 9:57 am

Sometimes on CCRs ports go totally down, disabling and enabling them solves the problem.
In production context ? :)
 
AVA
just joined
Posts: 15
Joined: Mon Jun 18, 2018 6:19 pm

Re: Severe port flapping on CRS328-24P-4S+ and CRS317-1G-16S+

Mon Feb 18, 2019 5:08 pm

I've wrote to Mikrotik Support ~2 weeks ago and also our Distributor said he would contact Mikrotik but till now no reaction. :cry:

Who is online

Users browsing this forum: amt, Baidu [Spider] and 35 guests