Community discussions

MikroTik App
 
bokad
Member Candidate
Member Candidate
Topic Author
Posts: 152
Joined: Tue Oct 18, 2005 7:34 pm

Computers with IPV6 installed and MT Hotspot

Thu Mar 01, 2007 5:03 am

Computers with IPV6 installed and MT Hotspot

I had a long standing problem that I've just figured out so I thought I would share with you all.

The problem is that clients with IPV6 installed on their machine could not use my hotspot. They would pull a good IP address from DHCP and could ping IP's all day but when they went to surf they would never get redirected to login and so couldn't use the net. IPV6 was being loaded automatically through windows update and this would periodically "break" several people's computers. I'd say we got at least 2-3 trouble calls per day as a result of this.

The source of the problem is how IPV6 clients do DNS lookups and MT's built in DNS server.

Without IPv6 installed I could ping hotspot.mynetwork.net
But as soon as IPV6 was installed, an attempted ping would result in "Ping request could not find host hotspot.mynetwork.net"

When configuring a hotspot it's common to also configure a DNS name for it for more aesthetic access and to support the use of an SSL certificate for secure logon.
ex. / ip hotspot profile set default dns-name="hotspot.mynetwork.net"

This creates a dynamic entry for the hotspot DNS name in "/ip dns static" and when users go to surf, the MT hotspot will redirect them to that DNS name so they can logon ie. https://hotspot.mynetwork.net/login.cgi or whatever.
When a a non IPv6 enabled client attempted to logon, they would be redirected to "https://hotspot.mynetwork.net/login.cgi", do a DNS A name lookup for "hotspot.mynetwork.net", get the resulting IP from the hotspot DNS server, and load the proper page. IPV6 clients do their initial lookup for a AAAA record. The MT DNS server doesn't know how to answer a request for a AAAA record so it passes the request up to it's parent public DNS server. If the DNS name of your hotspot isn't registered in a public DNS server (and normally, why would you want it to be as it's only significant to the local and probably private IP network) then the client will get an "unknown name" response from the DNS server and never be able to resolve the name of the hotspot and so not load the redirect/logon page.

The fix is to create a public DNS entry for your configured hotspot name. It doesn't even need to be accurate. Your client, seeing that the result of the AAAA record lookup is not an an IPv6 address, will follow it up with an A record lookup, which will be properly answered by the MT DNS server.

http://en.wikipedia.org/wiki/IPv6#IPv6_ ... ame_System

I'm running my hotspot on v2.9.6 so this may not apply to newer versions.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6624
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Thu Mar 01, 2007 3:46 pm

Upgrade your router to 2.9.40 version, as license policy is changed and upgrade for the latest version is possible for every 2.9.x user.
Report back if you will have any problems then.
 
davidw
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Fri Apr 27, 2007 11:11 pm

Re: Computers with IPV6 installed and MT Hotspot

Tue Aug 21, 2007 2:13 pm

Hi I have v2.9.43 installed and have this problem.

Just tried creating the entry in our DNS server to see if this fixes the problem.
 
kanch
newbie
Posts: 41
Joined: Mon Mar 26, 2007 3:41 am
Location: USA/Brazil

Re: Computers with IPV6 installed and MT Hotspot

Wed Aug 22, 2007 6:23 am

any soloution to your problem. I have the same problem
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6624
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: Computers with IPV6 installed and MT Hotspot

Wed Aug 22, 2007 8:30 am

Well, how should IPv6 client work with router that running IPv4 (there is not any support for IPv6 at RouterOS 2.9), as most likely some specific feature for him are necessary like IPv6 routing etc.
 
davidw
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Fri Apr 27, 2007 11:11 pm

Re: Computers with IPV6 installed and MT Hotspot

Wed Aug 22, 2007 8:33 am

sergjs, what do you mean by this comment ?
 
channingzou
Member Candidate
Member Candidate
Posts: 137
Joined: Sun Feb 25, 2007 7:57 am
Location: NC,USA

Re: Computers with IPV6 installed and MT Hotspot

Wed Aug 22, 2007 9:00 am

upgrade to 3.0 there have ipv6 supported
 
davidw
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Fri Apr 27, 2007 11:11 pm

Re: Computers with IPV6 installed and MT Hotspot

Wed Aug 22, 2007 9:44 am

Is Version 3.0 Stable and ready for production environment ?
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6624
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: Computers with IPV6 installed and MT Hotspot

Wed Aug 22, 2007 9:46 am

I mean that 2.9 does not support IPv6 addressing and routing, in other IPv6 host is not able to send any data trough 2.9 router (routing).
 
channingzou
Member Candidate
Member Candidate
Posts: 137
Joined: Sun Feb 25, 2007 7:57 am
Location: NC,USA

Re: Computers with IPV6 installed and MT Hotspot

Wed Aug 22, 2007 5:02 pm

Is Version 3.0 Stable and ready for production environment ?
it just beta, wait for couple months will be ready .do you think IPV6 is now common? so we have time to try it.
 
User avatar
andrewluck
Forum Veteran
Forum Veteran
Posts: 702
Joined: Fri May 28, 2004 9:05 pm
Location: Norfolk, UK

Re: Computers with IPV6 installed and MT Hotspot

Wed Aug 22, 2007 10:07 pm

This problem is also described by Microsoft as this issue affects all Vista clients (skip down to the section heading 'Installed and enabled by default):

http://www.microsoft.com/technet/commun ... g1005.mspx


Regards

Andrew
 
davidw
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Fri Apr 27, 2007 11:11 pm

Re: Computers with IPV6 installed and MT Hotspot

Thu Aug 23, 2007 3:03 am

it just beta, wait for couple months will be ready .do you think IPV6 is now common? so we have time to try it.
We have approximately 55 Hotspots and we are starting to get more and more people report this problem - 2-3 a day - and they are the ones that can be bothered calling.
 
davidw
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Fri Apr 27, 2007 11:11 pm

Re: Computers with IPV6 installed and MT Hotspot

Thu Aug 23, 2007 3:11 am

any soloution to your problem. I have the same problem
Yep I can confirm that adding an entry to the dns server works.
 
User avatar
gustkiller
Member
Member
Posts: 418
Joined: Sat Jan 07, 2006 5:15 am
Location: Brazil
Contact:

Re: Computers with IPV6 installed and MT Hotspot

Sun Sep 23, 2007 8:41 pm

how can i add these ipv6 public aaaa?
 
bushy
Member Candidate
Member Candidate
Posts: 140
Joined: Thu Oct 20, 2005 11:56 pm
Location: Ireland

Re: Computers with IPV6 installed and MT Hotspot

Sun Sep 23, 2007 8:57 pm

Its just the sad windows networking , debian etc just has a poke around and returns something like " no ipv6 routers present will do xxxx" .
It would be nice if someone released a 3rd party replacement for windows networking
 
andreacoppini
Trainer
Trainer
Posts: 489
Joined: Wed Apr 13, 2005 11:51 pm
Location: Malta, Europe

Re: Computers with IPV6 installed and MT Hotspot

Thu Jan 31, 2008 1:53 am

Would this issue still happen if I disable the DNS name of the hotspot? Would clients just get redirected to the IP address?
- No strings attached -

<< Please give good Karma if this post helped you. Press the + button above the Location entry
 
bokad
Member Candidate
Member Candidate
Topic Author
Posts: 152
Joined: Tue Oct 18, 2005 7:34 pm

Re: Computers with IPV6 installed and MT Hotspot

Mon Jan 19, 2009 11:45 pm

Yes, this problem still occurrs in V3 as I've just found out and forgot to create the public DNS entry.

You can also just disable the DNS name for the hotspot with:
/ip hotspot profile set default dns-name=""

v3 may support IPv6 but it's DNS server does not.


Problem only seems to occur with XP clients, not Vista.

Who is online

Users browsing this forum: anav, Bing [Bot], ingdaka, mszru, td32, xvo and 55 guests